Jump to content

formula


Recommended Posts

Tengo la siguiente cuestión:

Como puedo poner la palabra "ERROR" en una celda, cuando la diferencia de por ejemplo Libro1.xlsxLibro1.xlsxLibro1.xlsxLibro1.xlsxentre A1 y A2 es distinta de igual, superior a 0,01 o inferior a 0,01.

Es decir tengo dos celdas A1 y A2, que mientras la diferencia entre ambas no sean mayores de 0,01, en la celda por ejemplo A3 no tendría que salir valor, pero si los valores no son iguales o la diferencia es superior o inferior a 0,01, tendría que salir "ERROR".

Muchas gracias por vuestra paciencia.

Link to comment
Share on other sites

La formula que yo utilizo y que me da error es la siguiente:

=SI(O(A1=A2;A1<>0,01);"";"error".

Si por ejemplo tengo en a1 3026,25 y en a2 3026,24 me da correcto, es decir "".

Pero si tengo en a1 3027 y en a2 3026,24 me sigue saliendo lo mismo, es decir "", cuando tendría que ser "error".

Muchas gracias.

 

Link to comment
Share on other sites

Hola,

Claro. Es que fíjate en la fórmula: SI(O(A1=A2; A1<>0,01 );"";"error"

En la segunda parte, con ese A1<>0,01 estás diciendo que si en la celda A1 hay algo diferente a 0,01 te devuelva "". No estás contando con la diferencia entre A1 y A2, sino sólo con lo que haya en A1.

Y también, para evitar aquello de:

hace 5 horas, FEDERICO TRUJILLANO dijo:

la diferencia de entre A1 y A2 es distinta de igual, superior a 0,01 o inferior a 0,01

te puede ser útil la función =ABS

Saludos,

Link to comment
Share on other sites

hace 16 horas, Victor7 dijo:

Hola,

Claro. Es que fíjate en la fórmula: SI(O(A1=A2; A1<>0,01 );"";"error"

En la segunda parte, con ese A1<>0,01 estás diciendo que si en la celda A1 hay algo diferente a 0,01 te devuelva "". No estás contando con la diferencia entre A1 y A2, sino sólo con lo que haya en A1.

Y también, para evitar aquello de:

te puede ser útil la función =ABS

Saludos,

Efectivamente Victor, estaba escribiendo mal la formula, creo que sería así, pero no me sale:

=SI(O(O(A1=A2;A1-A2=0,01;A1-A2=-0,01;"";"ERROR")))

Lo que necesito es que si la diferencia entre A1 y A2 es igual o con una diferencia de +0,01 o -0,01, la celda salga en blanco, si es mayor de +0,01 o -0,01 dé "ERROR"., pero no soy capaz de dar con la formula.

Muchas gracias por vuestra paciencia.

Link to comment
Share on other sites

Hola @FEDERICO TRUJILLANO (y Víctor)

Prueba con:

=SI(ABS(A1-A2)<=0,01;"";"ERROR")

Con la función ABS verifica la diferencia tanto positiva como negativa. Si los números son iguales, la diferencia también es <0,01 y se cumple la condición.

Un saludo, Fernando

Edited by FGV
Link to comment
Share on other sites

Hola a ambos,

Sólo un  comentario al post de @FGV  Quizá podría ser interesante añadir la función =REDONDEAR a la fórmula, dejándola así:

=SI(REDONDEAR(ABS(A1-A2);2)>0,01;"error";"")

ya que PRECISAMENTE en el archivo adjunto al primer post figuran como cantidades a evaluar 5001,20 y 5001,21. En este caso concreto, y debido a un complejo proceso conocido como aritmética flotante, para Excel la diferencia entre ambas cantidades no es 0,01 sino 0,0100000000002183. Por lo tanto, el resultado de la fórmula sin emplear =REDONDEAR puede llevar a error.

@FEDERICO TRUJILLANO, te recomiendo que investigues sobre ese particular. Es uno de los ¿pocos? dolores de cabeza con los que a veces nos obsequia Excel...

Saludos,

Edited by Victor7
cambio en el texto
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Privacy Policy