Jump to content

total en importar dinamicos


Recommended Posts

Buenas tardes

 

Adjunto un ejemplo con una tabla sencilla de ejemplo para ver si me pueden ayudar.

Tengo una celda con una validación de datos para seleccionar el día que quiero ver sobre unas ventas. Lo tengo hecho con un importar dinámicos y no soy capaz de realizar la fórmula para que me devuelva el total general. El día que señale si me devuelve las ventas, pero no el total. 

 

Adjunto el ejemplo

 

Gracias por vuestra ayuda

 

ejemplo.xlsx

Link to post
Share on other sites

Buenas tardes

 

gracias njnsp por tu ayuda. En principio mi intención es que al seleccionar total general en el desplegable 

barras me salga 98 

chapatas 106

colones 106 

el motivo... porque al lado y debajo de la fórmula de importar dinámicos tengo que seguir formulando y no me interesa hacer campos calculados sobre la dinámica.

 

no de si me he explicado 

 

Gracias de antemano

 

Link to post
Share on other sites

ok, ok, ahora lo he pillado. Pensaba que trabajabas con la tabla dinámica..

Se me ocurre... en vez de usar si.error, porque no usas algo así??

N5:

Cita

=SI(L4=N1;IMPORTARDATOSDINAMICOS("VENTAS";$A$3;"TIPO PAN";"BARRAS");IMPORTARDATOSDINAMICOS("VENTAS";$A$3;"DIA";L4;"TIPO PAN";"BARRAS"))

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Crear macros Excel

  • Posts

    • Buenas tardes Haplox, es justo lo que necesitaba, funciona perfecto. Muchas gracias. Solucionado.
    • Hola a todos, Espero poder explicarme bien. Adjunto archivo y a continuación la explicación. Tengo una gran base de datos de la cual necesito pasar los datos de 2 columnas no contiguas a filas mientras éstos tengan el mismo ID. En el ejemplo, a partir de la columna L (marcado en rojo) pongo intercalado los valores de la columna K y D en la misma fila mientras el ID_FORMULA (columna A) sea igual y siempre en la primera fila del grupo (por grupo me refiero a igual valor en columna A). Aclaro que la cantidad de filas por ID no es fija. Ejemplo.xlsxPuede ser desde 2 filas hasta 7.  En el ejemplo, hay de 3, 5 y 4 filas.  Como son 900.000 filas se me ocurre que lo mejor es hacer un macro pero no sé como o tal vez haya otra forma sin macros.  Agradezco la ayuda. 
    • Yo pienso que si, y desde luego me apoyo en lo que he entendido, pero tu debes estar mas claro, sobre lo que necesitas ¡Suerte!   Saludos
    • Te dejo una solución según lo que explicas. Saludos Copia de Ejemplo.xlsm
    • José Lamento te hayas confundido con el (mal) ejemplo que puse en codigo,,,Cubo es una hoja por cierto y estoy copiando a otra, cuyo nombre está en la variable cractual, colu es un numero de columna al igual que columnacr, pero ---olvida ello y dale una mirada al adjunto por favor ...alli está lo que quiero hacer
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy