Jump to content

total en importar dinamicos


Recommended Posts

Buenas tardes

 

Adjunto un ejemplo con una tabla sencilla de ejemplo para ver si me pueden ayudar.

Tengo una celda con una validación de datos para seleccionar el día que quiero ver sobre unas ventas. Lo tengo hecho con un importar dinámicos y no soy capaz de realizar la fórmula para que me devuelva el total general. El día que señale si me devuelve las ventas, pero no el total. 

 

Adjunto el ejemplo

 

Gracias por vuestra ayuda

 

ejemplo.xlsx

Link to post
Share on other sites

Buenas tardes

 

gracias njnsp por tu ayuda. En principio mi intención es que al seleccionar total general en el desplegable 

barras me salga 98 

chapatas 106

colones 106 

el motivo... porque al lado y debajo de la fórmula de importar dinámicos tengo que seguir formulando y no me interesa hacer campos calculados sobre la dinámica.

 

no de si me he explicado 

 

Gracias de antemano

 

Link to post
Share on other sites

ok, ok, ahora lo he pillado. Pensaba que trabajabas con la tabla dinámica..

Se me ocurre... en vez de usar si.error, porque no usas algo así??

N5:

Cita

=SI(L4=N1;IMPORTARDATOSDINAMICOS("VENTAS";$A$3;"TIPO PAN";"BARRAS");IMPORTARDATOSDINAMICOS("VENTAS";$A$3;"DIA";L4;"TIPO PAN";"BARRAS"))

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Crear macros Excel

  • Posts

    • ¡¡¡¡ El archivo Libro1-1.xlsm
    • Prueba la macro, la solución en BD Solucion2de2, sin pasar por BD Solucion1de2. Sub FillRate() Application.ScreenUpdating = False With Sheets("BD Solución2de2") Sheets("BD").Cells.Copy .Cells .Select For x = 2 To .Range("A" & Rows.Count).End(xlUp).Row If x Mod 500 = 0 Then Application.StatusBar = "Tratando fila " & x If Not .Range("A" & x) = "" Then If .Range("C" & x) > 0 Then Base = "C" & x .Range("I" & x).Formula = "=D" & x & "/" & Base If .Range("I" & x) > 1 Or .Range("I" & x) < 0 Then .Rows(x).Delete x = x - 1 End If End If Next End With Application.StatusBar = False End Sub En la línea de estado de Excel se muestra un pequeño avance del proceso.
    • Un saludo a ambos, aquí te dejo otra opción
    • Private Sub TextBox1_Change() ActiveSheet.Range("C6").Value = TextBox1.Text TextBox3 = Range("C8").Text End Sub Private Sub TextBox2_Change() ActiveSheet.Range("C7").Value = TextBox2.Text TextBox3 = Range("C8").Text End Sub Private Sub CommandButton1_Click() TextBox1 = Empty TextBox2 = Empty TextBox3 = Empty TextBox1.SetFocus End Sub  
    • este es el archivo con userform   Libro1.xlsm
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy