Jump to content

Duda y desesperación por Macro al modificar varias celdas y pegar imagen por dicha modificación


Recommended Posts

He corregido las fórmulas de las columnas G9, G19, G29, G39,......, que a mi modo de ver estaban equivocadas.

Por ejemplo : 

G19=SI(G14>0;SI(G14>G4;G14-G4;SI(G14>G4;G4-G14;SI(G14=G4;0;"")));"")

la he cambiado por:

G19=SI(G14>0;SI(G14>G4;G14-G4;G4-G14);"")

El tema de la pendiente era un problema conceptual por mi parte, al considerar que la subida/bajada era en relación al punto siguiente y no al anterior.  Ahora al ver que la altura inicial va en la celda A8, lo he visto claro, o al menos eso creo.

A ver si es esto.

Has de tener en cuenta que solo se recalcula la representación de la pendiente en la fila que has hecho el cambio.

Solo eliminando las cabeceras intercaladas se podría articular el recalculo hasta el final.

Planificación con AZIMUT y pendiente - copia (1).xlsm

Link to post
Share on other sites

Vamos a intentarlo, pero para poder cerrar el tema anterior, abre un tema nuevo con las explicaciones y vuelve a subir el archivo con el ejemplo que has subido resuelto de forma manual. Estaré atento a tu nueva consulta.

Link to post
Share on other sites
Hace 22 horas, Antoni dijo:

He corregido las fórmulas de las columnas G9, G19, G29, G39,......, que a mi modo de ver estaban equivocadas.

Por ejemplo : 

G19=SI(G14>0;SI(G14>G4;G14-G4;SI(G14>G4;G4-G14;SI(G14=G4;0;"")));"")

la he cambiado por:

G19=SI(G14>0;SI(G14>G4;G14-G4;G4-G14);"")

El tema de la pendiente era un problema conceptual por mi parte, al considerar que la subida/bajada era en relación al punto siguiente y no al anterior.  Ahora al ver que la altura inicial va en la celda A8, lo he visto claro, o al menos eso creo.

A ver si es esto.

Has de tener en cuenta que solo se recalcula la representación de la pendiente en la fila que has hecho el cambio.

Solo eliminando las cabeceras intercaladas se podría articular el recalculo hasta el final.

Planificación con AZIMUT y pendiente - copia (1).xlsm 208.53 kB · 2 descargas

¡¡¡ Perfecto !!!
 

Muchísimas gracias Antoni, funciona a la perfección, justo como había deseado.

Un trabajo incrible, alucinante. Sigo sin entender el código aún estando comentado, pero es lo que tiene no tener ni idea.

Vaya, estoy alucinado, es una pasada. Lo dicho, muchísimos e inestimables agradecimientos.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Posts

    • ¡Hola @pmorales23! Ten en cuenta siempre subir un archivo adjunto Excel que lo que tienes y deseas obtener, para que la ayuda sea más precisa (además son normas del foro) Las columnas en las funciones x.SI(.CONJUNTO) deben tener la misma dimensión y sentido.  Si quieres sumar 4 columnas, puedes usar la función DESREF dentro de la función, así: =SUMA(SUMAR.SI.CONJUNTO(DESREF(Eventos[columna1];;{0\1\2\3});Eventos[columna5];A87;Eventos[Columna6];"Condición2")) ¡Bendiciones!
    • Mil Gracias Isidro, si es justo lo que necesito, mil Gracias, con este hermoso aporte, doy por cerrado el tema.  
    • Buenas noches: Tengo que sumar un rango de 4 columnas y quiero hacerlo usando referencias estructuradas. pero me da erro... me pone Valor hago lo siguiente                                                   Rango de suma               Rango condic 1        Cond 1      Rango cond 2         Cond 2 =Sumar.si.conjunto(Eventos[[columna1]:[Columna4]];Eventos[columna5];"="&A87;Eventos[Columna6];"Condición2") Se que el error está en el rango de la suma.  Gracias
    • Estimados, gracias por la ayuda, ya solucioné mi proyecto , Saludos,
    • Buenas tardes chic@s; Tengo una macro que pone diferentes fórmulas en varias hojas diferentes y para poder ponerlas tengo que antes seleccionar la hoja donde quiero que se ponga. Hay alguna forma de poner la fórmula en la hoja que necesite sin antes seleccionar/activar dicha hoja??. Las fórmulas las pongo de la siguiente forma: Worksheets("Hoja2").Range("A2:A30").FormulaR1C1= "aquí la fórmula" Pd: ahora mismo no tengo aquí el Excel, estoy escribiendo desde el móvil, si es necesario mañana le adjunto. Muchísimas gracias.
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy