Jump to content

Actualizar gráficos


Recommended Posts

Buenas, tengo la siguiente consulta.

Tengo una serie de gráficos que vinculan de un rango de datos, los cuales se van actualizando semana a semana. El problema esque las celdas en las que el vinculo no contiene nada, se muestran en la grafica como 0, lo que queda bastante feo.

Quiero saber si existe alguna macro en la que me cree un grafico eligiendo un rango, y que muestre unicamente donde haya datos introducidos y que cada semana se actualice.. Se que existe algo así, pero no tengo ni idea de como empezar..

Un saludo.

Link to comment
Share on other sites

Hola patosi

Binevenido al foro.

Dices...

"...Se que existe algo así, pero no tengo ni idea de como empezar....."

Yo empezaría por leerme las normas, justo tras eso verás que solemos solicitar un archivo con la problemática que se tiene y con lo que se quiere obtener. Esto último hecho a amno o indicado lo mejor que se pueda. A partir de ahí sólo te quedará esperar a que algún participante te dé la solución adecuada.

En cuanto subas tu archivo moveré el tema al subforo de gráficos.

Un saludo desde Vitoria

Link to comment
Share on other sites

Hola patosi

Revisa el enlace

https://www.ayudaexcel.com/foro/graficos-diagramas-63/solucionado-grafico-selectivo-sin-ceros-16279/

Una pregunta. ¿Quieres que el intervalo con ceros quede sin gráfica o te vale con que se una con el siguiente dato distinto de cero sin pasar por el eje X (en cero evidentemente)? Lo digo por que si es así usando una columna auxiliar =SI(B2=0;NOD();B2) y graficándo esta columna evitarías que los ceros quedaran sobre el eje.

Un saludo desde Vitoria

P.S. Estoy teniendo problemas para subir archivos por eso no te adjunto las pruebas que he hecho

Link to comment
Share on other sites

Gracias por la rapidez. Esa solución es buena lo único que para lo que necesito, seria montar una estructura enorme ya que son mas de 100 gráficos que tiran de 600 columnas por lo que sería tarea de chinos..

Por lo que he leido tengo entendido que en VB existen una serie de propiedades de los gráficos, aplicables a muchos a la vez, por lo que esa solución sería la que necesitaría..

Semana a semana se van actualizando esas columnas y las que aún no tienen valores, salen como 0 en el grafico (ya que tienen vinculos a otras hojas)..

Si se os ocurre algo más..

Saludos.

Link to comment
Share on other sites

Otra solucion que se me ha ocurrido es, cambiar las celdas en las que el vinculo sea 0 por "vacio". He probrado con =SI(VINCULO=0);"";(VINCULO), pero no me funciona, me sigue mostrando el valor 0 en las graficas. He probado con NULL y me muestra #¿NOMBRE?... No hay alguna variable que sea como "VACIO" para que la grafica no coja valor alguno...

Gracias.

Salu2

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

Privacy Policy