Jump to content

Devolver la cifra de la celda contigua elegida previamente de una lista desplegable.


Carrete

Recommended Posts

Que lio!!

Me explico. He creado una lista desplegable mediante una validacion de datos y esta lista coge los datos de la hoja 2 del mismo libro de un numero determinado de celdas en una columna que a su vez la columna siguiente a esta columna tienen datos referentes a la columna anterior y lo que quiero es que la celda siguiente a la lista desplegable me devuelva el valor de la celda siguiente a la celda seleccionada en dicha lista desplegable.

Un lio pero creo que me he explicado bien.

Un saludo y gracias.

Link to comment
Share on other sites

Guest luigi

Hola Mario;

Podrías indicarnos si hay algún inconveniente para realizar esto que se indica en la siguiente imagen y sale cuando se crea un tema?

normasmini.png

Link to comment
Share on other sites

Siento haberme saltado las normas del foro, soy nuevo y aun no estoy muy al tanto de estas. Te adjunto un ejemplo de lo que quiero hacer y te explico. Seguro que es mas sencillo que el ejemplo que me has enviado pero no es lo mismo y no consigo sacar lo que yo quiero. Te explico:

En la hoja 1 la celda A2 he puesto un lista desplegable que me sale los productos que he metido en la hoja 2 en las celdas A2 a la A20 que las he llamado "producto". Cuando por ejemplo elija en la lista desplegable la "pera" quiero que me aparezca en la celda B2 el numero que corresponde a pera que me lo da la lista paralela a la de "producto" que va de la celda B2 a la celda B20 llamada en este caso "unidad" y que esta en la hoja 2.

Espero haberme explicado bien y gracias por la respuestas. Un saludo. Carrete.

Ejemplo desplegable.xls

Link to comment
Share on other sites

Guest luigi

Hola pepe,

Gracias por colaborar en el foro, pero una sugerencia. Las fórmulas y códigos es necesario envolverlas con las etiquetas CODE, PHP o HTML, pero no con las de cita.

Gracias.

Link to comment
Share on other sites

Gracias Pepegoteraspepe, es justo lo que buscaba. Al final me ha tocado alargar la formula para que no me saliera el error. Esta es la formula:

=SI(ESERROR(E5*H4/(BUSCARV(B5;Hoja2!A2:B16;2;FALSO)));"";E5*H4/(BUSCARV(B5;Hoja2!A2:B16;2;FALSO)))[/CODE]

Otra pregunta. Que sentido tiene "FALSO" en la formula?

Un saludo y gracias de nuevo.

Link to comment
Share on other sites

Hola Carrete

Sólo para decirte que no es necesario ese alargamiento de la fórmula que citas en tu post 6, ya que tú tienes Excel 2007 y en esa versión existe la función SI.ERROR con la cual se evita la molesta repetición del contenido condicionante.

Consúltalo en la Ayuda Excel de tu PC.

Saludos a todos

Link to comment
Share on other sites

Otra pregunta. Que sentido tiene "FALSO" en la formula?

En la fórmula juega el mismo papel FALSO que cero (0).

Y le dice a Excel que busque el valor exacto. Si en lugar de FALSO ponemos VERDADERO (o un 1) buscaría el valor más próximo.

También encontrarás información en la ayuda Excel de tu PC.

Un saludo

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

Privacy Policy