Jump to content

sprit36

Members
  • Posts

    149
  • Joined

  • Last visited

Everything posted by sprit36

  1. Buenas tardes Haplox, es justo lo que necesitaba, funciona perfecto. Muchas gracias. Solucionado.
  2. Perdón en el archivo anterior no está bien explicado, adjunto nuevamente el ejemplo. Gracias. Ejemplo.xlsx
  3. Buenos días, necesito con una macro poder comparar dos hojas, extraer un dato y a la vez poder convertir en porcentaje una columna. Adjunto ejemplo. Gracias. Ejemplo.xlsx
  4. Re: Cambiar rangos Teneis que perdonarme por el retraso, he estado algo liado y he tenido poco tiempo para entrar. Gracias a los dos, Un saludo
  5. Re: Cambiar rangos Gracias por la respuesta, he visto el adjunto, pero no entiendo que es lo que debo hacer para que cambie el rango de una formula, por ejemplo tengo esta formula: =SUMAPRODUCTO((Hoja1!$A$2:$A$83)*((Hoja1!$A$2:$A$83) Necesito que me cambie el $A$2 por $A$60 y el $A$83 por $A$130. Que tengo que hacer? Gracias.
  6. Buenas tardes: Tengo una duda, queria saber si es posible en una formula de Excel cambiar los rangos sin tener que editar una a una, por ejemplo en la Columna C tengo formulas desde el 01 al 09 por ejemplo =SUMAPRODUCTO((Hoja1!$A$2:$A$830) los rangos A2 a A830 los cambio constantemente ya que segun el dia que quiera contar estos varian hay alguna forma de seleccionar ese rango C01 al C09 y que cambie a todas las celdas los rangos? Un saludo
  7. Re: Suma por referencia en dos hojas Gracias Sebastian por la respuesta, funciona correctamente.
  8. Re: Suma por referencia en dos hojas Gracias, pero... como indico en esta formula que busque en SS1,SS2y SS3 a la vez? =SUMAPRODUCTO((Hoja2!$B$2:$B$6="SS1")*Hoja2!$C$2:$ C$6*(Hoja2!$F$2:$F$6=E2))
  9. Re: Suma por referencia en dos hojas Gracias Sebastian, en la primera columna funciona perfectamente, donde no me queda muy claro es en la segunda, creo que la formula de la primera esta bien es: =SUMAPRODUCTO((Hoja2!$B$2:$B$6="SS1")*Hoja2!$C$2:$C$6*(Hoja2!$F$2:$F$6=E2)) En donde dice: ="SS1") aqui quizas deberia ser ="SS1" ¨SS2¨¨SS3¨ para que busque esos valores, pero no sé si es posible ya que lo intento y me dá error en la formula. Por otra parte como seria la formula para que buscar la referencia SS1 y que sume los vendidos y pedidos de la tienda 1 por ejemplo. Gracias por el interes mostrado. Un saludo
  10. Re: Suma por referencia en dos hojas Gracias Sebastian por tu respuesta, es exactamente lo que buscaba, lo que olvidé que no se si es posible es que además de buscar por referencia, busque por nº de tienda. adjunto ejemplo. Muchas gracias. vendidonovendidoSSS.zip
  11. Hola a todos: Tengo una duda, adjunto un ejemplo en el cual tengo por un lado en una hoja unos datos, en el ejemplo he puesto unos cuantos pero tengo muchos mas. Necesito una formula que en base a la referencia que es SS1, SS2 y SS3 sume de la Hoja2 el nº de articulos vendidos y por otra parte el nº de articulos no vendidos y pedidos. Gracias. Un saludo Ejemplo1.zip
  12. Muchas gracias a todos, con todas vuestras aportaciones, he conseguido hacerlo, he ido probando una cosa de la respuesta que me dió uno, la sumas de otro y al final creo que ha salido todo bien. muchas gracias a todos los que habeis dado vuestras ideas, con ello he conseguido resolver mis dudas. Muchas gracias. Un saludo
  13. Gracias por la respuesta Toldeman, está bien lo que me has adjuntado, pero creo que según lo voy viendo se me complica mas la cosa, adjunto el archivo con indicaciones mas claras la celda del producto no interesa solo seria la B y la explicación la dejo en el archivo, siento liar tanto esto pero pensaba que se podia hacer como lo expliqué al principio pero cuando me pongo a hacer los calculos me sobran ventas y es por lo que he explicado en el archivo. Un saludo y gracias por tu ayuda. [ATTACH]18757.vB[/ATTACH] Ejemplo1.zip
  14. Muchas gracias German, en principio se ajusta a lo que buscaba, lo que estaba pensando es no busque en la columna A de producto, unicamente que sea la B Zona con las restantes, y lo que he visto que cuando el valor no es 1 es por ejemplo 4, 3 u otro valor, no lo cuenta, necesitaria que cuente todo lo que no sea 0 pero no en suma, sino por ejemplo si en una celda pone: 4 en otra 3 y en otra 1 me aparezca 3 que no lo sume. ¿es posible hacerlo de alguna forma? por lo demás está muy bien hasta con validaciones, muchas gracias. Un saludo
  15. Buenos días, llevo unos dias dando vueltas a unos datos que necesito, he hecho una tabla dinamica pero no obtengo lo que necesito, quizas con una formula pueda obtenerlo, adjunto archivo con explicación. Un saludo. [ATTACH]18746.vB[/ATTACH] LibroSEMANA.zip
  16. Gacias por tu respuesta, funciona perfectamente. Un saludo y muchas gracias por tu ayuda.
  17. Buenos días: Hace un par de días Toldeman me dío la solución a una duda que tenía con una fórmula, la resolvió perfectamente, ahora mi duda es la siguiente, la formula que me dío es: SUMAPRODUCTO((A$2:A$8=A2)*(B$2:B$8=B2)*(C$2:C$8="O K")) Mi duda es: En el rango de la columna B hace referencia a la celda B2 que es donde hay una referencia S11 por ejemplo, pero si quiero que esa referencia busque a varias referencias por ejemplo las S11 y S12 creo que seria así pero no me funciona B2;B4;B6 SUMAPRODUCTO((A$2:A$8=A2)*(B$2:B$8=B2;B4;B6)*(C$2:C$8="O K")) Alguna sugerencia? Gracias, un saludo
  18. Muchas gracias Toldeman, era justo lo que necesitaba. un saludo y muchas gracias por tu ayuda.
  19. Buenas noches: He probado las dos formulas, pero ninguna de las dos tiene en cuenta la columna C que es la que nos interesa extraer los datos, unicamente compara la columna A con la B, en este caso necesitaria que compare las tres columnas. Un saludo y gracias por el interés mostrado.
  20. Buenas tardes: Necesito que comparando la columna a con la B me diga cuantas veces está Ok en numero, 1,2,3... 8 etc. Gracias, un saludo [ATTACH]18515.vB[/ATTACH] Libro2B.zip
  21. Muchas gracias a todos, Tuve el archivo que me adjuntaste con la validación en lista es perfecto, muchas gracias tambien a Julibaga y Luis por vuestra ayuda. un saludo.
  22. Buenas noches: Retomando una consulta que hice hace algun tiempo, tengo un problema con este archivo que adjunto, necesito que de una referencia me cuente el total de visitas de esa referencia, lo explico en el archivo adjunto. Un saludo y gracias por vuestra ayuda. Libro1.zip
  23. Perdón por el retraso pero he estado un poco liado y no he tenido tiempo de ver el foro. Gracias por la respuesta. Un saludo
  24. Gracias, habria alguna forma de que buscara en una sola formula tanto las SI como los no, en esta veo que busca solo los SI. =SUMAPRODUCTO((A:A=1)*(B:B="SI")) =SUMAPRODUCTO((A:A=0)*(B:B="NO")) Y en la anterior a NO lo que necesito es que busque tanto SI y No de una sola vez ya que la celda contiene como 500 registos y estan mezclados SI y NO Un saludo
  25. Muchas gracias logroastur, ha funcionado perfectamente, una pregunta mas, en una columna tengo varias celdas en las que pone SI y NO, necesito contar las SI que aparezcan con un 1 y las No con un 0. ¿como sería la formula? Muchas gracias
×
×
  • Create New...

Important Information

Privacy Policy