Jump to content

sprit36

Members
  • Content Count

    142
  • Joined

  • Last visited

About sprit36

  • Rank
    Advanced Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Retomo el tema para finalizarlo, efectivamente lo que aportó Silvia hacia la suma o resta solo con los ejemplos, al poner otros números no lo hacia correctamente. Lo solucioné con esta formula: =SI(A2>B2,A2+B2,A2-B2) Adjunto captura de pantalla con los resultados obtenidos con las diferentes formulas aportadas. Como se dijo si A es Mayor que B , es lo mismo que decir que B es Menor que A, aunque la teoría sea así, viendo los resultados no lo es. Gracias a todos!
  2. Gracias a todos, el archivo que adjunta Silvia es lo que busco, era lo que buscaba. Siento y no era mi intención crear polémica, aveces cuesta explicarse con textos y ejemplos que pueden dar lugar a múltiples interpretaciones. Adjunto dos capturas de pantalla con la formula inicial y la aportada por Silvia. El resultado de la formula inicial era 5 - 2 era 7 y en que aporta Silvia son 3. En el segundo Excel aportado había que ir cambiando el signo > < lo que hacia el proceso muy manual. Muchas gracias a todos por el interés y el tiempo empleado en encontrar la solución. Tema solucionado.
  3. Gracias Gabriel, he estado viendo el archivo y hace la función, pero hay que ir poniendo los signos < o > en la columna B, lo que busco es lo que sume cuando A es mayor que B y reste cuando B sea menor que A. Gracias.
  4. Gracias a todos por las aportaciones, yo adjunto un ejemplo en el cual pongo a modo de ejemplo unos resultados, aplico la formula facilitada y veo que no resta, adjunto captura de pantalla donde pongo la formula y en vez de restar está sumando. Si en la celda A aparece 5 y en la celda B aparece 2, el resultado será 3, no 7 como se ve en la imagen adjunta que se llama ejemplo. Lo que he visto es que si en la celda A aparece un valor mucho menor a la celda B si lo resta como se puede ver en el adjunto llamado ejemplo2, pero en el caso del ejemplo que aporté no lo hace. Gracias.
  5. Buenos días, si lo que necesito es que siempre que el valor de A sea mayor sume, y el valor de B siempre que sea menor reste. Los datos van cambiando, aveces pueden ser mayores o menores lo único que se conservan son las columnas. Gracias
  6. Gracias Gabriel, la formula daba error, cambié las comas por punto y coma quedando así =SI(A2>B2;A2+B2;A2-B2) el problema es que suma correctamente, pero no resta. No sé si hago algo mal. Gracias
  7. Buenos días, tengo un problema que no he podido resolver, si el valor de la columna A es mayor debe sumar y si el valor de la columna B es menor debe restar. Adjunto ejemplo. Gracias. ejemplo.xlsx
  8. Muchas gracias Gerson. Tema resuelto.
  9. Buenos dias, adjunto un ejemplo en el que necesito que sume o reste si el valor es positivo debe restar y si es negativo sumar. Gracias. ejemplo.xlsx
  10. Gracias Haplox, ahora funciona perfectamente. Muchas gracias por tu ayuda. Tema solucionado.
  11. Gracias Haplox, lo he probado y si por ejemplo añado un nueva referencia a la pestaña ref no la elimina. He probado a poner la referencia s0013 y al ejecutar la macro en cualquier hoja no la borra. No sé si tengo que hacer algo que no estoy haciendo. Gracias por la ayuda.
  12. Buenos días, necesito comparar dos hojas de un libro y borre una celda determinada, en el ejemplo adjunto debe comparar la columna F de la primera hoja con la Hoja Ref columna A, al ser varias hojas con los mismos datos de distintos meses, no sé como hacer para que la formula funcione con la hoja activa, la hoja que compara que se llama Ref siempre será la misma. El dato que debe borrar está en la celda T . Gracias. Ejemplo.xlsx
  13. Gracias, Haplox y johnmpl, las dos soluciones funcionan correctamente. Tema solucionado.
  14. Buenos dias, estoy intentando hacer una resta, pero busco que cuando sea negativa, muestre cero. Adjunto ejemplo. Gracias. Diferencia.xlsx
  15. Gracias johnmpl, funciona perfectamente. Tema resuelto. Muchas gracias a todos por las aportaciones y la ayuda para resolverlo.
×
×
  • Create New...

Important Information

Privacy Policy

Ayuda Excel - Madrid, Madrid, ES - Valorada por 6254 personas - Aprender Excel - Total: 4.7 / 5