Jump to content

sprit36

Members
  • Content Count

    146
  • Joined

  • Last visited

About sprit36

  • Rank
    Advanced Member
  • Birthday 12/15/1973

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Tienes razón, culpa mía había modificado el rango, pero parece que no se cambió, como tengo muchas cosas y haciendo varias cosas no me había fijado que el cambio no se había realizado, efectivamente solo estaba hasta la fila10. Funciona perfectamente. Mil disculpas y muchas gracias por tu ayuda. Tema resuelto.
  2. Adjunto un archivo en el que marco en color verde referencias que son de diferentes días y aparece 1 en vez de 2, el primer registro está correcto, ahí si se hace correctamente. Muchas gracias. Libro1B.xlsx
  3. Muchas gracias por la respuesta, he probado, pero cuando hay muchos datos no llega a hacerlo correctamente. Quizás sea necesario que sea una macro? O hay algo que esté haciendo mal. Estoy poniendo Ctrl + Shift + Enter, al ser una fórmula matricial.
  4. Buenos días, tengo una duda sobre la formula CONTAR.SI.CONJUNTO que creo que es la que necesito para poder marcar unas celdas que cumplan unos criterios, al comparar la columna A con la B, si está una vez, o duplicado en la misma fecha lo marcará como 1, si está duplicado varias veces en distintas fechas lo marcará como 2. Adjunto ejemplo. Gracias. Libro1.xlsx
  5. Retomo el tema para finalizarlo, efectivamente lo que aportó Silvia hacia la suma o resta solo con los ejemplos, al poner otros números no lo hacia correctamente. Lo solucioné con esta formula: =SI(A2>B2,A2+B2,A2-B2) Adjunto captura de pantalla con los resultados obtenidos con las diferentes formulas aportadas. Como se dijo si A es Mayor que B , es lo mismo que decir que B es Menor que A, aunque la teoría sea así, viendo los resultados no lo es. Gracias a todos!
  6. Gracias a todos, el archivo que adjunta Silvia es lo que busco, era lo que buscaba. Siento y no era mi intención crear polémica, aveces cuesta explicarse con textos y ejemplos que pueden dar lugar a múltiples interpretaciones. Adjunto dos capturas de pantalla con la formula inicial y la aportada por Silvia. El resultado de la formula inicial era 5 - 2 era 7 y en que aporta Silvia son 3. En el segundo Excel aportado había que ir cambiando el signo > < lo que hacia el proceso muy manual. Muchas gracias a todos por el interés y el tiempo empleado en encontrar la solución. Tema solucionado.
  7. Gracias Gabriel, he estado viendo el archivo y hace la función, pero hay que ir poniendo los signos < o > en la columna B, lo que busco es lo que sume cuando A es mayor que B y reste cuando B sea menor que A. Gracias.
  8. Gracias a todos por las aportaciones, yo adjunto un ejemplo en el cual pongo a modo de ejemplo unos resultados, aplico la formula facilitada y veo que no resta, adjunto captura de pantalla donde pongo la formula y en vez de restar está sumando. Si en la celda A aparece 5 y en la celda B aparece 2, el resultado será 3, no 7 como se ve en la imagen adjunta que se llama ejemplo. Lo que he visto es que si en la celda A aparece un valor mucho menor a la celda B si lo resta como se puede ver en el adjunto llamado ejemplo2, pero en el caso del ejemplo que aporté no lo hace. Gracias.
  9. Buenos días, si lo que necesito es que siempre que el valor de A sea mayor sume, y el valor de B siempre que sea menor reste. Los datos van cambiando, aveces pueden ser mayores o menores lo único que se conservan son las columnas. Gracias
  10. Gracias Gabriel, la formula daba error, cambié las comas por punto y coma quedando así =SI(A2>B2;A2+B2;A2-B2) el problema es que suma correctamente, pero no resta. No sé si hago algo mal. Gracias
  11. Buenos días, tengo un problema que no he podido resolver, si el valor de la columna A es mayor debe sumar y si el valor de la columna B es menor debe restar. Adjunto ejemplo. Gracias. ejemplo.xlsx
  12. Muchas gracias Gerson. Tema resuelto.
  13. Buenos dias, adjunto un ejemplo en el que necesito que sume o reste si el valor es positivo debe restar y si es negativo sumar. Gracias. ejemplo.xlsx
  14. Gracias Haplox, ahora funciona perfectamente. Muchas gracias por tu ayuda. Tema solucionado.
  15. Gracias Haplox, lo he probado y si por ejemplo añado un nueva referencia a la pestaña ref no la elimina. He probado a poner la referencia s0013 y al ejecutar la macro en cualquier hoja no la borra. No sé si tengo que hacer algo que no estoy haciendo. Gracias por la ayuda.
×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png