Jump to content

yameregistre

Members
  • Content Count

    84
  • Joined

  • Last visited

Everything posted by yameregistre

  1. Buenas con todos Tengo un PowerPoint La idea es que si le hago clic a un rectángulo o texto (en el ejemplo que adjunto son formas/rectángulos) se abra un archivo de Excel y que posicione el cursor a una celda exacta Adjunto el PowerPoint muy simplificado y el archivo de Excel también bastante simplificado para que me puedan indicar qué pasos puedo seguir y luego ya yo poder aplicarlos en el ejemplo real (más grande) que tengo Muchas gracias por su ayuda Saludos! PRES EXCEL.xlsx PRES.pptx
  2. Gracias por su ayuda a @Jamel y a @johnmpl Damos por solucionado el tema
  3. Hola, funciona muy bien Una duda adicional En lugar de que muestre una X como resultado Podría hacerse para que muestre la Fecha Fin en lugar de la x? Por ejemplo, con tu fórmula sale: X002 01/07/2017 X Lo que se desea es que salga X002 01/07/2017 02/07/2017 Saludos y gracias nuevamente
  4. Hola, gracias por responder La fórmula no da el resultado correcto para el registro X002 04/07/2017 V ya que le marca la V cuando en realidad no debería marcarle nada ya que las vacaciones del empleado X002 son del 1/07 al 2/07 Probé modificando tu fórmula matricial =SI.ERROR(BUSCARV(I2,SI($A$1:$A$5=H2,$B$1:$D$5),3,1),"") por =SI.ERROR(BUSCARV(I2,SI($A$1:$A$5=H2,$B$1:$D$5),3,0),"") Es decir, cambiando el 1 por 0 para que de una coincidencia exacta, pero tampoco funciona correctamente Saludos
  5. Buenas con todos, a ver si me podrían ayudar con este problema Tengo en una tabla las fechas en las que algunos empleados pidieron vacaciones Son tres columnas: Empleado, Fecha Inicio, Fecha Fin Todo inicia en A1 A B C Empleado Inicio Fin X002 01/07/2017 02/07/2017 X003 01/07/2017 01/07/2017 X003 03/07/2017 04/07/2017 X005 04/07/2017 04/07/2017 Y en otra tabla, tengo las marcaciones de asistencia diaria de los empleados Esta Tabla inicia en H1 H I Empleado Fecha Marc X001 01/07/2017 X002 01/07/2017 X003 01/07/2017 X004 01/07/2017 X005 01/07/2017 X001 02/07/2017 X002 02/07/2017 X003 02/07/2017 X004 02/07/2017 X005 02/07/2017 X001 03/07/2017 X002 03/07/2017 X003 03/07/2017 X004 03/07/2017 X005 03/07/2017 X001 04/07/2017 X002 04/07/2017 X003 04/07/2017 X004 04/07/2017 X005 04/07/2017 Se supone que si un empleado pidió vacaciones en determinados días, esos días no deberían asistir a trabajar Pero sucede que algunos lo hacen, y eso es lo que se desea detectar En el ejemplo, el empleado X003 asistió cuatro días: 1/7/2017 2/7/2017 3/7/2017 4/7/2017 De los cuales no debió asistir a trabajar tres días, el 1/7/2017, 3/7/2017, 4/7/2017 ya que los pidió como vacaciones Hice una columna auxiliar en J, con esta fórmula a partir de J2 =SI.ERROR(SI(Y(H2=BUSCARV(H2,$A$2:$C$5,1,0), I2>=BUSCARV(H2,$A$2:$C$5,2,0), I2<=BUSCARV(H2,$A$2:$C$5,3,0)), "x", ""), "") La cual funciona bien para encontrar la primera fecha que no debió asistir a trabajar un determinado empleado, pero no detecta las siguientes fechas en las cuales no debió asistir Me gustaría poder detectar no sólo la primera asistencia que no cumpla, sino también las siguientes, para determinado empleado Saludos! BuscarV 2do, 3er criterios.xlsx
  6. Buenas, probando la solución planteada no da ningún resultado, nisiquiera funciona para las celdas de A2:A10, saludos
  7. Buenas con todos A ver si me pueden ayudar con este pequeño inconveniente con la validación de datos Si deseo ingresar una lista de nombres en la columna A, siendo A1 el título y de A2:A10 la zona donde se ingresarán los valores pero sin repeticiones A 1 Lista 2 3 4 5 6 7 8 9 10 Entonces, selecciono de A2:A10 y realizo una validación de datos con fórmula =CONTAR.SI($A$2:$A$10, A2) =1 Eso me ayuda a que al ingresar nuevos valores, ninguno de ellos esté repetido (al menos dentro de ese rango, de A2:A10) Luego tuve la necesidad de aumentar nuevas filas, entonces convertí todo en Tabla, del rango A1:A10 indicando que A1 era encabezado Pero al ingresar nuevos valores a partir de A11, la Tabla no hace que la validación de datos funcione adecuadamente en A11 Viendo la fórmula en A11 de la validación de datos, veo que queda así: =CONTAR.SI($A$2:$A$10, A11) =1 Cuando debería estar adaptada como $A$2:$A$11 y no quedarse como $A$2:$A$10 Intenté usando el nombre de la Tabla y referencias estructuradas en la Validación de Datos y nada Intenté usando nombres de rango en la Validación de Datos y nada Cuál es la forma de solucionar esto, para que al ingresar nuevos valores en A11, A12, A13 etc, la validación de datos siga funcionando bien y se adapte a nuevas filas? Es posible usar referencias estructuradas o rangos con nombres para solucionar esto? Sería la única solución que el Contar.Si lleve como rango A:A y luego convertir todo en Tabla y así tenerlo de forma automatizada para las nuevas filas con datos que se agreguen debajo de A10? Saludos! Lista sin repetidos.xlsx
  8. Interesante la solución Usando primero un filtro avanzado de sólo únicos Y luego haciendo el filtro de 10 inferiores
  9. Hola Silvia =CONTAR.SI($A$5:A5,A5) es la solución que yo mismo pongo en mi archivo original Yo usé =SI(CONTAR.SI($A$5:A5,A5)=1, A5, "") La pregunta de mi tema va por dos puntos: - Hay otra forma de hacerlo además de crear una columna auxiliar con fórmula? Una respuesta es quitar duplicados como bien comentas - Si se usa fórmulas en una columna auxiliar, si hay otra opción a: =SI(CONTAR.SI($A$5:A5,A5)=1, A5, "") Saludos
  10. Amigo Snake, la pregunta es sobre cuando uno filtra los "x" superiores e inferiores, y no sobre tener la lista de únicos Ejemplo Tienes 10 10 20 20 30 Quiero los dos más bajos Usando filtro, 2 inferiores, la respuesta obtenida es: 10 10 Y lo que se esperaría tener por resultado en realidad debe ser: 10 20 La solución de Silvia es buena, pero tiene el problema de que deben ser números que estén ordenados para que funcione, del tipo 3 3 3 4 7 8 Es decir, si tengo Ventas 3 7 3 4 8 3 Y quiero filtrar los dos inferiores, su fórmula no funcionaría Y la pregunta también de si obligatoriamente tendría que usar una columna auxiliar cuando existen empates y quiero filtrar los x superiores/ inferiores, o existe alguna solución adicional Saludos
  11. Hola con todos Si tengo una lista de valores ejemplo Venta 55 55 55 55 55 55 56 57 58 59 60 60 61 62 63 64 64 si Intento un filtro con la opción 5 inferiores Lo que esperamos seria tener 55, 56, 57, 58 y 59 Pero el resultado sólo muestra todas las repeticiones de 55 55 55 55 55 55 55 Cómo solucionan o lidian con este tipo de casos? Yo tuve que hacer una columna auxiliar y un contar.si que me permita tener sólo una vez cada elemento Se soluciona de otra manera? Existe alguna opción especial? Gracias, saludos FILTRAR CUANDO HAY EMPATES.xlsx
  12. Así es. Cuando asignamos la propiedad de rowsource a través de Initialize, ya no colapsa Excel en ninguno de los dos escenarios aquí planteados. No hay problemas ni con el Combobox ni con el Listbox Entonces el procedimiento indicado por Riddle sería el que siempre se debe usar en el 100% de situaciones Gracias, saludos y solucionado, a no ser alguien quisiera profundizar en las causas
  13. Hola Hoy en el trabajo un compañero me acaba de prestar su laptop que tiene Excel 2013 y Windows 8 y acabo de repetir el experimento 1- abrí un Excel nuevo 2- tipear datos de A1:a4 Vendedor Juan Maria José 3- presione Ctrl+t y se convirtió en Tabla. No le cambie de nombre, lo deje como tabla1 4- Alt+f11 para entrar al visual, inserte un userform y dibuje un combobox 5- al combobox no le cambie de nombre. En el panel de propiedades Del lado izquierdo en la propiedad rowsource le puse Tabla1 Prueba del experimento Abrí el userform para ver reflejado los datos Lo cerre Ingrese un nuevo dato a la tabla1 y Excel colapsó Lo que quisiera repetir es que la prueba la estoy haciendo todos estos días en diferentes computadoras con archivos creados de cero y siempre lo mismo Hoy lo acabo de hacer sobre Windows 7 y Excel 2013 en una laptop random de un compañero de trabajo Bueno, gracias
  14. Buenas tardes/noches/días con todos Si tienes un Combobox o Listbox con Rowsource amarrado a alguna tabla Escenario 1: Si primero agregas una fila nueva a tu Tabla Y luego abres el UserForm que contiene el ComboBox o ListBox para visualizar los datos de dicha Tabla Excel no colapsa Escenario 2: Si abres el UserForm que contiene el ComboBox o ListBox para visualizar los datos de dicha Tabla Y luego lo cierras y agregas una fila nueva a tu Tabla Excel colapsa ¿Por qué? ¿Les ha pasado? ¿Cómo se evita? ¿A qué se debe? ¿Es un error del cual hay que informar a Microsoft Pero principalmente, ¿qué solución existe ante ello? He visto que eso sucede no sólo con los archivos que aquí adjunto (los cuales los acabo de hacer de cero), sino que si intentas hacer el experimento con archivos creados desde cero, es posible les suceda lo mismo. Así que no veo sea motivo de "reparar el archivo" o algo así Lo he probado con Excel 2016 bajo Windows 7 y 10 en diferentes computadores. Saludos Com List.xlsm
  15. Hola gracias por responder, de momento según la prueba que estoy haciendo, si ingreso un nuevo contrato manualmente en el excel llevaría el número 10, cuando cargo el userform y busco el 10, sale los datos del 1. Si busco el contrato 6 no aparecen datos. Voy a chequear el código para ver ese detalle y lo voy a seguir probando para ver qué puedo afinar y qué no y comentar luego Muchas gracias
  16. Hola, no, no he protegido el documento ni nada Ahora la duda es si teniendo la base de datos como una Tabla de Excel, deja o no deja insertar filas en cualquier lugar mediante programación, quizás sea eso?
  17. Si alguien me pudiera ayudar, estaría muy agradecido Si es necesario crear alguna columna auxiliar, no habría problemas en hacerlo Saludos y gracias
  18. Para terminar con los detalles de mi problema, y ver si es factible el ayudarme Todo esto es lo que no consigo resolver aún ListBox1 En el UserForm, si coloco el número de contrato, en ListBox1 debe mostrarse las fechas programadas del empleado que tiene asociado ese contrato si las hubiera. En este ejemplo no las hay aún, pero la vamos a agregar luego Si deseo agregar la programación por Primera Vez a alguien Si un empleado desea una vacación, primero pide la programación y se registra dicha programación en nuestro Excel mediante el UserForm donde está el Marco Programar, por el lado izquierdo (como se ve en la captura de arriba). El procedimiento sería ingresar primero el número de contrato, y aparece el nombre del empleado debajo. Ya con eso luego se puede programar ingresar los datos en la parte inferior (Fecha inicio, Días, Fecha Final). Luego se presionaría el botón programar. Por ejemplo, al Empleado 4 le hago la primera programación, por 10 días. La columna H, I, J son ingresadas por el Userform (Fecha Inicio, Fecha Fin, Dias) En la siguiente captura he marcado en un círculo los datos ingresados. Luego la columna F debe mostrar dicho total. Si deseo confirmar la programación de alguien, es decir hacerla Efectiva Llegado el día, si el Empleado mantiene la programación que indicó y sale de vacaciones el día pactado, entonces deben suceder dos cosas: - El número 10 pasaría de la columna J (días programados) a la columna K (días efectivos) ya que el empleado ha hecho realidad el irse de vacaciones. - Las columnas H,I,J deben quedarse sin el resaltado amarillo. Para que esto suceda se selecciona la programación deseada del ListBox y se presiona el botón Hacer Efectivo. El ListBox también actualiza los cambios de la Columna J a la K Si deseo reprogramar una programación Si un empleado decide reprogramar una vacción programada (es decir, que aún no es efectiva) lo puede hacer El procedimiento sería: Seleccionar la programación del ListBox y presionar Reprogramar Eso abriría el formulario Reprogramar donde se cambiaría la Fecha Inicio, Fecha Final, Días y se presiona el botón respectivo Luego de reprogramar dicha vacación (después de presionar el botón): - En el Excel se insertaría una nueva fila debajo de la vacación programada que se desea reprogramar. En esa fila nueva va como datos Fecha Inicio, Fecha Fin y Dias para esta reprogramacion - La fecha programada que acabamos de reprogramar, debe perder el resaltado amarillo y debe borrarse el número de dias. Y ahora la fila con la reprogramación es la que debe tener el color de fondo fucsia en las columnas H,I,J - Se actualiza el número de la columna F (el cual es la suma de todo lo programado/reprogramado - Se actualiza el saldo días en la columna L (el cual es la diferencia del número de la columna F para cada contrato menos la suma de todos los días de vacaciones tomados de manera efectiva en la columna k) Agrego la foto de otro caso más grande, para el Empleado 2 por ejemplo para que se entienda todo lo anterior. En donde vemos que Saldo Días = Nro Dias (Col F) - SUMA(Todos los Dias Efectivos) 60 - 52 = 8 Espero con esto y las indicaciones que puse en el Excel original, me puedan ayudar, ya avance todo lo que pude, el resto que planteo en este mensaje no consigo dar con la solución Gracias por tomarse la molestía de leer Les estaré eternamente agradecido por su ayuda Saludos!
  19. Así es @Haplox eso es lo que falta, que al elegir un numero de contrato muestre sus detalles en el ListBox, tal como lo pongo en los comentarios del Excel que adjunté a partir de la columna N La idea es asi, lo voy explicando nuevamente por partes Columnas A,B,C,D De forma manual (directamente en cada celda, sin userform) se ingresará las columnas A,B,C,D Es decir, se pondrá el Nro de Contrato (que es único) el empleado, el nombre del Empleado, la fecha de inicio de contrato de y la fecha de fin de ese contrato en particular. Entonces originalmente los datos se verán así Un empleado puede tener varios contratos en el transcurso del tiempo, no hay problema, el código de cada contrato lo diferenciará como se ve en el caso del Empleado 2, que tiene los contratos con código 2 y 8 Aquí no hay problema ni nada que resolver Columna E y G La columna E calculará de acuerdo a la fecha de inicio de contrato y la fecha de fin de contrato cuantos días gana de vacaciones (30 por cada año de trabajo que cumple). Estos 30 se cumplen así. por ejemplo si ingresa el 3/04/2015, sus 30 días ganados de vacaciones se dan el 2/04/2016, los 60 días el 2/04/2017, etc Aquí no hay problema ni nada que resolver La columna G calculará si es un Contrato de tipo VENCIDO o NO VENCIDO basándose en la fecha actual Aquí no hay problema ni nada que resolver Continuo en un momento con el siguiente mensaje
  20. Hola, a la altura de la celda N1 está el botón para invocar al userform llamado Vacaciones La idea sería poner en el textbox el nro de contrato y con eso ya se puede programar alguna nueva vacacion por la parte izquierda del formulario y mostrar en el listbox de la derecha sus vacaciones ya programadas Luego para hacer efectiva una vacacion se selecciona la misma del listbox y se presionaria el boton hacer efectivo Y si se desea reprogramar una vacacion se selecciona la misma del listbox y se presionaria el boton reprogramar. Eso llamaria al otro formulario llamado Reprogramar para reprogramarla Esa es la idea. He resumido mi idea en este diseño minimalista, pero si hay que modificar el diseño y hacerlo mejor o separar algo en otro form, o agregar algún control no hay problema, la idea es que funcione muy bien, pero creo que quizás como esta planteado sí se puede realizar Gracias por el comentario, saludos
  21. Hola a todos En este problema espero me puedan ayudar, ya que he intentado muchas cosas y si bien es cierto algunas conseguí, otras aún no y ya llevo varios días en esto y se está volviendo un poco frustrante Es un archivo que he estado creando sobre programar/reprogramar fechas En el archivo adjunto muestro la lista de operaciones que debe realizar el formulario Algunas tareas ya las conseguí automatizar, otras no Las que pido ayuda es en las tareas que aún no Pongo toda la explicación de lo que se necesita en el archivo adjunto ya que allí es más fácil de entender Nuevamente agradezco bastante su colaboración Gracias! MODELO VACACIONES.xlsm
×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png