Jump to content

Silvia

Moderators
  • Content Count

    2,968
  • Joined

  • Last visited

  • Days Won

    115

Everything posted by Silvia

  1. hola Susana Prueba con: =Si(J4="","",TUFORMULA) mi separador de argumentos es la coma, si el tuyo es otro, corriges. saludos, Silvia
  2. ah.... mmm, entendí. No sabría como ayudarte, yo creo que no se puede hacer de la forma que quieres.. trabajar con libros compartidos es así, te limita muchas cosas.. Sin embargo hay algo, Al menos el ID lo deberías ingresar manualmente, y traer el resto de columnas con formula , referenciando ese ID y no directamente solo con "=", como lo estás haciendo. (Como comentario, no se si te sirva, pero una cosa que si puedes hacer es , una vez trabajada la fila, convertir esos datos a valores.. , de esa forma si alguien mueve algo no se moverán tus datos) En todo caso, esperemos a ver si alguien mas te puede dar alguna idea.. saludos, Silvia
  3. También debes adjuntar un archivo tipo muestra de lo que tienes y lo que quieres conseguir..
  4. hola Miguel, tienes dos consultas iguales, borraré la otra.. Por favor, no olvides que el Título debe contener el motivo/tema de tu consulta. saludos. Silvia
  5. hola a los dos.. Gerson Ruben para casos similares utiliza la combinación de Indice y Coincidir. Sin embargo, como ahora hay mas criterios, el no sabía como aplicar Indice con Coincidir y utilizó Sumar. Si.Conjunto, que le entrega el resultado que necesita. Pero se queda con la duda si su formula es apropiada, ya que en realidad no tendría que estar sumando nada, tan solo tiene que traer un resultado, como lo haría con Indice y con Coincidir. Entonces, pregunta si su formula es la que tiene que aplicar o no.. y yo ya le dije que sería cuestión que pruebe con cual le va mejor, y también le dije que a mi me parece que la que el utilizó es la que le dará mejor resultado. Porque ya sería solo cuestión de eficiencia de su PC.. ____________________________________ Ruben Para llegar al resultado esperado mayormente se puede hacer de muchas maneras, cuanto menos funciones utilices es mejor; la mejor o formula mas adecuada, es la que te entregue el resultado de manera eficiente.. En resumen, te toca analizar a ti, o esperar que hayan mas aportes de formulas a tu consulta y seguir evaluando cual te resulta mejor. Digamos que si en toda tu hoja, tienes una pocas formulas, entonces utilizar una formula con funciones volátiles, con funciones anidadas, con mega formulas, o con funciones SuperPoderas (Sumaproducto).. etc.. no le harán ni chis ni mus a tu trabajo.. utiliza la que te apetezca.. He dicho saludos, Silvia
  6. yo creo que tu duda está en base a que a lo mejor tu piensas que al utilizar sumar.si.conjunto, podrías enlentar los procesos de cálculo en tu pc? Tendrías que probar con las que te pasé y ver cual es mas efectiva, yo pienso que tu opción es mejor.. porque solo usas una función.. (yo también te pasé una con Sumaproducto, sin embargo, Sumaproducto es una superpotente función, que también podría llega a consumir muchos recursos de tu pc) en resumen, solo te queda probar las diferentes propuestas y quedarte con la que funcione mejor.. saludos Silvia @Gerson Pineda está haciendo acto de silencio...
  7. hola buenos dias y según tu ejemplo, cual sería el 1er y el 2do dato estimado???
  8. otra =SUMAPRODUCTO((A10:A15&B10:B15&C10:C15&D10:D15=A2&B2&C2&D2)*(E10:E15)) yo creo que hasta ahora... sumar.si.conjunto....
  9. se puede omitir concatenar el guión =INDICE($E$10:$E$15,COINCIDIR(A2&B2&C2&D2,INDICE($A$10:$A$15&$B$10:$B$15&$C$10:$C$15&$D$10:$D$15,),))
  10. sale otra opción... =INDICE($E$10:$E$15,COINCIDIR(A2&"-"&B2&C2&D2,INDICE($A$10:$A$15&"-"&$B$10:$B$15&$C$10:$C$15&$D$10:$D$15,),)) mi separador de argumentos la coma, si el tuyo es otro, corriges. ...
  11. no había leído bien... ..Pero eso no importa, porque siempre dará la solución correcta.. , la tuya es una posible solución...
  12. hola RubenDario (y Gerson) que tal si comentas, por qué te parece que tu solución no es la correcta??
  13. Hola Blecho no se si entendí bien... revisa saludos, Silvia appcc1.xlsx
  14. nada es fácil en esta vida, será fácil cuando hiciste que se haga fácil, después de haber estudiado, investigado, practicado.... el conocimiento no se adquiere de la nada... https://www.abc.es/tecnologia/redes/20130415/abci-hombre-cobro-millonada-trazar-201304150921.html entonces nada está chupado .. jaja saludos, Isidro!
  15. hola rabonelli75 así? =SUMAR.SI.CONJUNTO(Hoja2!$D$1:$D$10,Hoja2!$A$1:$A$10,Hoja1!A2,Hoja2!$B$1:$B$10,Hoja1!C2,Hoja2!$C$1:$C$10,E2) mi separador de argumentos es la coma, si el tuyo es otro, corriges.. **ojo, la formula sumara todas las veces que en los datos encuentre los criterios.. saludos, Silvia
  16. que bien... y siempre es bueno, mencionar cual fué la solución, para que otra persona que necesite lo mismo que tu, pueda resolverlo, leyendo este hilo..
  17. hola Jeani y (Gerson ) Jeani Cuando uno va a consultar, debe ponerse del lado del que está mirando y no sabe nada de lo que estás haciendo, cuando alguien te trata de ayudar, hay que comentar sobre la ayuda recibida, lo que sale bien, lo que sale mal... , es solo cuestión de interactuar de manera que fluya la ayuda y se resuelva el tema.. para no estar dando vueltas sobre lo mismo.. pero si adjuntas ejemplos y no colocas en que falla la formula.. es como si te negaras a usarlas y uno pierde el gusto en ayudar&"te" ... Mira, el motivo por el que no funciona tu formula, lo puedes leer en mi comentario, aqui https://ayudaexcel.com/foro/topic/41260-buscarv-con-horas-no-funciona-en-todas-las-celdas/ Entonces, ya te darás cuenta, porque Gerson utilizó Redondear en su fórmula... ahora si utilizas la tuya, pues se agrandará bastante.. la de Gerson es 100% mejor y mas eficiente.. y si el tema terminó con los criterios que mencionaste y todo el resto que se salga de eso, es cero, pues envuelve la formula de Gerson con SI.ERROR (FORMULA, 0) Y listo.. saludos, Silvia.
  18. Hola Johana (y Snake) Mira, lo que pasa es que excel considera un largo de numero a buscar, de solo 15 dígitos. esto lo copié de la ayuda de Microsoft. . lo que tu ves como 09:50:00 p. m. en realidad es 0.909722222222222 y por eso excel no lo puede encontrar. el largo máximo de las horas es 17, entonces lo que podemos hacer es redondear y convertir en texto, para que busque el texto. y la formula quedaría así =INDICE(Hoja2!$B$2:$B$541,COINCIDIR(REDONDEAR(A2,17)&"",INDICE(REDONDEAR(Hoja2!$A$2:$A$541,17)&"",),)) mi separador de argumentos es la coma, si el tuyo es otro, corriges. ah.. si deseas que en lugar de error salga NO =SI.ERROR(INDICE(Hoja2!$B$2:$B$541,COINCIDIR(REDONDEAR(A2,17)&"",INDICE(REDONDEAR(Hoja2!$A$2:$A$541,17)&"",),)),"no") saludos, Silvia
  19. hola nitrito (Manuel y Gerson ) Manuel.. Yo diría D:D tendría el mismo efecto que D4:D1048576 y también es una mala práctica. Lo ideal es limitarse al rango de datos y tal vez un poquito mas.. ahora que, si tiene toda la columna llena de Datos, pues Excel no creo que le sirva para lo que necesita.. su máquina tal vez explote... nooo, no lo creooooo, ¿o si ?, en 2003 había buscar , buscarv, buscarh y las 3 tienen usos diferentes... y en excel 2016 también los hay y siguen teniendo usos diferentes. Aunque no significa que no se pueda conseguir.. =BUSCAR(1,1/(REGISTRO!$D$2:$D$100=H5),REGISTRO!E4:E100) **mi separador de argumentos es la coma.. se debe cambiar por el que utilice la pc que aplicará la formula. Si lo que quiere el consultante, es buscar un código o unos pocos códigos en la hoja registro y este no se repite, bien le puede servir buscarv, como lo mencionaste; e incluso no habría problemas en el caso de utilizar rangos completos de tipo D:D.... y si no (Es decir si va a hacer muchas búsquedas) .. pues la sugerencia de Gerson sería mas acertada... pues no le quedará de otra.... saludos y feliz semana. Silvia
  20. se movió el tema a solicitud del consultante. saludos, Silvia
  21. Pero hacer una formula por cada celda ............. es mejor hacerlo a mano...
  22. hola a mi parecer esto va mas por macros... la formula en el adjunto, hace lo que pides, pero... y que pasa con las palabras que se cortan? difícil con formulas.. tal vez con mas columnas auxiliares.. saludos, ayuda excel 1.xlsx
  23. Te aconsejo convertir en tabla el MATERIAL y la incluyas en la formula; de esta forma, cada vez que agregues Materiales, la formula actualizará los rangos..
×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png