Jump to content

sailepaty

Members
  • Posts

    1,374
  • Joined

  • Last visited

  • Days Won

    8

Everything posted by sailepaty

  1. Te gane Antoni! Yo tengo nivel de principiante 🤛 Saludos!
  2. Re: Application.WorksheetFunction.Match Puede ser algo así, Sub Insertar() Dim rFound As Range Set rFound = Sheets(2).Range("A1:A5").Find(Sheets(1).Range("B1")) If Not rFound Is Nothing Then rFound.Offset(0, 1) = Sheets(1).Range("B2") End Sub [/CODE] Saludos
  3. O puedes utilizar este complemento. http://www.oaltd.co.uk/indenter/default.htm Saludos
  4. Si este no funciona lo dejamos para mas tarde, el deber llama. Saludos a todos y feliz año. SUMA 1 DIGITO POR CELDA.zip
  5. Me parece que la formula estaba bien lo que estaba mal fue mi explicación, checa el anexo. Saludos SUMA 1 DIGITO POR CELDA.zip
  6. Buen apunte Fleming, haber así. M11=RESIDUO(SUMA(M7:M10);10) L11=RESIDUO(SUMA(L7:L10)+SI(M11=0;ENTERO(MULTIPLO.SUPERIOR(SUMA(L7:L9);10)/10);ENTERO(SUMA(M7:M10)/10));10) J11=RESIDUO(SUMA(J7:J10)+SI(L11=0;ENTERO(MULTIPLO.SUPERIOR(SUMA(J7:J9);10)/10);ENTERO(SUMA(L7:L10)/10));10) Copiar formula de J11 a I11, H11 y G11. Saludos
  7. Otra opción, M11=RESIDUO(SUMA(G7:G10)+ENTERO(SUMA(H7:H10)/10);10) Ahora copia la formula en L11, I11, H11 y G11 Para J11 debido a que la siguiente columna es texto se suma la division de la suma de dos columnas a la derecha en lugar de una. J11=RESIDUO(SUMA(J7:J10)+ENTERO(SUMA(L7:L10)/10);10) Saludos
  8. Felicidades Josemaría Salió en la quinta posición, ahora de seguro ya tienes una visita desde México y en cuanto regrese a casa tendrás una de USA. Saludos
  9. Que tal Mauricio, Tienes toda la razon siempre se aprende algo, tanto que hacer y que no hacer Saludos
  10. Me pregunto para que hace falta una UDF para obtener el resultado del total de dias de un mes? Saludos
  11. Gracias por la aclaración Pedro, ya quedo modificado. Me gusta la opción que le añadiste a la función. Saludos
  12. Y para no dejar solo a Macro Antonio, aqui va una UDF. Function SoloNumeros(sTexto As String) As Double With CreateObject("VBScript.RegExp") Application.Volatile .Pattern = "\D" .Global = True SoloNumeros = .Replace(sTexto, "") End With End Function[/CODE] Saludos
  13. Si bien con el añadido de la función INDICE en algunas formulas matriciales se evita la confirmación con Ctrl+Shift+Enter, eso NO mejora (en ocaciones empeora) el tiempo de calculo y efecto en el rendimiento del archivo. Saludos
  14. Otra opción sin importar la posición de los numeros. Se crea el nombre nFilas que es igual a: =FILA(INDICE(!$A:$A,1):INDICE(!$A:$A,10)) Ahora la formula matricial para extraer los numeros de la celda A2 =SUMA(EXTRAE(0&A2,K.ESIMO.MAYOR(ESNUMERO(--EXTRAE(A2,nFilas,1))*nFilas,nFilas)+1,1)*10^nFilas/10) Saludos Extraer numeros de cadena con texto.zip
  15. Sin ver tu hoja y solo por lo que comentas me imagino que se soluciona aumentando la cantidad de ceros. =SUMA(EXTRAE(A1:A7&"0000";4;1)*1) Confirma con Ctrl+Mayus+Enter o =SUMA(INDICE(EXTRAE(A1:A7&"0000";4;1)*1;0)) Confirma solo con Enter Saludos
  16. Haber así, =SUMA(EXTRAE(A1:A7&"00";4;1)*1) Confirma con Ctrl+Mayus+Enter o =SUMA(INDICE(EXTRAE(A1:A7&"00";4;1)*1;0)) Confirma solo con Enter Saludos
  17. Como cualquier formula de fechas si deseas incluir ambos extremos solo le tienes que aumentar uno como lo hiciste con tu formula. =FRAC.AÑO(MAX(N(B1)+1;A2);B2+1;3)*(B2>N(B1)) Saludos
  18. Abrí el archivo que había publicado y me di cuenta que es recomendable salvarlo antes de correr la macro para que identifique correctamente la ruta y el nombre del archivo. Y ya estando con el archivo le hice una pequeña modificación para que no presente un error cuando la acción es igual a Crear y la conexión ya existe. Saludos EXCEL QUERY.zip
  19. Le sumamos uno para evitar contabilizarlo doblemente. 1/29/2010 – 3/30/2010 3/30/2010 – 4/25/2010 En este caso el 3/30/2010 existe en los dos rangos, por lo tanto si no le sumas uno se duplicara en el conteo. Saludos
  20. Aquí va una opción con MSQuery. Se crea un QueryTable que se puede modificar mediante código o manualmente. Esta probado no extensamente en Excel 2007 y por el manejo de algunos objetos y parámetros no creo que funcione en versiones anteriores. Pero seguro que los expertos en VBA lo podrán adaptar fácilmente para versiones anteriores, además de corregirlo y mejorarlo indudablemente. 1.- Seleccionar en la celda B13 de la hoja PARAMETERS la opción Create. 2.- Seleccionar la sentencia SQL que se desea ejecutar en la celda B15 de la hoja PARAMETERS 3.- Presionar el botón RUN QUERY Una vez creada la conexión ahora pueden jugar con las diferentes sentencias SQL que puse o crear las propias. 1.- Seleccionar en la celda B13 de la hoja PARAMETERS la opción Refresh 2.- Seleccionar la sentencia SQL que se desea ejecutar en la celda B15 de la hoja PARAMETERS 3.- Presionar el botón RUN QUERY Saludos EXCEL QUERY.zip
  21. Puede que así funcione. C2=FRAC.AÑO(MAX(N(B1)+1;A2);B2)*(B2>N(B1)) Saludos
  22. Siguen los ejemplos. Recordset Tricks in Excel 2 ? Cascading ListBoxes Bacon Bits: Saludos
  23. Haber así, Fecha Inicial en A2, Fecha Final en B2 y formula en C2. Las siguientes fechas en las filas 3, 4, etc. C2=FRAC.AÑO(MAX(N(B1)+1;A2);B2) Copia hacia abajo y suma los resultados. Saludos
×
×
  • Create New...

Important Information

Privacy Policy