[Súper Truco] Cómo buscar datos de varias columnas en varias columnas con BUSCARV

El título puede parecer un poco confuso. El objetivo de este tutorial es mostrarte cómo buscar con BUSCARV el contenido de varias celdas a la vez, en un rango donde la columna de búsqueda no es una, sino dos.

Hace unos días recibí un correo de un amigo al que le habían enviado un libro de Excel con una fórmula que no entendía:

{=BUSCARV(E2&F2;SI({1\0};$A$2:$A$6&$B$2:$B$6;$C$2:$C$6);2;FALSO)}

La pregunta que me hacía era “¿qué significa esa función SI dentro de BUSCARV?”. Más concretamente lo que a él le extrañaba era eso de {1\0}.

Javier, te respondo por la web para compartirlo y que otras personas también puedan aprenderlo, 🙂

Antes de nada, te dejo que descargues el libro para que puedas ir siguiendo la explicación con un ejemplo que creé para responderle:

BUSCARV en multiples columnas
Título: BUSCARV en multiples columnas (41 clics)
Tamaño: 10 KB

Te recuerdo la sintaxis de BUSCARV:

=BUSCARV(valor_buscado;matriz_buscar_en;indicador_columnas;[ordenado])

Los argumentos en color rojo son obligatorios.

función buscarv varias columnas excel

En el ejemplo puedes ver en la parte izquierda una tabla con una serie de categorías y subcategorías de productos, los cuales tienen asignado un descuento. Con los datos de búsqueda de las columnas E y F, se trata de buscar el descuento correspondiente en la tabla de la izquierda.

¿Cómo funciona la fórmula?

En primer lugar déjame decirte que se trata de una fórmula matricial, es decir, que no devuelve un solo resultado, sino una matriz. Para introducir este tipo de fórmulas debes pulsar Ctrl + Mayús + Intro.

buscarv varias columnas excel

  1. El símbolo & se utiliza para concatenar o unir los valores de las celdas E2 y F2 para hacer la búsqueda combinada. En el ejemplo sería como buscar “TornilloHexagonal”.
  2. La función SI crea una matriz, que es el argumento matriz_buscar_en de la fórmula. Esta matriz tiene dos columnas.

Recuerda la sintaxis de SI:

=SI(condicion;valor_si_verdadero;[valor_si_falso])

La matriz {1\0} son los equivalentes numéricos de VERDADERO y FALSO y son la condición de la función SI.

Función BUSCARV varias columnas Excel

Fíjate cómo el argumento Valor si VERDADERO utiliza también el símbolo & para unir la categoría y la subcategoría.

  1. Para finalizar, indicador_de_columnas le dice a Excel la columna que tiene que devolver, en este caso es la segunda columna de la matriz, es decir, el rango que contiene los descuentos.

¿Qué se te pasa por la cabeza?

Javier, espero haber aclarado tu duda…

Este es uno de los trucos que enseño en mi libro BUSCARV y otras funciones de búsqueda.

¿Habías visto antes esta forma de utilizar BUSCARV?

Cuéntamelo en los comentarios.

¡Compartir es vivir!
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario 0 comentarios

Escribe una respuesta:

Powered by WishList Member - Membership Software