7

¿Qué son los criterios de validación de datos?

Si trabajas habitualmente con bases de datos y eres capaz de hacer una consulta una o varias tablas, no hará mucha falta que te explique para qué sirven los criterios en Excel.

A grandes rasgos un criterio de validación es una condición que debe cumplir un dato para que se evalúe como VERDADERO y pase a formar parte del conjunto de datos sobre el que se calculará una función. Si no la cumple, se evalúa como FALSO y la función no lo tiene en cuenta para el cálculo.

Es la forma más fácil de seleccionar cierto tipo de datos para realizar un cálculo con ellos.

Algunas situaciones en la que es imprescindible el uso de criterios (a menos que quieras incluir los datos manualmente) pueden ser las siguientes:

  • Cuando deseas sumar los valores mayores de 5: (“>5”)
  • Cuando quieres sumar solo números positivos: (“>0”)
  • Si quieres contar el número de valores que se encuentran entre 20 y 30

Funciones que utilizan criterios

Aunque no son muchas funciones las que admiten expresiones o criterios, algunas de ellas son algunas de las más utilizadas por los usuarios en general.

Por supuesto, todas las funciones de la categoría Base de datos admiten criterios ya que fueron diseñadas para trabajar con ellos:

Funciu00f3nDescripciu00f3n
BDCONTARCuenta el nu00famero de celdas que contienen nu00fameros en una base de datos
BDCONTARACuenta el nu00famero de celdas no vacu00edas en una base de datos
BDDESVESTCalcula la desviaciu00f3n estu00e1ndar a partir de una muestra de entradas seleccionadas en la base de datosn
BDDESVESTPCalcula la desviaciu00f3n estu00e1ndar en funciu00f3n de la poblaciu00f3n total de las entradas seleccionadas de la base de datos
BDEXTRAERExtrae de una base de datos un u00fanico registro que cumple los criterios especificados
BDMAXDevuelve el valor mu00e1ximo de las entradas seleccionadas de la base de datos
BDMINDevuelve el valor mu00ednimo de las entradas seleccionadas de la base de datos
BDPRODUCTOMultiplica los valores de un campo concreto de registros de la base de datos que cumplen los criterios especificados
BDPROMEDIODevuelve el promedio de las entradas seleccionadas en la base de datos
BDSUMAAgrega los nu00fameros de la columna de campo de los registros de la base de datos que cumplen los criterios
BDVARCalcula la varianza a partir de una muestra de entradas seleccionadas de la base de datos
BDVARPCalcula la varianza a partir de la poblaciu00f3n total de entradas seleccionadas de la base de datos

En el caso de las funciones anteriores, los criterios de validación deben introducirse a través de referencias de celdas de la siguiente forma:

uso bdsuma

Otras funciones Matemáticas y Estadísticas que utilizan criterios de validación son:

Funciu00f3nDescripciu00f3n
CONTAR.SICuenta el nu00famero de celdas, dentro del rango, que cumplen el criterio especificado
CONTAR.SI.CONJUNTOCuenta el nu00famero de celdas, dentro del rango, que cumplen varios criterios
PROMEDIO.SIDevuelve el promedio (media aritmu00e9tica) de todas las celdas de un rango que cumplen unos criterios determinados
PROMEDIO.SI.CONJUNTODevuelve el promedio (media aritmu00e9tica) de todas las celdas que cumplen mu00faltiples criterios
SIEspecifica una prueba lu00f3gica que realizar
SUMAR.SISuma las celdas especificadas que cumplen un criterio determinado
SUMAR.SI.CONJUNTOSuma las celdas de un rango que cumplen varios criterios

En estas funciones los criterios pueden introducirse tanto a través de referencias de celdas como directamente al escribir la función:

=SI(A1>5;”Mayor que 5”;”Igual o menor que 5”)

 ¿Qué son los comodines y cómo utilizarlos en un criterio?

Los comodines son determinados símbolos que pueden introducirse en sustitución de uno o varios caracteres.

  • *: Sustituye a uno o varios caracteres
  • ?: Sustituye a un solo carácter. Dos interrogaciones seguidas sustituirían a dos caracteres.

Son de mucha utilidad cuando , por ejemplo, quieres contar las palabras de un rango de celdas que terminen en –aba.

=CONTAR.SI(A1:A1000;”*aba”)

Puedes ver un buen ejemplo de uso al utilizar la función BUSCARV.

¿Qué criterios de validación de datos utilizas con más freciencia?

¡Compartir es vivir!
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario 7 comentarios
Juan - 16/03/2015

Desconocía la existencia de comodines: Muchísimas gracias.
Juan.

Responder
Anabel - 17/03/2015

Muchas gracias

Responder
danilo - 17/03/2015

Excelente Muchas gracias por tus aportaciones
Saludos.
Danilo

Responder
pilarbcn - 17/03/2015

Muchas gracias Sergio!!

Responder
Tomas Alonso - 17/03/2015

De gran utilidad, gracias.

Responder
Jorge C - 17/03/2015

No sabia el uso de los comodines, gracias por tu comentario.

Responder
Eduardo Rojas - 20/03/2015

Muchas gracias Sergio. Como siempre de gran utilidad.

Responder

Escribe una respuesta: