Cómo utilizar comodines en la función BUSCARV

¿Sabías que puedes hacer funcionar correctamente la función BUSCARV sin que coincida todo el contenido de la celda?

Cuando utilizas la función BUSCARV de la forma simple, debes hacer coincidir todo el contenido de la celda con el criterio a buscar, incluyendo espacios y otros caracteres no imprimibles. De lo contrario, obtendrás el error #N/A.

Imagina una clase con 4 alumnos en la que cada uno de ellos tiene asignado un código:

nota_examen_excel_1

Como ves, el nombre de los alumnos está precedido por un código y un guion. En la columna B, se muestra la nota que obtuvo cada uno en un examen realizado la semana pasada.

En otra hoja, tengo solamente el código del alumno y la nota de otro examen realizado ayer.

nota_examen_excel_2

Si intento utilizar la función BUSCARV de una forma ortodoxa, voy a obtener el error #N/A que, en este caso significa, que la función ha sido incapaz de encontrar el criterio que he especificado.

nota_examen_excel_3

La solución más sencilla de conseguir que la función haga lo que yo quiero, es utilizando “caracteres comodín

¿Qué son los caracteres comodín?

Los caracteres comodín son capaces de sustituir a uno o varios caracteres. Puedes utilizarlos para crear criterios y filtros.

En un artículo anterior, en el que te hablé de los formatos de número personalizados, hablé también de este tipo de comodines.

  • ?: Sustituye a un único carácter.
  • *: Sustituye a cualquier número de caracteres.
  • ~ seguida de ? ó *: Permite incorporar la interrogación o el asterisco en el criterio.

Estos caracteres pueden utilizarse no sólo con BUSCARV, sino que podrás aplicarlo también con BUSCARX, INDICE+COINCIDIR, SUMAR.SI, ENCONTRAR, HALLAR o REEMPLAZAR.

Pero hoy vamos a tomar BUSCARV como ejemplo para que veas cómo funcionan los comodines en acción, ya que funcionan igual en cualquier función.

¿Cómo funcionan los caracteres comodín?

En el ejemplo de los exámenes de los alumnos, la fórmula que debería introducir en la celda C2 sería la siguiente:

=BUSCARV(A2&»*»;’Examen anterior’!A2:B5;2;0)

  • A2 es el contenido de la celda que se va a buscar.
  • & es el carácter de concatenación. Esto significa se buscará el contenido de la celda A2 junto con el contenido que venga detrás.
  • “*” es el carácter comodín que sustituye a cualquier número de caracteres.
  • ‘Examen anterior’!A2:B5 es el rango de celdas donde se buscará el criterio.
  • 2 es el número de la columna que se devolverá contando desde la columna que contiene el criterio.
  • 0 significa que quiero que encuentre exactamente el criterio.

Si introduzco la fórmula anterior, el resultado será el que espero ya que se buscará el código del alumno con cualquier dato que vaya detrás.

nota_examen_excel_4

¿Y qué ocurriría si el código del alumno estuviese tras el nombre? Aunque la fórmula cambiaría un poco, seguro que ya tienes una idea de cómo hacerlo:

=BUSCARV(«*»&A2;’Examen anterior’!A2:B5;2;0)

Sin duda creo que el uso de comodines es una técnica muy sencilla pero que nos puede resultar muy realmente útil en muchas ocasiones.

¿La conocías?

notas_examenes
Título: notas_examenes (965 clics)
Tamaño: 10 KB

Sergio

Sergio

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Sobre mí

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios… y son las culpables de que me guste el origami. +info.

¿De qué hablo aquí?

Consultoría plantillas Excel
Foro Excel
Ebook De 0 a 100 con macros y VBA

De 0 a 100 con macros y VBA

Esta oferta no es para siempre...

¡no la desaproveches!