4

Las funciones K.ESIMO.MAYOR y K.ESIMO.MENOR

Si te suenan las funciones MAX y MIN imagino que sabrás que sirven para hallar los valores máximo y mínimo en un rango de celdas. Pero ¿qué ocurre si quieres encontrar el segundo o tercer valor más alto o más bajo en lugar del máximo o el mínimo?

Para resolverlo, la forma más rápida es utilizar las funciones K.ESIMO.MAYOR y K.ESIMO.MENOR.

Las funciones K.ESIMO.MAYOR y K.ESIMO.MENOR

Las sintaxis de las dos funciones son iguales:

=K.ESIMO.MAYOR(matriz;k)
=K.ESIMO.MENOR(matriz;k)

  • Matriz: Es el rango de datos o matriz en el que se encuentra el valor enésimo que quieres extraer.
  • k: Es la posición (a partir de los valores mayor o menor) del dato que se va a extraer.

Te pongo dos ejemplos:

En una empresa se realizaron ventas de varios productos y se muestra su facturación. Para hallar el tercer importe más alto de la lista, debes utilizar la fórmula:

=K.ESIMO.MAYOR(B2:B6;E2)

Excel k.esimo.mayor función

Para conocer el tiempo que tardó el tercer corredor en una carrera, se utiliza K.ESIMO.MEJOR, ya que se parte del valor más bajo del rango:

=K.ESIMO.MENOR(B2:B6;E2)

Excel K.ESIMO.MENOR función

El dato obtenido en muchas ocasiones no es relevante. En estos ejemplos de poco sirve saber que del tercer producto se vendierno 83.678 €, sino más bien qué producto fue el tercero del que más ventas se obtuvieron.

Existen varias formas de conocer a qué producto corresponden esas ventas cuando el dato a buscar se encuentra a la izquierda…

=INDICE(A2:A6;COINCIDIR(E4;B2:B6;0))
=DESREF(B1;COINCIDIR(E4;B2:B6;0);-1)

Buscar con INDICE y COINCIDIR Excel
Buscar con INDICE y COINCIDIR k.esimo menor Excel

Estas son solo un par de ellas, seguro que a ti se te ocurren más. Incluso puedes utilizar BUSCARV.

Venga, es tu turno… ¿qué fórmula utilizas habitualmente para buscar datos que se encuentran hacia la izquierda?

¡Compartir es vivir!
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario 4 comentarios
LUIS PABLO GALVEZ HERRERA - 15/03/2019

excelente aporte, gracias

Responder
Carlos - 15/03/2019

hola Sergio, muchas gracias por compartir, en mi caso utilizo BUSCARV, sin embargo está fabulosa esta función y la pondré en práctica en algunas tareas especificas como por ejemplo buscar de una lista de costos de productos el 3ro de más costo ó el 3er de menor costo!!

Responder
    Sergio - 15/03/2019

    Ese es el objetivo de estas funciones, calcular posiciones que no son ni la primera ni la última. ¿Cómo utilizas BUSCARV para esto?

    Responder
Félix Falconi - 16/03/2019

Gracias por compartir. Lo uso en varios casos, pero en lo que mas, es para organizar listas luego de una recopilación de información de datos de estudiantes. Recibo la asistencia la obtengo en la hoja de calculo y aplico buscarV para reorganizar la lista en orden alfabético y así se quien no asistió a clases.

Responder

Escribe una respuesta:

Powered by WishList Member - Membership Software