Las funciones K.ESIMO.MAYOR y K.ESIMO.MENOR

Excel función k.esimo.mayor

Si te suenan las funciones MAX y MIN imagino que sabrás que sirven para hallar los valores máximo y mínimo en un rango de celdas. Pero ¿qué ocurre si quieres encontrar el segundo o tercer valor más alto o más bajo en lugar del máximo o el mínimo?

Para resolverlo, la forma más rápida es utilizar las funciones K.ESIMO.MAYOR y K.ESIMO.MENOR.

Las funciones K.ESIMO.MAYOR y K.ESIMO.MENOR

Las sintaxis de las dos funciones son iguales:

=K.ESIMO.MAYOR(matriz;k)
=K.ESIMO.MENOR(matriz;k)

  • Matriz: Es el rango de datos o matriz en el que se encuentra el valor enésimo que quieres extraer.
  • k: Es la posición (a partir de los valores mayor o menor) del dato que se va a extraer.

Te pongo dos ejemplos:

En una empresa se realizaron ventas de varios productos y se muestra su facturación. Para hallar el tercer importe más alto de la lista, debes utilizar la fórmula:

=K.ESIMO.MAYOR(B2:B6;E2)

Excel k.esimo.mayor función

Para conocer el tiempo que tardó el tercer corredor en una carrera, se utiliza K.ESIMO.MEJOR, ya que se parte del valor más bajo del rango:

=K.ESIMO.MENOR(B2:B6;E2)

Excel K.ESIMO.MENOR función

El dato obtenido en muchas ocasiones no es relevante. En estos ejemplos de poco sirve saber que del tercer producto se vendierno 83.678 €, sino más bien qué producto fue el tercero del que más ventas se obtuvieron.

Existen varias formas de conocer a qué producto corresponden esas ventas cuando el dato a buscar se encuentra a la izquierda…

=INDICE(A2:A6;COINCIDIR(E4;B2:B6;0))
=DESREF(B1;COINCIDIR(E4;B2:B6;0);-1)

Buscar con INDICE y COINCIDIR Excel
Buscar con INDICE y COINCIDIR k.esimo menor Excel

Estas son solo un par de ellas, seguro que a ti se te ocurren más. Incluso puedes utilizar BUSCARV.

Venga, es tu turno… ¿qué fórmula utilizas habitualmente para buscar datos que se encuentran hacia la izquierda?

¿Me ayudas a promocionar este contenido?

Share on facebook
Facebook
Share on google
Google+
Share on twitter
Twitter
Share on linkedin
LinkedIn
Consultoría plantillas Excel
Foro Excel
La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios... y son las culpables de que me guste el origami. +info.

¿Quieres ahorrarte horas de trabajo diario?

macros excel manual

Descarga este informe y aprenderás a crear tus propias macros de forma rápida y sencilla

INFORMACIÓN BÁSICA SOBRE PROTECCIÓN DE DATOS

Responsable: Sergio Andrés Celemín

Finalidad: Gestionar y enviar información de boletines y promociones a través de correo electrónico.

Legitimación: Consentimiento del interesado.

Destinatarios: Tus datos se encuentran alojados en mi hosting Hetzner Online GmbH.

Derechos: Puedes ejercitar en cualquier momento tus derechos de acceso,
rectificación, supresión, oposición y demás derechos legalmente establecidos a
través del email sergio@ayudaexcel.com.

Información adicional: Encontrarás más información en la política de privacidad.