Cómo usar BUSCARV hacia la izquierda

buscarv izquierda

Estoy seguro de que siempre que has buscado información sobre BUSCARV, has encontrado artículos que dicen que es imposible que la función devuelva un valor que se encuentre a la izquierda de la columna de búsqueda.

Y también estoy seguro de que cuando has creído encontrar uno, al hacer clic en el enlace, has comprobado que no te decían la verdad porque utilizaban las funciones INDICE + COINCIDIR (u otros cientos de combinaciones posibles).

Pues eso se acabó.

Hoy te mostraré una forma de utilizar BUSCARV que es capaz de devolver datos situados a la izquierda de la columna de búsqueda.

¡¡Con lo fácil que sería poder introducir números negativos en el argumento Columna de búsqueda!!

Bueno, vamos allá:

Aunque la protagonista de la fórmula es BUSCARV, me voy a ayudar también de otra útil función: ELEGIR.

En el siguiente listado aparecen los datos de una serie de personas dispuestos de esta forma:

BUSCARV izquierda Excel

Como ves, la columna ID está situada a la derecha del resto de datos.

Voy a utilizar BUSCARV para buscar un número en la columna ID y que me devuelva cualquiera de los otros datos. Como no es posible utilizar la versión simple de BUSCARV para buscar datos hacia la izquierda, voy a utilizar ELEGIR para invertir el orden de las columnas.

La fórmula final que utilizaré para buscar el ID para que devuelva el nombre de la persona será:

=BUSCARV($H$3;ELEGIR({2\1};$A$2:$A$78;$E$2:$E$78);2;0)

excel buscarv izquierda

  • Dato a buscar: Es el dato que quieres buscar y desde el cual se comenzará a contar el número de columna de búsqueda.
  • Se invierte el orden de las columnas: Aquí está la clave de la fórmula. La matriz (encerrada entre llaves) le dice al resto de argumentos de la función ELEGIR, cuál va en primer lugar y cuál en segundo.
  • Primera columna y segunda columna: Son rangos de celdas. En la primera se encuentra el dato que se va a devolver y en la segunda el dato buscado.
  • Columna de búsqueda: Es el número de columna donde se encuentra el dato a devolver.
  • Ordenado: Para hacer una búsqueda exacta o aproximada.

Como te vas a dar cuenta ahora, la columna de búsqueda siempre va a ser 2, ya que solo hay dos columnas que intervienen en la fórmula (la de búsqueda y la de resultado.

Para verlo más claro, te pongo otro ejemplo:

¿Cómo sería la fórmula si quisieras buscar la dirección de una de las personas sabiendo su ID?

Únicamente tendrías que sustituir el rango de la primera columna.

=BUSCARV($H$3;ELEGIR({2\1};$B$1:$B$77;$E$2:$E$78);2;0)

La única diferencia que existe sobre la fórmula anterior es la referencia a la columna de resultados. Tanto la columna de búsqueda como el número de columna sigue siendo el mismo.

excel izquierda buscarv

Para practicar o ver cómo he creado la fórmula, descarga el ejemplo que he utilizado:

BUSCARV izquierda Excel
Título: BUSCARV izquierda Excel (7066 clics)
Tamaño: 12 KB

Puedes ver otros trucos como este en mi manual BUSCARV y otras funciones de búsqueda.

¿Qué te parece? Comparte si te ha gustado.

¿Me ayudas a promocionar este contenido?

Share on facebook
Facebook
Share on google
Google+
Share on twitter
Twitter
Share on linkedin
LinkedIn
Consultoría plantillas Excel
Foro Excel
La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios... y son las culpables de que me guste el origami. +info.

¿Quieres ahorrarte horas de trabajo diario?

macros excel manual

Descarga este informe y aprenderás a crear tus propias macros de forma rápida y sencilla

INFORMACIÓN BÁSICA SOBRE PROTECCIÓN DE DATOS

Responsable: Sergio Andrés Celemín

Finalidad: Gestionar y enviar información de boletines y promociones a través de correo electrónico.

Legitimación: Consentimiento del interesado.

Destinatarios: Tus datos se encuentran alojados en mi hosting Hetzner Online GmbH.

Derechos: Puedes ejercitar en cualquier momento tus derechos de acceso,
rectificación, supresión, oposición y demás derechos legalmente establecidos a
través del email sergio@ayudaexcel.com.

Información adicional: Encontrarás más información en la política de privacidad.