Jump to content

Sumaproducto pero que una matriz no sea matriz si no una celda.


Recommended Posts

Hola, quería haceros una consulta que me está generando problemas.

Para calcular que orientación e inclinación de paneles solares es más óptima, tengo muchas combinaciones, entre orientación e inclinación (45 combinaciones). Tengo que restar la producción solar al consumo que tengo cada hora del año (8760 filas). Además estas combinaciones las tengo que multiplicar por diferentes números de placas fotovoltaicas. El caso es que si he conseguido hacerlo añadiendo columnas y columnas con los diferentes pasos, pero sólo con 4 combinaciones ya me está ocupando mucho el archivo y le empieza a costar calcular.

Había pensado utilizar el sumaproducto (u otra opción), que multiplique la potencia de las placas fotovoltaicas (que es una celda) por las diferentes producciones, pero sin pasar por muchas columnas, que me aumenta mucho el tamaño del archivo. Me resulta difícil explicarlo escrito, creo que en la excel que adjunto está más claro, he puesto la formula de forma manual de lo que haría (en colores azul y verde)

Y si fuese posible, también me gustaría filtrar estos datos por otra columna, por ejemplo que solo coja la hora 9. Está sombreado en amarillo.

¿Sabéis si hay alguna manera de hacer esta fórmula en una celda (o alguna más)?

Muchas gracias de antemano!

Sumaproducto_celda.xlsx

Link to comment
Share on other sites

Hola,

La fórmula =C9-(D9*C3) + C10-(D10*C3) + C11-(D11*C3)

la puedes sustituir así: =SUMAPRODUCTO((C9:C11)-(D9:D11*C3))

(te pongo sólo 3 factores para que puedas comprobar que da el mismo resultado. Modificando 11 por la última cifra que necesites evaluar, tendrás el resultado deseado).

En cuanto a la hora, prueba con: =SUMAPRODUCTO((B9:B56=I3)*((C9:C56-D9:D56*C3)))

...a ver si es lo que necesitas.

Saludos,

Link to comment
Share on other sites

Muchas gracias Víctor! Va genial, incluso he conseguido hacer que sume por separado los valores positivos y negativos. Voy a seguir haciendo pruebas. Gracias de nuevo.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Privacy Policy