Jump to content

Ejecución de Macro en Hoja Protegida


Recommended Posts

Hola Estimados, pido Disculpas por el Titulo del tema, vi que ya estaba con anterioridad, pero bloqueado, lo que quiero saber es que si hay alguna manera de que al ejecutar la macro en la hoja protegida me aparezca en la cinta de opciones habilitados la fuente el tipo de letra combinar celdas entre otros, ya que al ejecutar la macro aparecen todas esas opciones bloqueadas.

 

 

adjunto archivo e imagen

Captura de pantalla (4)_LI.jpg

foro.xlsm

Link to comment
Share on other sites

Solo una Consulta Maestro Antoni; será posible que al ejecutar la macro se proteja solamente por ejemplo de A1 a AC20???? y que después de ese rango hacia abajo quede desprotegido..?

Link to comment
Share on other sites

La protección es a nivel hoja, no obstante se puede cambiar la protección de la hoja al seleccionar una celda.

Revisa el adjunto, he añadido esta macro en la hoja:

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
If Target.Row > 20 Then 'Protección total hasta la fila 20
   ActiveSheet.Protect "prueba", AllowFormattingCells:=True
Else
   ActiveSheet.Protect "prueba", AllowFormattingCells:=False
End If
End Sub

 

foro (1).xlsm

Edited by Antoni
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Crear macros Excel

  • Posts

    • Antoni muchas gracias, si me sirvió estaba poniendo mal la celda.. Te agradezco mucho tu apoyo 🙂 Excelente máster 👌
    • Buenas tardes, ya lo hice y no me permite
    • Buenas tardes integrantes de este prestigioso foro, en esta ocasión recurro a uds para que me brinde su apoyo con la formula que vengo trabajando =SI(G8="";"";SUMA(--(FRECUENCIA((C$8:C$2507=G8)*D$8:D$2507;(C$8:C$2507=G8)*D$8:D$2507)>0))-1) el cual me esta mostrando error de valor cuando agrupo el valor fecha de la celda D8 hasta D2507, que proviene de la pestaña SORT que se ubica en la celda B2, y teniendo 2 alternativas para evitar el error de valor que serían: *REEMPLAZAR EL PARÁMETRO $2507 POR $792    "=SI(G8="";"";SUMA(--(FRECUENCIA((C$8:C$2507=G8)*D$8:D$2507;(C$8:C$2507=G8)*D$8:D$2507)>0))-1)"   ubicada en la celda K8, o *ELIMINAR LAS FILAS EN BLANCO DESDE LA A793 HASTA LA A2507 quedando los valores obtenidos en la celda J8 Desde ya agradezco su atención, para lo cual adjunto archivo. FORMULA PARA CONTAR DIAS TRABAJADOS.xlsm
    • `Hola, Para contar las celdas de un rango, que cumplen con determinado criterio puede leer el uso de la siguente función. =CONTARI.SI.CONJUNTO( https://support.microsoft.com/es-es/office/función-contar-si-conjunto-dda3dc6e-f74e-4aee-88bc-aa8c2a866842    
    • Buen dia, requiero del conocimiento y soporte  de cada uno de ustedes, tengo una columna con N filas, en esas filas ubicare valores (N) deseo el otra celda que cuente los valores estipulados en el siguiente rango y los lleve a la celda destinada para tal fin. 3.000.000  hasta  4.999.999 es sido claro compañeros   les agradezco  
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy