Jump to content

Error en tiempo de ejecución (error 13)


Recommended Posts

Buenas a todos los que pertenecemos a este gran foro.

Desde hace unos 4 o 5 días me arroja el error 13, porque hasta la fecha la macro corría bien, por mas que he leído en el foro no doy con la solución.

en rojo es la linea  que me arroja el error.

Private Sub Matricula_AfterUpdate()
If WorksheetFunction.CountIf(Hoja12.Range("C:C"), Me.matricula.Value) = 0 Then
MsgBox "Matricula Incorrecta"
Me.matricula.Value = ""
Exit Sub

End If
With Me
nombre = Application.WorksheetFunction.VLookup(CLng(Me.matricula), Sheets("AGENTES").Range("C3:D3000"), 2, 0)

End With

End Sub

error.png

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • 28 ¿Te parecen útiles los tips de las funciones? (ver tema completo)

    1. 1. ¿Te parecen útiles los tips de las funciones?


      • No
      • Ni me he fijado en ellos

  • Ayúdanos a mejorar la comunidad

    • Donaciones recibidas este mes: 0.00 EUR
      Objetivo: 130.00 EUR
  • Files

  • Download Statistics

    • Files
      150
    • Comments
      88
    • Reviews
      25

  • Crear macros Excel

  • Posts

    • Gracias a @Israel Cassales que me advirtió de un fallo en la formula del archivo, pero el procedimiento VBA si esta bien Lo correcto es  =INDICE(B2:N11,COINCIDIR(Q1,A2:A11,),COINCIDIR(P1,B1:N1,)) Es decir, estaba invertido la fila y columna, como argumento de INDICE  
    • Gracias por la confianza, a lo que yo me refiero es que en la formula INDICE ves que después de la matriz, sigue la fila y luego la columna, como en el ejemplo hace referencia a la celda, ésta toma primero la columna y después la fila. Eso hace que el resultado no sea el mismo con respecto al que da el ejemplo correcto del VBA.   Y como dices, esperar la respuesta, que la opción del VBA debería cumplir con la solicitud sin problema. Saludines.  
    • Hola Israel Tranquilo nada de entrometido... he visto el archivo y no lo veo invertido o no entiendo exactamente a que te refieres Esperemos que el consultante, suba su propio libro, para ver claramente su caso ¡Gracias por el aviso!   Saludos   
    • Saludos cordiales @Gerson Pineda Lamento si escribo en tu presentación pero no me dejo mandarte algún mensaje, me dice que estoy limitado a 0 mensajes por día 😁 No quiero parecer entrometido y me disculpo de antemano pero me pareció bien el avisarte sobre el detalle en el tema siguiente: Extraer valor de una tabla Las referencias de columna y celda en el COINCIDIR están invertidas devolviendo un valor diferente al correcto como te da la sentencia en VBA. Saludines
    • ¡Hola! ¿Como estan? Me gustaría de saber cómo hacer un hipervínculo dinámico, que lleve a un sitio web externo, al elegir una opción de una lista desplegable. Es decir, cada opción que elijo de la lista desplegable, el hipervínculo cambiará. EN EL CASO DE LA IMAGEN A CONTINUACIÓN, QUIERO QUE CADA NOMBRE DE EJERCÍCIO QUE ELIJO DE LA LISTADESPLEGABLE 'D3' , EL HIPERVÍNCULO DE I3 CAMBIE AL VÍNCULO DEL VIDEO CORRESPONDIENTE AL EJERCICIO EN YOUTUBE:
  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Privacy Policy