Jump to content

Número de semana


lphant

Recommended Posts

Buenas tardes;

Por favor, ayuda......

Hasta este año no he tenido problemas con el número de semana en las macros que tengo hechas, digo hasta este año porque hoy al actualizar y meter los datos del año que viene .....😯 No sale el número de semana que tendría que salir.

El número de semana le estoy sacando de la siguiente forma:

día="01/01/2021"

Numero_semana=format(format(día,"ww"),"0#")

El número de semana resultante debería de ser 53 pero me está dando 01.

Como puedo solucionarlo.

Estoy con el móvil, si necesitais el Excel con el ejemplo enciendo el ordenador y lo subo.

Muchísimas gracias.

 

Link to comment
Share on other sites

Te dejo una función que obtiene el número de semana del lunes de la semana que corresponde a la fecha.

Sub ObtenerSemana() 'Ejemplo de llamada a la función Semana
NumSemana = Semana(CDate("01/01/2021"))
End Sub

Function Semana(Día As Date)
Semana = WorksheetFunction.WeekNum(Día - Weekday(Día, vbMonday) + 1)
End Function

 

Edited by Antoni
Link to comment
Share on other sites

Hace 9 horas, Antoni dijo:

Te dejo una función que obtiene el número de semana del lunes de la semana que corresponde a la fecha.


Sub ObtenerSemana() 'Ejemplo de llamada a la función Semana
NumSemana = Semana(CDate("01/01/2021"))
End Sub

Function Semana(Día As Date)
Semana = WorksheetFunction.WeekNum(Día - Weekday(Día, vbMonday) + 1)
End Function

 

Muchas gracias @Antoni

Voy a probarlo ahora mismo.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Crear macros Excel

  • Posts

    • Hola 2 horas de proceso ufff me parece mucho tiempo... Si ese proceso te congela momentáneamente Excel, no te queda mas que usar una virtual   Saludos 
    • Hola El comportamiento de las funciones utilizando formato de tabla estructurada, cambia respecto a las referencias Una forma sencilla de superarlo es usar referencias relativas de esas celdas Mira =SUMAR.SI.CONJUNTO(J$7:J7,C$7:C7,$C7)   Saludos 
    • ¡Hola, @gogua! El tema de los rangos expandibles en tabla tienen un comportamiento "peculiar" cuando llegan al final de la misma.  Entonces, una opción para trabajar con ellos es "jugar" con las referencias estructuradas.  Tu fórmula, al tener un solo criterio, puede usarse con la función SUMAR.SI de la siguiente forma: =SUMAR.SI(C$7:[@CODIGO];[@CODIGO];J$7:[@[Ent./Sal.]]) ¡Pruébala y comentas! ¡Bendiciones!
    • Hola ,  A ver si soy capaz de explicarme.  Estoy intentando hacer un inventario "sencillo" para la gestión de EPIs y Vestuario Laboral de mi empresa.Más o menos tengo lo que necesito aunque poco a poco iré añadiendo cosas Una libro excel con 2 hojas (ARTICULOS  , ENTRADAS Y SALIDAS). En ARTICULOS introduzco los productos con un codigo maestro y me sirve para ver el stock actual de todos los productos. En ENTRADAS Y SALIDAS voy introduciendo los articulos utilizando el CODIGO de forma manual o utilizando la "lupa" que hay encima de la columna Ent./Sal. En la columna Existencia actual lo que pretendo es ven en cada momento , haya entrada o salida de artículo, como estába el inventario en ese momento (fecha). Para ello utilizo la formula.  =SUMAR.SI.CONJUNTO($J$7:J7;$C$7:C7;[@CODIGO]) y este código se replica en toda la columna de forma automática.   Pero me ocurre, que cuando inserto un nuevo registro, ya sea manual o con la lupa, esa formula me la cambia y me hace el sumatorio de toda la columna  para el CODIGO en concreto en la posición-fila anterior y ya no me va haciendo lo que pretendo, sino que me hace el inventario total.     Os dejo el fichero, que quizás se pueda ver mejor lo que quiero explicar y su funcionamiento.   gracias     Inventario_01 - copia.xlsm
    • buenas tardes,    tengo una macro que trabaja con datos, que los extrae de otras planillas y tablas web, cuando hago correr la macro, esta se demora aprox 2 horas en completar su proceso, lo que me imposibilita de trabajar en otras planillas existe alguna manera de abrir otro excel y poder utilizarlo a la par? tal vez con una maquina virtual o algo asi?   muchas gracias por su ayuda
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy