Jump to content

Llenado de un Combo que no muestra la lista


Recommended Posts

Para desplegar la lista de información en un ComboBox no dependiente y del cual tampoco depende ninguno otro (concretamente para una lista de Proveedores), he escrito el siguiente código, y sin embargo no logro que me despliegue la lista referida.

Private Sub cmbVendNameR_Enter()
Sheets("Proveedores").Select
Range("C29").Select

Do While Not IsEmpty(ActiveCell)
cmbVendNameR.AddItem ActiveCell
ActiveCell.Offset(1, 0).Select
Loop

End Sub[/CODE]

¿Que estoy haciendo mal? Gracias anticipadas

Anexo el archivo correspondiente.

EMR.xls

Link to comment
Share on other sites

¿ Estás seguro que es C29 el rango de partida ? ¿ No será C2 ?

El archivo me da error, pero lo he probado con otro archivo y la macro funciona correctamente, aunque también te digo que el evento que usas no es el mas adecuado, ya que si no entras, no se carga, y si entras varias veces, tal como lo tienes, se irán añadiendo los proveedores al final de la lista cada vez.

Llena los combobox que vas a usar como listas fijas en el evento Initialize o Activate del formulario.

Nota:

En una versión anterior de tu archivo el combobox en cuestión tiene la propiedad .Locked = True, debes ponerla a False.

Link to comment
Share on other sites

Mil disculpas, ya elimine el código que había introducido para el llenado del combo (mismo que refiero en mi primer mensaje del tema), e inserte la siguiente linea:

Me.cmbVendNameR.RowSource = "Proveedores_"[/CODE]

No se si tenga algo que ver pero el nombre real del formulario es UserForm1, en tanto que por error, desde un principio yo teclee en el código para el evento Activate solo UserForm.

Esto lo refiero debido a que a pesar de que el código que me enviaste para corregir el problema de la falta de empate entre la última fila de datos y la última fila con datos informados me funciono perfectamente cuando el código utilizado para el evento Activate mencionado se refiere a UserForm, cuando le cambio por UserForm1, dicho código ya no opera y no me despliega los datos de Numero de registro y Fehca actual en el formulario.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

Privacy Policy