Jump to content

Bastet

Members
  • Content Count

    4
  • Joined

  • Last visited

Everything posted by Bastet

  1. ¡Buenos días, Germán y Grueda! Aquí vuelvo... Estoy intentando aplicar vuestras sugerencias. Germán: De tu fórmula, no entiendo una parte, y es la que, una vez adaptada tu fórmula a mi tabla real (que es más extensa que la del ejemplo que puse), hace que falle en el resto de columnas excepto en la primera... Esta parte es: =COLUMNAS($A:A) Por lo que he visto, de alguna manera es la parte que discrimina los datos por los meses. Pero no consigo ver a qué hace referencia ni cómo lo que quiere obtener. ¿Podrías explicarme tu lógica? Si la llego a entender quizá pueda adaptar la fórmula, o si no, poner otra manera en la que discrime por meses... ¡Gracias! P.D.: Adjunto el archivo con las columnas de mi tabla original. - - - - - Mensaje combinado - - - - - Después de estar a la mañana buscando una solución, al final he escrito lo siguiente en la fórmula: =SUMAPRODUCTO((MES('Facturas Proveedores'!$C$2:$C$124)=1)*('Facturas Proveedores'!$E$2:$E$124=$A3)*('Facturas Proveedores'!$G$2:$G$124)) Y he ido cambiando =1, por el número del mes que busco. Este dato me lo obtiene de la columna del mes, por lo que podría prescindir de la columna mes y utilizar sólo la columna fecha. Tengo que revisar toda la tabla, pero parece que funciona. 2012_problema-discriminar-mes.rar
  2. Hola Germán: ¡¡¡¡Lo primero, gracias por la celeridad!!!! Es exactamente lo que buscaba hacer, ¡perfecto! Desconozco el funcionamiento de esa fórmula SUMAPRODUCTO, pero este fin de semana me pongo a entender la fórmula tal y como me las has sugerido. Estimo muchísimo tu ayuda. ¡Gracias! :congratulatory:
  3. Gracias, Germán, por la puntualización. Adjunto el archivo, a ver si alguien me pudiera ayudar... Muchas gracias de antemano, porque le doy vueltas a la fórmula, pero no consigo ver por qué no funciona. 2012_Problema-formula-SUMAR-SI-CONJUNTO.rar
  4. Buenas a todos: Os quisiera plantear una cuestión a ver si alguien me ayuda a resolver la fórmula: Tengo dos tablas en dos hojas Excel diferentes: TABLA 1 (hoja 1 denominada "Facturas Proveedores"): recoge una serie de facturas, con columna de fecha (dd/mm/aaaa), importe de cada factura por fila, nombre del proveedor, entre otras columnas con otros datos. TABLA 2 (hoja 2 denominada "Proveedores MENSUAL"): recoge el listado de proveedores y otra columna donde quisiera que se sumara por cada mes el total de todas las facturas emitidas por ese proveedor. Por tanto, intento utilizar la fórmula SUMAR.SI.CONJUNTO con dos condiciones: 1) Que se obtenga el mes del rango de fechas de la TABLA 1, para determinar la suma para ese mes en la TABLA 2. 2) Que del listado de proveedores que se repite en las diferentes facturas en la TABLA 1 coincida con el proveedor para el que se quiere sumar todas sus facturas del mes, para la TABLA 2. En la celda de la hoja 2 que quiero sumar el total de los importes de las facturas de ese proveedor, he puesto la siquiente fórmula: =SUMAR.SI.CONJUNTO('Facturas Proveedores'!G2:G124;'Facturas Proveedores'!C2:C124;MES(1);'Facturas Proveedores'!E2:E124;A3) Pero me da como resultado cero (y manualmente compruebo que no es así, claro, por en enero ese proveedor tiene facturas). ¿Cómo podría solucionarlo? Gracias de antemano.
×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png