Jump to content

jbpinto85

Members
  • Content Count

    7
  • Joined

  • Last visited

About jbpinto85

  • Rank
    Newbie
  • Birthday 11/15/1985
  1. Re: Buscarv gracias!! aunque ya lo habia conseguido de otra forma, lo dejo aqui por si es de interes: =SI(ESERROR(BUSCARV('Tabla Mediciones'!K14;Menfis!A1:I600;9;0));0;BUSCARV('Tabla Mediciones'!K14;Menfis!A1:I600;9;0))+SI(ESERROR(BUSCARV('Tabla Mediciones'!K15;Menfis!A1:I600;9;0));0;BUSCARV('Tabla Mediciones'!K15;Menfis!A1:I600;9;0))+SI(ESERROR(BUSCARV('Tabla Mediciones'!K16;Menfis!A1:I600;9;0));0;BUSCARV('Tabla Mediciones'!K16;Menfis!A1:I600;9;0))+SI(ESERROR(BUSCARV('Tabla Mediciones'!K17;Menfis!A1:I600;9;0));0;BUSCARV('Tabla Mediciones'!K17;Menfis!A1:I600;9;0))+SI(ESERROR(BUSCARV('Tabla Mediciones'!K18;Menfis!A1:I600;9;0));0;BUSCARV('Tabla Mediciones'!K18;Menfis!A1:I600;9;0))
  2. Hola, tengo un problemilla con la función BUSCARV.El codigo es el siguiente: =BUSCARV('Tabla Mediciones'!K14;Menfis!A1:I600;9;0)+BUSCARV('Tabla Mediciones'!K15;Menfis!A1:I600;9;0)+BUSCARV('Tabla Mediciones'!K16;Menfis!A1:I600;9;0)+BUSCARV('Tabla Mediciones'!K17;Menfis!A1:I600;9;0)+BUSCARV('Tabla Mediciones'!K18;Menfis!A1:I600;9;0) Busco el valor K14, por ejemplo, de la hoja Tabla Mediciones en una matriz de la hoja Menfis (en concreto en A1:I600). El problema viene cuando BUSCARV no encuentra el valor indicado en K14 en la hoja Menfis; me devuelve N/A y no suma el resto de BUSCARV que tengo en el codigo. Entonces me gustaria saber como puedo hacer para que si no encuentra el valor buscado devuelva 0 y asi poder realizar la suma de todos los BUSCARV que aparecen en el código de arriba.
  3. Hola!! tengo una hoja programada que compara 2 columnas pero necesito que no diferencia entre mayusculas y minusculas, es decir, si pone 'Abrazadera' que lo considere igual a 'abrazadera'
  4. Respuesta: Buscar primera fila vacia e insertar datos a partir de ahi No, copio los datos de Cables P a Inicio (eso me sale bien), lo unico que necesito poder hacer el proceso mas veces y que no sobreescribiera a lo existente, de ahi que necesite buscar la fila vacia inmediatamente posterior a la ultima fila escrita.
  5. Respuesta: Buscar primera fila vacia e insertar datos a partir de ahi gracias por contestar tan rapido. Se me ha olvidado comentar un detalle, yo traslado datos de la pestaña "Datos P" a la pestaña de otro libro llamada "Inicio", pero me da error al poner Set ws = Worksheets("Inicio") Realmente no se donde tendria que colocar tu codigo dentro del mio para que lo reconociera bien....
  6. Hola necesitaria saber como buscar la 1ª fila vacia dentro de mi hoja, y a partir de ahi insertar unos datos (esto lo hago con la siguiente macro), es decir, necesito que mi boton haga todo esto cuando encuentre una fila en blanco (y nunca antes de la fila 5 a poder ser, ya que ahi tengo escritos unos encabezados): Sub Botón1_AlHacerClic() 'extraer de otro excel, hoja inicio path_fichero = Range("B1").Value Workbooks.Open Filename:=path_fichero Sheets("Cables P").Activate Dim fila As Integer With ActiveWorkbook.Sheets("Cables P") For fila = 5 To .Range("d65536").End(xlUp).Row Select Case LCase(.Range("d" & fila)) Case Is >= 3 Workbooks(Range("B4").Value).Worksheets("Inicio").Range("a" & fila).Value = .Range("d" & fila).Value Workbooks(Range("B4").Value).Worksheets("Inicio").Range("b" & fila).Resize(, 2).Value = .Range("e" & fila).Resize(, 2).Value Workbooks(Range("B4").Value).Worksheets("Inicio").Range("c" & fila).Resize(, 2).Value = .Range("f" & fila).Resize(, 2).Value Workbooks(Range("B4").Value).Worksheets("Inicio").Range("d" & fila).Resize(, 2).Value = .Range("g" & fila).Resize(, 2).Value Workbooks(Range("B4").Value).Worksheets("Inicio").Range("e" & fila).Resize(, 2).Value = .Range("h" & fila).Resize(, 2).Value Workbooks(Range("B4").Value).Worksheets("Inicio").Range("g" & fila).Resize(, 1).Value = .Range("u" & fila).Resize(, 1).Value End Select Next End With Workbooks(Range("B4").Value).Worksheets("Inicio").Range("a5:g1000").SpecialCells(xlCellTypeBlanks).Delete 'borrar filas en blanco hoja inicio end sub Muchas gracias de antemanoo!!!!!!!!!
  7. Buenas!!! tengo una hoja excel programada en vba, algo sencillo, y me gustaria mejorarla un poco. Mi hoja sirve xa insertar filas una vez rellenas ciertas celdas, busca esas celdas e inserta debajo de cada una el nº de filas q yo le diga. En esas filas insertadas me escribe unas unidades que tengo en otra pestaña. Me gustaria colocar unas casillas d verificacion xq no para todos los casos necesito escribir todas las unidades Por ejemplo: (va sobre señales ferroviarias) Si la señal es AVANZADA solo necesito insertar 2 filas con los valores IFP,PREVIA Si la señal es ENTRADA necesito insertar 3 filas con los valores IFP,PREVIA,ASFA Habia pensado en colocar 2 casillas de verificacion donde decirle q tipo de señal es, y a partir de ahi q coja las unidades necesarias a insertar Muchas gracias!!
×
×
  • Create New...

Important Information

Privacy Policy