Jump to content

eugeniocol

Members
  • Content Count

    532
  • Joined

  • Last visited

  • Days Won

    2

eugeniocol last won the day on August 24

eugeniocol had the most liked content!

About eugeniocol

  • Rank
    Advanced Member
  • Birthday 06/06/1975

Converted

  • Campos
    ;

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Gracias. Ando un poco liado, pero en cuanto pueda la pruebo. Salud2...
  2. Y una macro para solo el booque L:R hasta fila 700.000 ??? que pueda acoplarse para contar coincidencias 3,4 y 5, pero individualmente no que cuente a la vez 3,4 y 5. Salud2....
  3. En el libro este ejemplo 1º parece ok, pero..... lo paso al libro mas real y no va. Veras que en Hoja1 las columnas a rellenar en Naranja la dejo en blanco , le das al boton donde pone tu nombre y lo veras. El libro pesa un poco lo tengo que poner en este enlace https://www.dropbox.com/s/m8ews9s73tn5fgh/CONTAR%20COINCIDENCIA%20PLANTILLA%20ORIGINAL.rar?dl=0 Salud2....
  4. A ver ahora. Mira Hoja 2 Formula en R L: R en fila 2 busca contar cuatro coincidencias con C: H encontrando las coincidencias en fila 5 y 8, resultado en R2 =2 L: R en fila 5 busca contar cuatro coincidencias con C: H encontrando las coincidencias en fila 7, pero……. resultado en R2 =0 ¿??? Sé que si pongo en })=4)) esto })=5)) pues cuenta 1, pero como busco contar 4 coincidencias ¿?? Y la segunda parte es buscar mayor rapidea a esta macro con grabadora. Y en Hoja 1. Formulas visibles en R y Z Plantilla original con la macro por grabadora, que tomo la fórmula en color amarillo como referencia para correrla a mano y después copio pego a valores para que el libro sea menos pesado al abrirlo de nuevo. Son 150.000 mínimo filas x 10 bloques. Y como ya comente al ejecutar la macro de grabadora por bloque 50 minutos y a mano bloque a bloque puf…….. Espero que se entienda ahora. Subo Libro. Un Saludo. Foro CONTAR COINCIDENCIAS_2.xlsm
  5. Buenas de Nuevo. Tengo esta macro hecha por mí con grabadora (no doy más de sí) trabaja con esta formula =SUMA(N(MMULT(N(CONTAR.SI(DESREF(C$5:H$5;FILA(C$5:C$10000)-FILA(C$5););$L1:$Q1)>0);{1;1;1;1;1;1})=4)) Para contar coincidencias de 2, 3, 4, 5,6 números de las familias en de valores de L: CL con 😄 H El rango real es mínimo en L: CL es de 150.000 claro cada grupo tarda +- 50 minutos, habría otra macro que fuese mucho más rápida ¿? Ahora tengo otra sorpresa que acabo de ver y esta fórmula la daba por buena y es que veo que no hace la función que yo pensaba. Ejemplo: EN L:R SEGUNDA FILA DEBERIA SER EN R 1 COINCIDENCIA DE 4 NUMEROS CON FILA 5 DE C:H Subo Libro. Salud2.... Foro CONTAR COINCIDENCIAS_2.xlsm
  6. Perdon por la tradanza. Pensaba que era sencilla la explicaion sin mas. Bueno subo libro. Hoja 1 datos a copiar. Hoja2 destino de copia con criterio >0 en R. Hoja2,Boton MACRO encontrada en san google funciona Ok, pero cuando la meto a rango 150.000 se eterniza en tiempo de ejecucion. Un Saludo. Foro copia con criterio.xlsm
  7. Gracias. Y si quiero contar 3 y 4 ?? que no se hacer esto: =SUMA(N(MMULT(N(CONTAR.SI(DESREF(B$2:G$2;FILA(B$2:B$33)-FILA(B$2););$K2:$P2)>0);{1;1;1;1;1;1})>=3))+ =SUMA(N(MMULT(N(CONTAR.SI(DESREF(B$2:G$2;FILA(B$2:B$33)-FILA(B$2););$K2:$P2)>0);{1;1;1;1;1;1})>=4)) En la columnas hay valores por encima del 4 y solo quiero contra el 3 y 4 Salud2....
  8. Me da error en End With De todas formas no entiendo varias cosas en la macro 1º No ve diferenciar entre hoja origen y destino, solo hay Hoja1 2º Si el rango a copiar es L:R, esta orden en la macro Range("A65536") Se refiere a la hoja de la copia ??? Salud2...
  9. Me doy cuenta que la explicación que doy es incompleta. El rango a copiar es ejemplo L2:R50, en R hay valores de 0 en adelante solo quiero que copie las filas que R>0 Salud2….
  10. Hola buenas. Necesitaria una macro para copiar pegra de una hoja a otra con un criterio. Copiar pegar L:R si en R >0 Salud2.
  11. Hola buenas. Tengo esta fórmula en Q, cuenta las coincidencias de K: P de 3, 4,5 y 6 valores S en B: G. En Q2 se supone que tiene que contar 3 coincidencias como resultado da 8, repasando el tema veo que hay 10 coincidencias ¿?? Columna I. El mismo tema en Q3 resultado 1 y hay 2 coincidencias columna J. No sé qué estaré haciendo mal ¿?? Salud2… Foro contar coincidencias.xlsm
×
×
  • Create New...

Important Information

Privacy Policy