Jump to content

LarzixCrew

Members
  • Posts

    15
  • Joined

  • Last visited

  • Country

    Spain

Everything posted by LarzixCrew

  1. funciona pero no hace lo que quiero que haga.. que no me cambie los códigos, en la que prueba que has hecho vuelve a introducir la misma referencia "Prueba" y verás que no sale lo mismo la segunda vez y si lo haces con nuevas referencias cada nueva referencia cambia la anterior. Y es justo lo que no debe pasar. Pero, ya lo he hecho de otra forma y ya está todo okay.
  2. He probado con esta alternativa pero no me funciona, ya que no me relaciona los código de productos correctamente cada vez que introduzco un nuevo producto en en la celda E5 se cambian los códigos anteriores. Esta es la formula que uso, y no se cambian los códigos, lo malo es que son rangos fijos. Como puedes ver aquí los códigos ya cambian y estaría mal. Como puedes ver cada vez que introduzco un nuevo producto se cambian los código anteriores. No puedo usar esta solución, no en este caso. gracias. Puedes probarlo en el archivo adjunto.
  3. Muchas gracias. No conocía lo de [#Todo]. Entiendo lo que hace ( indicarle a la formula que busque en todo el rango de la tabla) podrías decirme si tiene otras aplicaciones fuera de las tablas insertadas? .. Gracias.
  4. Hola buenas a todos. No sé si es que estoy pasando por alto algún concepto básico, pero no sé como puedo solucionar esto que parece tan sencillo. Quiero usar tablas con la formula BuscarV, pero me da error... no funciona, pero si uso os rangos de celda en vez de las tablas insertadas entonces si funciona. No entiendo nada. dejo las capturas y el archivo Las capturas pertenecen a la hoja llamada "ENTRADAS" Quiero usar las tablas insertadas para que la formula encuentre o coja los nuevos valores que se vaya introduciendo de forma automática, es decir que no tenga que modificar la formula cada vez que entre una nueva referencia y el rango de datos aumente. Pero no sé porqué no funciona. Esta es la formula que quiero usar y no funciona Esta es la formula que estoy usando y que sí funciona pero que no quiero. Muchas gracias a todos. PANDORA V_0_0_1.xlsm
  5. Muy buenas a todos. Muy seguramente será un error estúpido pero no veo o no detecto el problema. Y es que la macro que tengo en el botón (guarda) me tira error si uso una tabla don introduce los datos, pero si la quito entonces la macro funciona a la perfeción. Os lo explicaré con capturas. Aquí se puede ver el lugar donde la macro debe introducir los datos, como se puede ver...No hay tabla alguna insertada.(captura de arriba) Ahora como podéis ver si se ha insertado una tabla, y nos dirigimos a la hoja "ENTRADAS", donde está la macro ( captura de arriba) Primero seleccionar la celda "E5"( recuadro rojo grande), después click en botón buscar y seleccionar cualquier referencia de la lista que os aparece en el formulario de búsqueda ( ventana emergente que os aparecerá). Después en la celda "F5"(recuadro rojo pequeño) poner una cantidad... por ejemplo 5. Y por último le dais al botón guardar. ( captura de arriba ) Y como se puede observar, salta el error que aparece en la captura. Os recuerdo que este error solo aparece si inserto una tabla en la hoja llamada "Registro PMP", al quitar la tabla este error no aparece, y la macro no da error. (captura de arriba) Os dejo la captura del código de la macro, que como se aprecia está en "Módulo 3" ( captura de arriba) Aquí se aprecia el error que tira la macro al ejecutarse, y es que no inserta la nueva fila en la hoja "Registro PMP"( captura de arriba) Se puede ver, que sí introduce los datos, pero no termina de ejecutarse la macro y no inserta la fila. Hasta aquí este primer problema. Ahora viene otro muy **maravilloso**, pero que tampoco entiendo como solucionarlo... Y es que he fijado una celda con "$" pero al insertar la nueva fila la macro, la celda se mueve y no sirve de nada fijarla. Os pongo capturas como es costumbre. Se puede ver que he fijado la celda "J10" de la hoja "Registro PMP". ( captura de arriba) Si vamos a la hoja "ENTRADAS" y hacemos el procedimiento explicado arriba para esta hoja, y le damos al botón guardar ( pero esta vez si la tabla de la hoja "Registro PMP" para que no salte el error anterior) Como se aprecia al insertar la macro una fila, se mueve la celda que he fijado en "W5" y la celda que he fijado es $J$10, pero como se aprecia ahora es $J$11. Para poder ver la tabla completa desliza la barra de desplazamiento. Este es el error **maravilloso** que no sé solucionar. Muchas gracias por leer este periódico de explicación XD, pero por si las moscas lo detallo todo. Copia de PANDORA V_0_0_1.xlsm
  6. Si el usuario anterior me ayudó mucho, y está resuelto. Te doy las gracias por tu interés en mi duda. Muchas gracias.
  7. Muchísimas gracias por tu ayuda, y muchísimas gracias por tu pronta respuesta. De verdad muchas gracias.
  8. Hola a todos, Estoy intentando aplicar los formatos condicionales que se aprecian en la captura, pero Excel no hace nada. *El archivo no es compartido *Las celdas tienen formato "General" es decir no definido *Los formatos condicionales se han definido con formulas simples tipo : J6=0, J6<0; J6>0; La dinámica es que cuando la celda ( recuadro Rojo) cumpla con alguno de los formatos condicionales aplicados en la celda (recuadro Azul) entonces la la celda (recuadro Azul) Cambie de color Nunca he tenido, este problema, de hecho tengo otro libro de Excel donde funciona perfectamente. Os adjunto el archivo, podéis encontrar los formatos condicionales en la pestaña "Laboratorio(Alertas)" Maquinas año 2020.xlsm
  9. Sí es exactamente o que estaba haciendo, ya está todo resulto ayer estaba muy saturado y me ataqué en un problema muy estúpido. En cuanto al buscado, te adjunto mi solución ( es un poco diferente) pero lo bueno es que funciona perfectamente. Esta semana que viene estudiaré tu código con detenimiento para robarte conocimiento XD Muchas gracias. PD: Te adjunto le archivo para que puedas ver mi solución Maquinas año 2020.xlsm
  10. Muchas Gracias Antoni, Al final entendí lo que me decías ayer, solo que estaba ya muy saturado y algo tan sencillo como es no lo captaba, pero esta mañana lo he resuelto y ya funciona. Voy a ver tu solución a ver si lo hemos resuelto igual o puedo aprender algo nuevo. Muchas gracias por tu ayuda.
  11. Muchas gracias, Sí tienes razón, luego lo miré con calma después de tomar un descanso y entendí lo que quería decir, solo que ya estaba saturado y hasta algo tan sencillo como eso me parecía complicado. Gracias.
  12. No recuerdo leer tu respuesta en otro foro, lo miraré. te adjunto el archivo para que puedas verlo. Yo uso Excel del 2019, lo digo por si te afecta en algo. Respecto a lo que dices. No sé como quitar lo de TextBox para que aparezca la variable. Y luego no sé como se quita lo de On Error Resume Next. Gracias por la ayuda. PD: Como verás hay cosas que están a mitad de hacer en las macros y eso. Si tienes alguna duda avisa me. Maquinas año 2020.xlsm
  13. Hola a todos, Soy nuevo por aquí, espero poder aprender más de lo poco que sé y ayudaros si puedo en algo. Estaré encantado de compartir mi conocimiento y conocer vuestras habilidades de Excel. Si quieres un reto de Excel te propongo algo a ver si lo resolvemos, ya me cuentas. Saludos
  14. Hola a todos, Quiero usar la variable ( .List ) en mi macro pero VBA pare ser que no la encuentra como si no existiera. No entiendo nada. Os adjunto las capturas de pantalla. Como podéis ver en la lista desplegable de VBA no aparece esta variable que acabo de escribir. Pero he seguido escribiendo el código a mano, esperando que me saltara algún error o que se pusiera en rojo el código ( como cuando lo has puesto mal ) pero no es el caso parece ser que está bien aparentemente. Pero cuando ejecuto la macro me salta ese error. Creo que porque no reconoce la variable .List Creo que no he cometido errores en el código, os adjunto capturas de mis tablas para que entendáis el código que estoy usando. En rojo las columnas de Excel y en azul las columnas de mi tabla que empiezan en la columna B de excel. Ese código es para una lista de formulario, es decir me tiene que mostrar las primeras 6 columnas de mi lista ( la naranja) en la lista del formulario ( en el recuadro ROJO del formulario que os adjunto ) Gracias por la ayuda. Si tenéis dudas pedir lo que necesitéis.
×
×
  • Create New...

Important Information

Privacy Policy