Jump to content

JHP

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. Ya está!. Al final lo he resuelto, aunque creo que de una forma poco ortodoxa. He ordenado la matriz por categorías. He añadido una tercera columna. En esta tercera columna, en la primera fila he copiado el valor de la segunda columna de esa misma fila. Después, en la segunda fila, también en la tercera columna, he puesto la fórmula =SI(A2=A1;B2&","&C1;B2). Luego, he copiado los valores únicos de la columna 1 y los he pegado en otra hoja. En esta otra hoja he puesto la fórmula =BUSCAR(A1;Hoja2!A1:C18842). De este modo, me ha cogido de la matriz de 3 columnas de la primera hoja todos los valores últimos de la tercera columna de cada valor de la primera columna. Lo que no sé por qué la fórmula de BUSCAR toma el valor de la columna que se le indica pero siempre de la última fila de cada valor de la primera columna. No sé si me explico.
  2. Hola Todelman. Nada, no lo consigo. También es cierto que no se usar macros ni entiendo Visual Basic. He intentado copiar el código de la macro en mi libro y cambiar el rango que se indica por el que realmente tiene mi matriz, pero nada. ¿Se puede crear una fórmula combinando Buscar y Concat? No logro dar con la sintaxis correcta. En otros sitios de internet otros usuarios utilizan fórmulas con funciones JOINTEXT (que no tengo en mi versión de Excel) o LOOKUP_CONCAT (que así escrito tampoco interpreta mi Excel, ni aun cambiando LOOKUP por BUSCAR ni cambiando _ por *). A ver si conseguimos dar con una solución que no implique macros Mil gracias de nuevo!
  3. Muchas gracias Todelman por responder tan rápido. Mañana por la mañana reviso el ejemplo a ver si soy capaz de replicarlo. Saludos
  4. Buenas tardes. Tras haber pasado por la sección de presentaciones como es de rigor, os expongo mi problema. Necesito la fórmula para poder concatenar valores de una columna en base a un dato de otra. Ejemplo- Dada la siguiente matriz: Columna 1: Categorías Columna 2: Productos Fruta Pera Fruta Manzana Fruta Melón Carne Cordero Verdura Lechuga Verdura Tomate Carne Pollo Pescado Salmón Pescado Dorada El resultado que quiero obtener es (incluido el separador de la coma): Columna 1: Categorías Columna 2: Productos Fruta Pera,Manzana,Melón Carne Cordero,Pollo Verdura Lechuga,Tomate Pescado Salmón,Dorada He visto en diversos foros diversas funciones pero no lo consigo. A lo más que he llegado es a recuperar el primer valor de la Columna 2, pero no la concatenación con todos aquellos valores de la Columna 2 que tengan el mismo valor en la Columna 1. Muchas gracias!
  5. JHP

    Presentación

    Buenas tardes. Me llamo Jaime y escribo desde Mallorca. Gracias por permitir el registro gratuito para facilitar el teletrabajo en estas fechas de confinamiento por el COVID19. Saludos
×
×
  • Create New...

Important Information

Privacy Policy