Jump to content

jik

Members
  • Content Count

    8
  • Joined

  • Last visited

About jik

  • Rank
    Newbie

Profile information

  • Gender
    Hombre
  • Localización:
    Santiago, Chile

Converted

  • Campos
    ,
  1. Pues a mi no me funciona. Ya lo probé y sólo borra los saltos de página. No faltará un "Else" o algo así? Donde termina esta fórmula? Necesitaría darle un fin en, por ejemplo, la fila 10.000 Gracias
  2. Hola. No funciona. NO hace nada más que borrar los saltos de página existente.
  3. Hola de nuevo. La macro me daba un error en la segunda línea pero la corregí cambiando por número de fila. Sub insertar_filas() Application.ActiveSheet.ResetAllPageBreaks For i = 40 To 1000 Step 40 ActiveWindow.SelectedSheets.HPageBreaks.Add Before:=Rows(i + 1) NextDemo.xlsx End Sub Ahora tengo una complicación adicional que es que tengo que insertar el salto de página cada 40 filas VISIBLES. Con esto quiero decir que si por ejemplo, hay fila ocultas, éstas no se consideren para la cuenta de líneas del salto de página. Adjunto el archivo donde he ocultado las filas de 10 a 20 y 70 a 80. Para que funcione como yo quiero, el salto de página debería ir en la línea 51 (1 + 40 filas + 10 filas ocultas) El siguiente salto sería de la 52 a la 102 porque también hay 10 ocultas y así sucesivamente. Aclaro que el número de fila ocultas no es fijo (en mi ejemplo fueron 10 las 2 veces pero podría 5 una vez, 20 otra vez, etc).
  4. Hola. Muchas gracias. No tengo un archivo pero lo que necesito es algo para uso general. Lo que tú me has enviado inserta filas. Yo necesito insertas saltos de página cada una cierta cantidad de filas. Por ejemplo: insertar un salto de página cada 40 filas. Saludos.
  5. Hola. Necesito hacer una macro para que se inserten saltos de página cada una determinada cantidad de filas en un libro que tiene unas 10.000 filas aproximadamente. Gracias
  6. Hola. Perdona pero no te entiendo. La parte de igualdad me funciona bien. Lo que no me funciona correctamente es cuando uso el símbolo de distinto.
  7. Hola. Perdona pero no te entiendo. La parte de igualdad me funciona bien. Lo que no me funciona correctamente es cuando uso el símbolo de distinto. Saludos.
  8. Hola a todos. Tengo la siguiente función que funciona perfectamente: =SUMAR.SI.CONJUNTO(Softland!AG9:AG10000,Softland!A9:A10000,"=3",Softland!G9:G10000,"=MV*"). En una hoja que se llama Softland se suman los valores de la columna AG cuando el valor de la columna A es 3 y cuando unos códigos de la columna G comienzan con las siglas MV. Hasta ahí, todo bien. Cuando quiero hacer la función "inversa", es decir, sumar los valores de la columna AG pero cuando el valor de la columna A es distinto de 3, lo hago como sigue: =SUMAR.SI.CONJUNTO(Softland!AG9:AG10000,Softland!A9:A10000,"<>3",Softland!G9:G10000,"=MV*"). El problema que tengo es que con esta última fórmula, el resultado es la suma de todos los valores, los distintos de 3 e iguales a 3 también. Qué estoy haciendo mal?
×
×
  • Create New...

Important Information

Privacy Policy