Jump to content

Pedro Martin Bonilla Hdez

Members
  • Content Count

    10
  • Joined

  • Last visited

About Pedro Martin Bonilla Hdez

  • Rank
    Member

Converted

  • Campos Array

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. solo te falta poner absoluta la primera celda de la matriz en donde vas a buscar. ejemplo tu tienes =BUSCARV($B$7,'Full Report'!A2:$J$1165,5,FALSO) y debe de ser =BUSCARV($B$7,'Full Report'!$A$2:$J$1165,5,FALSO)
  2. Buen dia! no se si te sirva de algo este código. con esta función puedes leer información de un libro cerrado Private Function getvalue(path, file, sheet, ref) Dim arg As String If Right(path, 1) <> "\" Then path = path & "\" If Dir(path & file) = "" Then getvalue = "file not found" Exit Function End If arg = "'" & path & "[" & file & "]" & sheet & "'!" & _ Range(ref).Range("A1").Address(, , xlR1C1) getvalue = ExecuteExcel4Macro(arg) End Function Sub test() p = "F:\Users\xxxx\Documents" 'aqui ponemos la ruta del archivo f = "ARCHIVO.xlsx" ' aqui va el nombre del archivo del cual quieres obtener informacion s = "Hoja1" ' y el nombre de la hoja Application.ScreenUpdating = False For r = 1 To 100 ' en este ejemplo recorro 100 filas For c = 1 To 12 ' en este ejemplo recorro de la columna "A" hasta la "L" (doce columnas) a = Cells(r, c).Address Cells(r, c) = getvalue(p, f, s, a) Next c Next r Application.ScreenUpdating = True End Sub es del Autor John Walkenbach. Nada mas es cuestión que lo adaptes a tus necesidades, si es que te sirve. Saludos
  3. yo tengo instalado 2016 y también es de esta forma, mas que falla lo hace para que si tu aplicación presenta un formulario, este no pierda el enfoque hasta que termines de llenarlo o cerrarlo. 1.- abre el editor de vba 2.-en la parte izquierda te aparecen dos recuadros, uno es el explorador de proyectos y el otro la ventana de propiedades, en el explorador de proyectos seleccionas el formulario 3.- despues te vas a la ventana de propiedades (parte izquierda abajo, si no aparece presiona F4) que en este momento te debe estar presentando las propiedades del formulario seleccionado. 4.ahi encuentras la propiedad que te comento. lamento no poderte enviar una imagen, desconozco el proceso y un archivo tampoco me permito enviar, fallo el envio, tengo problemas de internet
  4. Buenas Tardes: no se si les sirva esto: si utilizas las formulas que te propone @Haplox, solo que haríamos que la función AHORA() dejara de ser volatil. En tu archivo que adjunto ya modificado, solo agregue una función llamada AhoraFijo() en vez de AHORA(), realmente AhoraFijo() es una llamada a la misma funcion, pero con esto queda estático. Function AhoraFijo() AhoraFijo = Now() End Function Saludos CONSOLIDADOS.xlsm
  5. Archivo/Opciones/Avanzadas/opciones de edición en dirección seleccionas Derecha. espero que esto sea lo que quieras. saludos
  6. Buen dia! checa si te sirve esta formula =+SI(BUSCARV(F5,$B$5:$C$8,2)>=F5,BUSCARV(F5,$B$5:$D$8,3),"??") ?? en esta parte se pondria algo para los valores no considerados en los intervalos de tu tabla. que tengan excelente fin de semana.
  7. Hola espero que te pueda servir esto =(LARGO(celda)-LARGO(SUSTITUIR(celda,"0 0 0 0 0 0 0 0 0 0","")))/19 o en su caso =(LARGO(celda)-LARGO(SUSTITUIR(celda,"0000000000","")))/10 el 19 0 el 10 es el largo de la cadena que vas a buscar, en tu caso como lo tienes con espacios por eso le puse 19 ó 10 en el caso que no tenga espacios.
    Excelente aportación, gracias por compartir tus conocimientos.
×
×
  • Create New...

Important Information

Privacy Policy

Ayuda Excel - Madrid, Madrid, ES - Valorada por 5112 personas - Aprender Excel - Total: 4.7 / 5