Jump to content

bdurango

Members
  • Content Count

    26
  • Joined

  • Last visited

About bdurango

  • Rank
    Member

Converted

  • Campos
    ;

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hola buen día. Algo así: Columna = Worksheets("Hoja1").Rows(1).Find("Gato").Column Saludos. Boris
  2. Hola fsabater. Intenta lo mismo que te dice Gabriel, pero sin convertir a tablas. =SI(CONTAR.SI.CONJUNTO(Hoja2!$B$6:$B$9;Hoja2!$B6;Hoja2!$F$6:$F$9;Hoja2!$F6)>1;"Repetido";"") Saludos. Boris
  3. Listo Abraham. Con el Application.DisplayAlerts quedó solucionado. Muchas gracias. Saludos. Boris
  4. Hola Abraham, gracias por tu tiempo. Bueno, decir base de datos es una exageración. Es un simple archivo de excel al que llaman base de datos. No adjunto el archivo porque es bastante denso, pero es una macro que copia información de las hojas del archivo "Base de datos" y con estas genera un archivo nuevo. Nunca tuvo complicación, de hecho funciona desde 2017. Pero al parecer hicieron actualizaciones (posiblemente restricciones de seguridad). He estado validando la configuración del centro de confianza de excel (versión 2010) pero no he dado con el chiste. Como dije, sí se genera el archivo, pero es engorroso dar escape tantas veces como la macro rescata información de "Base de datos". Adjunto archivo con la captura de pantalla y parte del código. Saludos Boris 'Se capturan datos y se crea un archivo nuevo Dim direc, nombre, nuevo, mes As String Dim ri, rf As String Application.ScreenUpdating = False mes = InputBox("Digite mes de informe", "Mes Informe") nombre = "Parafiscales " & mes ri = InputBox("Digite inicio periodo en formato yyyymmdd", "Inicio Periodo") rf = InputBox("Digite fin periodos en formato yyyymmdd", "Fin Periodo") fi = DateSerial(Val(Mid$(ri, 1, 4)), Val(Mid$(ri, 5, 2)), Val(Mid$(ri, 7, 2))) ff = DateSerial(Val(Mid$(rf, 1, 4)), Val(Mid$(rf, 5, 2)), Val(Mid$(rf, 7, 2))) Call rutaguardar 'Nueva línea direct = Sheets("Parafiscales").Range("B32").Value 'Nueva línea Workbooks.Add nuevo = ActiveWorkbook.Name Workbooks("INFORMES CALIDAD2.xlsm").Activate Sheets("Parafiscales").Copy before:=Workbooks(nuevo).Sheets("Hoja1") Workbooks(nuevo).Activate Sheets("Parafiscales").Activate Range("p8").Value = fi Range("p10").Value = ff 'Así se toma la información del archivo "Bases de Datos Calidad" y se copia al nuevo Workbooks("Bases de Datos Calidad.xlsm").Sheets("BD_PERS").Copy before:=Workbooks(nuevo).Sheets("Hoja1") Workbooks(nuevo).Sheets("BD_PERS").Activate Application.CutCopyMode = False Columns("A:AT").Select Columns("A:aT").EntireColumn.AutoFit Range("A1").Select Range("b2").Select ActiveSheet.Hyperlinks.Add Anchor:=Selection, Address:="", SubAddress:= _ "'Parafiscales'!A1", TextToDisplay:="REGRESAR"
  5. Buenas tardes a todos. Tengo un archivo con macros, las cuales toman información de una base de datos abierta, y me generan un archivo. Siempre ha funcionado, pero de un momento a otro me muestra la ventana de actualizar valores, aunque con scape me genera el archivo. Al parecer hicieron cambios en la seguridad de los equipos en la empresa. Alguna idea de como eliminar estas ventanas Muchas gracias. Boris
  6. Hola buenos días. No creo haberte entendido mucho, pero puedes utilizar la siguiente fórmula y acomodarla a tus necesidades. =SI(SUMAPRODUCTO(--(G11:G17>H6))>0;"ARRIBA";SI(SUMAPRODUCTO(--(G11:G17<H7))>1;"ABAJO")) Saludos. Boris
  7. Buenas tardes a todos. Tengo una pequeña inquietud que le he dado infinidad de vueltas y no doy. Es algo como esto: With r(1, 7).Resize(r.Rows.Count, 1) .FormulaR1C1 = "=IF(RC[-2]> sm * 4, RC[-2] * 0.01,0)" .Value = .Value End With Trato de comparar la celda escogida con la variable sm, pero no sé cómo llevar esta variable a la fórmula. He intentado con comillas, dobles comillas pero no doy. Alguna idea?? Muchas gracias por su tiempo Boris
  8. Buenas tardes. Aunque ya te lo solucionaron con fórmulas, te envío otra opción con macros. Saludos. Boris Copiar fórmulas según condición.xlsm
  9. Hola buen día. Te adjunto una posible solución creando un rango con los datos que vas a comparar, excluyendo los subtotales. Saludos. Boris Durango Copia de Ejemplo Ranking.xlsx
  10. Hola buenos días. Selecciona las celdas con las fórmulas que quieres modificar, ctrl+l, buscar el signo $ y reemplazas todo. Saludos
  11. Buenas tardes. Prueba con esta fórmula: =(SUMA(C2:J2)-K.ESIMO.MENOR(C2:J2;1)-K.ESIMO.MENOR(C2:J2;2))/6 Saludos. Boris
  12. Buenos días. No sé si sea posible con fórmulas, pero mientras puedes probar con macros. Te paso un pequeño ejemplo, modifícale el rango y la fila si es el caso. Saludos Contar color.xlsm
  13. Buenos días. Te comparto un link de una solución que da Héctor Miguel sobre el tema. Lo puedes acomodar a tus necesidades. https://answers.microsoft.com/es-es/msoffice/forum/msoffice_excel-mso_other-mso_archive/lista-en-excel-de-archivos-en-una-carpeta/f2567905-2b45-e011-9767-d8d385dcbb12 Saludos
  14. Hola buenas tardes. Solo modifica la columna a filtrar y el criterio de filtrado. ActiveSheet.ListObjects("BD_0C").Range.AutoFilter Field:=7, Criteria1:="<>12,195" Saludos. Boris Durango
×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png