Jump to content

fatbird

Members
  • Content Count

    18
  • Joined

  • Last visited

About fatbird

  • Rank
    Member
  • Birthday 05/02/1951
  1. Re: sumar tiempos con la misma fecha ¡Muchas gracias! Totalmente solucionado.
  2. Re: sumar tiempos con la misma fecha continuación del post anterior... Ya lo he podido subir. suma_horas_fecha.zip
  3. Hola, Después de leer los posts relacionados con SUMA, SUMAPRODUCTO, SUMAR.SI... etcétera e intentar adaptar las fórmulas de varios ejemplos, no logro obtener un resultado satisfactorio. Tampoco he logrado encontrar una solución en la net, Lo que pretendo: En una matiz con fechas que se repiten y los tiempos correspondientes, necesito sumar los tiempos por fecha. Por ejemplo, si tengo varias celdas con la fecha 25-01-11 cada una con distintos tiempos, necesito sumar todos los tiempos correspondientes a esa fecha. Hay una celda donde escribo la fecha y al lado de la misma pretendo tener l
  4. Re: Macro cambiar formato hora Muy interesante, No es lo que estaba buscando en este momento, pero no está de más saberlo, para utilizarlo en otras situacones... Una vez más, muchas gracias.
  5. Re: Macro cambiar formato hora A todos los compañeros que, con más o menos éxito, me han ayudado, ¡Muchísimas gracias! Considero que este tema está solucionado. Saludos
  6. Re: Macro cambiar formato hora Está perfecto, pero no me resuelve el problema, porque necesito aplicar la función "SUMA" en algunos casos, en otros sumar celdas dispersas y quiero todo automatizado, con lo cual no se hace práctico sumar de la forma que me indicas. Te agradezco muchísimo tu ayuda y todo el tiempo que dedicaste a mi asunto.
  7. Re: Macro cambiar formato hora Muchas gracias. Realmente funciona, pero es una solución solamente de apariencia. El aspecto es perfecto, pero no se comporta como horas. Clarifico: Si sumamos varias celdas con esos tiempos, aparecen resultados de este tipo: 03:55 + 01:30 = 04:85
  8. Re: Macro cambiar formato hora Hola AOSA. Perdona que haya tardado tanto en contestar, pero estuve fuera bastante tiempo... Te agradezco tu ayuda, pero no me funciona totalmente bien para lo que necesito. Si escribo 1234, va perfecto. Aparece 12:34. Si escribo 3, aparece :3 y lo que necesito es que me aparezca 00:03 o 0:03. Un saludo
  9. Hola, Necesito tener una forma de escribir 4 dígitos en varias celdas, sin ningún tipo de separador entre hh y mm y en cada una de ellas, esos 4 dígitos se transformen en hh:mm, cuando presiono enter. Para ser más explícito: escribo 1435 y al presionar enter, esa cifra se transforma en 14:35. No puedo aplicar una fórmula, porque lo primero que ocurriria era que esta se borraría de inmediato. Supongo que tendría que ser hecho con una macro o en programación VBA, aplicable a determinadas celdas. Tengo Excel 2010. Alguien me echa una mano :-) ?
  10. Te voy a hacer una sugerencia, que me parece aún más más práctica. La fórmula que te voy a escribir permite que escribas las hh e mm sin separadores. Me explico con ejemplos: Si escribes 1 te devuelve 0:01 Si escribes 25 te devuelve 0:25 Si escribes 238 te devuelve 2:38 Si escribes 2456 te devuelve 24:56 Supongamos que escribes la hora en la celda F3 y quieres el resultado en la celda G3 Pues en este ejemplo, escribes en la celda G3: =TEXTO(F3;"00\:00")+0 Espero que te guste la solución ¡Un saludo y feliz 2011!
  11. Estimados Logroastur y Ioyama, Lo primero: un millón de gracias por vuestra ayuda. Logroastur, tuve que hacer un par de cambios en tus fórmulas. Quedaron así: =SI(Y(A4<D2;A4>=E2);0;1) - entrada y =SI(Y(B4<E2;B4>=E2);0;1) - salida. Esto ocurre, porque estoy trabajando en formato [h]:mm y no en horas decimales, por lo tanto no hay que dividir por 24. El A4>= y B4>= es porque a la hora que está en la celda E2 es la de salida del sol, con lo cual a esa hora ya es de día. Yoyama, en las tuyas tuve solamente que cambiar =SI(O(A4>=D2;A4<E2);1;0) - entrada y =SI(O(B4>
  12. Hola Toldeman, Muchas gracias por tu ayuda, pero no me funciona bien del todo. Como estamos trabajando con períodos de 24 horas, en ciertas situaciones, 4:55 por dar un ejemplo, tendría que ser tratado como 28:55, para que pudiera funcionar. Sin embargo, para otras situaciones no es así, porque dependiendo de la época del año y de las coordenadas terrestres, 4:55 unas veces es de noche y otras es de día. Usando tu tabla, si escribes 4:55, excel asume que ese valor es menor que la hora del ocaso y en esta particular situación, no es así. La respuesta que da es 0, o sea que es de día. Lo qu
×
×
  • Create New...

Important Information

Privacy Policy