6

Cómo usar las funciones SI e Y de forma combinada

Ya sabes que en Excel se utilizan unas funciones más que otras o, por lo menos, parece que hay algunas más importantes que otras. En la mayoría de los casos, para valorar unas funciones mejor que otras nos basamos exclusivamente en ellas de forma individual sin prestar atención a que pueden ser combinadas con otras funciones.

Este es el caso de la función Y. Si la utilizas de forma individual en el libro de Excel parece que no sirve para nada (¿quién va a comparar dos valores utilizando la función Y?). Sin embargo, combinada con SI (la reina de las condicionales), la cosa cambia.

¿Quieres aprender a combinar las funciones Y y SI?

Ambas funciones tienen su utilidad pero cuando se utilizan juntas, pueden resolver problemas que por separado sería imposible:

  • La función SI evalúa una condición y devuelve un resultado si esa condición se cumple o devuelve otro resultado si no se cumple.
  • La función Y evalúa varias condiciones y devuelve VERDADERO si se cumplen todas ellas. Si alguna o todas las condiciones no se cumple, devuelve FALSO.

Gracias a la combinación de las dos funciones puedes evaluar con una sola función SI, varias condiciones. Si todas las condiciones se cumplen, la función devuelve un resultado. Y si alguna no se cumple devolverá otro resultado.

Para combinar las dos funciones, utiliza esta sintaxis:

=SI(Y(condicion_1;condicion_2);valor_si_verdadero;valor_si_falso)

Como digo, si todas las condiciones son verdaderas, la función Y será VERDADERO y, por lo tanto se mostrará el valor que hayas dado como Verdadero.

Te pongo un ejemplo:

formula si excel

Los estudiantes de esta lista deben obtener una puntuación de 5 o más en cada uno de los exámenes para aprobar el curso. Si en alguna asignatura sacan menos de un 5, suspenderán.

La fórmula que he utilizado es la siguiente:

=SI(Y(B2>=5;C2>=5;D2>=5);”Aprobado”;”Suspenso”)

Si B2 es igual o mayor que cinco, C2 es igual o mayor que cinco y D2 es igual o mayor que cinco, entonces el resultado es Aprobado.

Utilízala solamente cuando se deban cumplir todas las condiciones para que devuelva VERDADERO.

De la misma forma que he utilizado la función Y, puedo usar la función O. En este caso devolverá VERDADERO cuando se cumpla una o más condiciones.

Descárgate el archivo para comprobar cómo funciona la fórmula. He calculado las notas de los alumnos con la función ALEATORIO.ENTRE, de forma que si pulsas la tecla F9, podrás ver nuevos resultados.

Notas alumnos
Título: Notas alumnos (1649 clics)
Tamaño: 32 KB

Espero tus comentarios si te ha sido útil.

¡Compartir es vivir!
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario 6 comentarios
LUIS PABLO GALVEZ HERRERA

excelente aporte, muchas gracias por facilitarnos la existencia

Responder
Teodoro

Estimado, muy buena la lógica para poder desarrollar formulas mas potentes.
Gracias por tu tiempo.

Responder
Alejandro Reynada

Hola Sergio, muchas gracias por compartir tus conocimientos de excel, saludos.

Responder
Fernanda de los Rios

Muchas gracias por compartir tus conocimientos 😀

Responder
Rafael Cano

Excelente explicación, pero son con con operadores lógicos, que pasa si hay 2 condiciones de texto para efectuar una operación:
Ejemplo: =SI(Y(B2=Ready;C2=Managua);D3=D3*0.01”;”0”)
No me funciona con texto…. como haría la operación…?

Responder
    Sergio

    Hola Rafael!
    En tu fórmula no has encerrado los textos entre comillas… ese es el error.

    Responder

Escribe una respuesta:

Esta web usa cookies propias y de terceros para mejorar tu experiencia de navegación, elaborar información estadística y analizar tus hábitos de navegación. Si no estuvieras conforme puedes eliminarlos. Al hacer clic en "Aceptar" o si continúas navegando, aceptas su uso. Puedes revocar tu consentimiento en cualquier momento. Leer más

Los ajustes de cookies de esta web están configurados para «permitir cookies» y así ofrecerte la mejor experiencia de navegación posible. Si sigues utilizando esta web sin cambiar tus ajustes de cookies o haces clic en «Aceptar» estarás dando tu consentimiento a esto.

Cerrar