3

Cómo usar las funciones SI e Y de forma combinada

La verdad es que las funciones Y y O no tienen mucho que decir por sí solas. Ambas comparan dos o más condiciones y devuelve diferentes resultados:

  • Y devuelve VERDADERO cuando se cumplen todas las condiciones introducidas como argumentos, devolviendo FALSO en el caso de que una o más no se cumplan.
  • O es todo lo contrario. Devuelve VERDADERO cuando al menos una de las condiciones se cumplen. Devuelve FALSO en el caso de que no se cumplan todas las condiciones.

Como ves, esto es poco útil.

Lo interesante viene cuando las combinas con la función SI, obteniendo fórmulas mucho más poderosas.

Me voy a centrar en las funciones SI e Y.

Ambas funciones tienen su utilidad pero cuando se utilizan juntas, pueden resolver problemas que por separado sería imposible:

  • La función SI evalúa una condición y devuelve un resultado si esa condición se cumple o devuelve otro resultado si no se cumple.
  • La función Y evalúa varias condiciones y devuelve VERDADERO si se cumplen todas ellas. Si alguna o todas las condiciones no se cumple, devuelve FALSO.

Gracias a la combinación de las dos funciones puedes evaluar con una sola función SI, varias condiciones. Si todas las condiciones se cumplen, la función devuelve un resultado. Y si alguna no se cumple devolverá otro resultado.

Para combinar las dos funciones, utiliza esta sintaxis:

=SI(Y(condicion_1;condicion_2);valor_si_verdadero;valor_si_falso)

Como digo, si todas las condiciones son verdaderas, la función Y dará VERDADERO y, por lo tanto se mostrará el valor que hayas dado como Verdadero.

Te pongo un ejemplo:

formula si excel

Los estudiantes de esta lista deben obtener una puntuación de 5 o más en cada uno de los exámenes para aprobar el curso. Si en alguna asignatura sacan menos de un 5, suspenderán.

La fórmula que he utilizado es la siguiente:

=SI(Y(B2>=5;C2>=5;D2>=5);”Aprobado”;”Suspenso”)

Si B2 es igual o mayor que cinco, C2 es igual o mayor que cinco y D2 es igual o mayor que cinco, entonces el resultado es Aprobado.

Utilízala solamente cuando se deban cumplir todas las condiciones para que devuelva VERDADERO.

De la misma forma que he utilizado la función Y, puedo usar la función O. En este caso devolverá VERDADERO cuando se cumpla una o más condiciones.

Descárgate el archivo para comprobar cómo funciona la fórmula. He calculado las notas de los alumnos con la función ALEATORIO.ENTRE, de forma que si pulsas la tecla F9, podrás ver nuevos resultados.

Notas alumnos
Título: Notas alumnos (862 clics)
Tamaño: 32 KB

Espero tus comentarios si te ha sido útil.

¡Compartir es vivir!
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario 3 comentarios
LUIS PABLO GALVEZ HERRERA - 08/03/2019

excelente aporte, muchas gracias por facilitarnos la existencia

Responder
Teodoro - 09/03/2019

Estimado, muy buena la lógica para poder desarrollar formulas mas potentes.
Gracias por tu tiempo.

Responder
Alejandro Reynada - 17/03/2019

Hola Sergio, muchas gracias por compartir tus conocimientos de excel, saludos.

Responder

Escribe una respuesta:

Powered by WishList Member - Membership Software