Cómo usar las funciones SI e Y de forma combinada

funcion si excel funcion y excel

Ya sabes que en Excel se utilizan unas funciones más que otras o, por lo menos, parece que hay algunas más importantes que otras. En la mayoría de los casos, para valorar unas funciones mejor que otras nos basamos exclusivamente en ellas de forma individual sin prestar atención a que pueden ser combinadas con otras funciones.

Este es el caso de la función Y. Si la utilizas de forma individual en el libro de Excel parece que no sirve para nada (¿quién va a comparar dos valores utilizando la función Y?). Sin embargo, combinada con SI (la reina de las condicionales), la cosa cambia.

¿Quieres aprender a combinar las funciones Y y SI?

Ambas funciones tienen su utilidad pero cuando se utilizan juntas, pueden resolver problemas que por separado sería imposible:

  • La función SI evalúa una condición y devuelve un resultado si esa condición se cumple o devuelve otro resultado si no se cumple.
  • La función Y evalúa varias condiciones y devuelve VERDADERO si se cumplen todas ellas. Si alguna o todas las condiciones no se cumple, devuelve FALSO.

Gracias a la combinación de las dos funciones puedes evaluar con una sola función SI, varias condiciones. Si todas las condiciones se cumplen, la función devuelve un resultado. Y si alguna no se cumple devolverá otro resultado.

Para combinar las dos funciones, utiliza esta sintaxis:

=SI(Y(condicion_1;condicion_2);valor_si_verdadero;valor_si_falso)

Como digo, si todas las condiciones son verdaderas, la función Y será VERDADERO y, por lo tanto se mostrará el valor que hayas dado como Verdadero.

Te pongo un ejemplo:

formula si excel

Los estudiantes de esta lista deben obtener una puntuación de 5 o más en cada uno de los exámenes para aprobar el curso. Si en alguna asignatura sacan menos de un 5, suspenderán.

La fórmula que he utilizado es la siguiente:

=SI(Y(B2>=5;C2>=5;D2>=5);»Aprobado»;»Suspenso»)

Si B2 es igual o mayor que cinco, C2 es igual o mayor que cinco y D2 es igual o mayor que cinco, entonces el resultado es Aprobado.

Utilízala solamente cuando se deban cumplir todas las condiciones para que devuelva VERDADERO.

De la misma forma que he utilizado la función Y, puedo usar la función O. En este caso devolverá VERDADERO cuando se cumpla una o más condiciones.

Descárgate el archivo para comprobar cómo funciona la fórmula. He calculado las notas de los alumnos con la función ALEATORIO.ENTRE, de forma que si pulsas la tecla F9, podrás ver nuevos resultados.

Notas alumnos
Título: Notas alumnos (1944 clics)
Tamaño: 32 KB

Espero tus comentarios si te ha sido útil.

9 comentarios en “Cómo usar las funciones SI e Y de forma combinada”

  1. LUIS PABLO GALVEZ HERRERA

    excelente aporte, muchas gracias por facilitarnos la existencia

  2. Estimado, muy buena la lógica para poder desarrollar formulas mas potentes.
    Gracias por tu tiempo.

  3. Alejandro Reynada

    Hola Sergio, muchas gracias por compartir tus conocimientos de excel, saludos.

  4. Excelente explicación, pero son con con operadores lógicos, que pasa si hay 2 condiciones de texto para efectuar una operación:
    Ejemplo: =SI(Y(B2=Ready;C2=Managua);D3=D3*0.01”;”0”)
    No me funciona con texto…. como haría la operación…?

    1. Hola Rafael!
      En tu fórmula no has encerrado los textos entre comillas… ese es el error.

  5. Hola, estoy con esta simple fórmula con 4 condiciones, todo va bien, pero tengo que hacerla con 40 productos y solo pude colocar 6 por ser muy larga, existe manera de abreviar esta fórmula?
    =SI(Y(C21=»band 4″;H21=»x»);Valores!I$10)+SI(Y(C21=»band 4″;I21=»x»);Valores!G$10)+SI(Y(C21=»band 4″;J21=»x»);Valores!C$10)+SI(Y(C21=»band 4″;K21=»x»);Valores!E$10)
    Gracias!

    1. Hola Daniel!
      Seguro que existe una forma más fácil de calcularlo, pero no te puedo ayudar si no sé qué tipo de datos contienen las celdas y su disposición en la hoja.

  6. Daniel Cicerone

    Hola Sergio soy un autodidacta entusiasta de nuevos desafios. Estoy con esto de crear una solucion para muchos colegas mios que no comprenden mucho de planillas. Estoy tratando de hallar una fórmula que me devuelva un resultado en base a un rango multiple de una celda en particular. En castellano simple sería : (celda A36) Si I24 es mayor que 0 y menor que 3700 escribir «minimo», Si I24 es mayor que 3700 y menor que 7000, escribir «medio», Si I24 es mayor que 7000 y menor que 11000, escribir «Elevado». Eso ayudaria muchisimo. Muchas Gracias. Daniel Cicerone Molini

Los comentarios están cerrados.

Sergio

Sergio

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.
Ebook De 0 a 100 con macros y VBA

De 0 a 100 con macros y VBA

Esta oferta no es para siempre...

¡no la desaproveches!