Números consecutivos para facturas

A la hora de facturar, la mayoría de las empresas se suelen inclinar por los números de factura consecutivos.

Sí, ya sé que si escribes un par de números en la columna A y arrastras el contenido hacia abajo, se rellenan las celdas con números consecutivos…, pero necesitaba una excusa para presentar la siguiente fórmula que también lo hace:

=SI(B2<>»»;CONTARA(INDIRECTO(«B1:B»&FILA()-1));»»)

La fórmula dice:

Si B2 no está vacía, cuenta los elementos de la columna B que van desde la fila 1 hasta la fila donde se encuentra la fórmula, y si se encuentra vacía, aparecerá en blanco.

El ejemplo que he puesto es sólo un ejemplo de uso ¿Para qué utilizarías tú esta fórmula?

numeros_consecutivos
Título: numeros_consecutivos (270 clics)
Tamaño: 9 KB

12 comentarios en “Números consecutivos para facturas”

  1. Se podría hacer en el caso de que el número de factura tuviera letras (fac-1), o el año un guión y el número de factura (2015-1), o alguna otra combinación, te agradecería si hicieses un caso.
    Gracias un saludo

  2. =SI(B2″»,AÑO(HOY())&»-«&CONTARA(INDIRECTO(«B1:B»&FILA()-1)),»»), da como resultado 2015-1

  3. Excelente, lo que no entiendo muy bien que hace la función INDIRECTO. Gracias

  4. Muy Bueno, estaba en la búsqueda de una formula parecida para mejorar mi formato.
    Gracias

  5. Utilizo la función indirecto para actualizar datos en un informe de acuerdo al numero del mes, es excelente.

  6. Que tal, me sirvio para hacer una concilacion bancaria, ya que con esto solo coloca un consecutivo de deposito o retiro a las celdas que estan ocupadas. Gracias

  7. buenas tardes, y en el caso que las facturas no comience por uno sino por el número 100 como quedaría la formula?

Los comentarios están cerrados.

Sergio

Sergio

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Ebook De 0 a 100 con macros y VBA

De 0 a 100 con macros y VBA

Esta oferta no es para siempre...

¡no la desaproveches!