12

Números consecutivos para facturas

A la hora de facturar, la mayoría de las empresas se suelen inclinar por los números de factura consecutivos.

Sí, ya sé que si escribes un par de números en la columna A y arrastras el contenido hacia abajo, se rellenan las celdas con números consecutivos…, pero necesitaba una excusa para presentar la siguiente fórmula que también lo hace:

=SI(B2<>””;CONTARA(INDIRECTO(“B1:B”&FILA()-1));””)

La fórmula dice:

Si B2 no está vacía, cuenta los elementos de la columna B que van desde la fila 1 hasta la fila donde se encuentra la fórmula, y si se encuentra vacía, aparecerá en blanco.

El ejemplo que he puesto es sólo un ejemplo de uso ¿Para qué utilizarías tú esta fórmula?

numeros_consecutivos
Título: numeros_consecutivos (281 clics)
Tamaño: 9 KB

¡Compartir es vivir!
Sergio
 

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Haz clic aquí para dejar un comentario 12 comentarios
David Davila

Exelente Post!! esta formula me sera de mucha utilidad :)!

Responder
Jorge Cruz

muy bueno y en vedad desconocia esta función
Gracias

Responder
Juan

Se podría hacer en el caso de que el número de factura tuviera letras (fac-1), o el año un guión y el número de factura (2015-1), o alguna otra combinación, te agradecería si hicieses un caso.
Gracias un saludo

Responder
Armando Roa

=SI(B2″”,AÑO(HOY())&”-“&CONTARA(INDIRECTO(“B1:B”&FILA()-1)),””), da como resultado 2015-1

Responder
MAURICIO

Excelente, lo que no entiendo muy bien que hace la función INDIRECTO. Gracias

Responder
Alex

Muy Bueno, estaba en la búsqueda de una formula parecida para mejorar mi formato.
Gracias

Responder
Gilber

Utilizo la función indirecto para actualizar datos en un informe de acuerdo al numero del mes, es excelente.

Responder
danilo

Excelente gracias por compartirlo
Saludos.
Danilo

Responder
ARTEMIO GLEZ

Que tal, me sirvio para hacer una concilacion bancaria, ya que con esto solo coloca un consecutivo de deposito o retiro a las celdas que estan ocupadas. Gracias

Responder
elisa

buenas tardes, y en el caso que las facturas no comience por uno sino por el número 100 como quedaría la formula?

Responder
Sergio

Elisa, podrías utilizar esta fórmula:

=SI(B2<>“”;CONTARA(INDIRECTO(“B1:B”&FILA()-1))+99;””)

Espero que te sirva.

Responder
dito58 (Rolando Segovia)

he estado probando y estos son los resultados =CONCATENAR(“Fact”;”-“;SI(B2″”;CONTARA(INDIRECTO(“B1:B”&FILA()-1));””))

Responder

Escribe una respuesta:

Esta web usa cookies propias y de terceros para mejorar tu experiencia de navegación, elaborar información estadística y analizar tus hábitos de navegación. Si no estuvieras conforme puedes eliminarlos. Al hacer clic en "Aceptar" o si continúas navegando, aceptas su uso. Puedes revocar tu consentimiento en cualquier momento. Leer más

Los ajustes de cookies de esta web están configurados para «permitir cookies» y así ofrecerte la mejor experiencia de navegación posible. Si sigues utilizando esta web sin cambiar tus ajustes de cookies o haces clic en «Aceptar» estarás dando tu consentimiento a esto.

Cerrar