Jump to content

Antoni

Members
  • Content Count

    10,379
  • Joined

  • Last visited

  • Days Won

    581

Everything posted by Antoni

  1. Me vais a hacer llorar. 😂😂😘😷. Suerte a todos en estos tiempos difíciles.
  2. Es el problema de explicar los problemas por partes. Si Mauricio no te contesta, intentaré echarle un vistazo durante el fin de semana, aunque no te lo aseguro.
  3. Esto si que es una forma de agradecer,......😅😒 Agradecimiento
  4. 'Posicionar después de la posición 3 TextBox1.SetFocus TextBox1.SelStart = 3 No estaría de más que que te documentases acerca de las propiedades de los controles que vas a utilizar y así te ahorrarías tiempo, tú y nosotros.
  5. Revisa el adjunto. Observa que he relacionado el nombre del conector con la celda de la columna E. Seguro que se puede hacer con un gráfico, pero ni idea. GRAFICO.xlsm
  6. Solo por culturilla, las variables, si están definidas dentro del procedimiento, se inicializan cada vez que se ejecuta el procedimiento, por eso están definidas a nivel módulo, pero entonces ocurre lo contrario, es decir, mantienen su valor y por eso es necesario inicializarlas en el procedimiento principal. 😏
  7. ¡Jo..!, no acierto ni una. Ahora creo que si. Planificación Formulario Final II.xlsm
  8. ¡Correjido!, atención a la nota, no es importante, que he puesto en la hoja AZIMUT. Gracias por el reconocimiento. 🙂 Nota: Chafardeando, he visto un formulario con un montón de TextBox, hay una forma de hacer un tratamiento masivo sin necesidad de ir control a control. Si llegas a usarlo, no dudes en consultar. Planificación Formulario Final II.xlsm
  9. Te juro que funcionaba, debo haber hecho algún 'adorno' de última hora y lo he estropeado. 😬 Lo corrijo en cuanto pueda.
  10. He eliminado todas las fórmulas y formatos condicionales a partir de la columna E y he incluido las acciones en las macros. Esto te permitirá borrar/copiar la información de entrada sin el peligro de borrar las fórmulas y los formatos. Abre el adjunto y pulsa sobre el botón Calcular, a ver que te parece. Planificación con rumbo, tiempo y pendiente-TOTAL.xlsm
  11. Los encabezados solo son compatibles si el llenado del combobox/listbox se hace a través de la propiedad RowSource con un rango continuo. Ejemplo: ComboBo1.RowSource = "Hoja1!A2:F20"
  12. Estoy en ello. A ver si mañana te puedo subir algo.
  13. Lo mismo que Haplox, pero con adornos 😘😏😷 Come_Clonare_Una_Textbox_In_Un_Userform.xlsm
  14. Sub Guardar() Dim Fila As Long Dim H1 As Worksheet Dim H2 As Worksheet '-- Application.ScreenUpdating = Falso 'Evita el parpadeo Set H1 = Sheets("INSERT") Set H2 = Sheets("DATOS") 'PARA GUARDAR LOS DATOS EN LA FICHA BD-- For x = 1 To 3 Fila = H2.Range("B" & Rows.Count).End(xlUp).Row + 1 H2.Range("B" & Fila) = H1.Range("D3") 'Hab. H2.Range("C" & Fila) = H1.Range("D4") 'Nombre H2.Range("D" & Fila) = H1.Range("D5") 'Entra H2.Range("E" & Fila) = H1.Range("D6") 'Dias H2.Range("F" & Fila) = H1.Range("D7") 'Salida H2.Range("G" & Fila) = H1.Range("D8") 'Turno H2.Range("h" & Fila) = H1.Range("D9") 'Pax Next 'Limpiar FICHA UNA VEZ SE HAYA GRABADO LOS DATOS H1.Activate ' H1.Range("D3").ClearContents 'Hab. H1.Range("D4").ClearContents 'Nombre H1.Range("D5").ClearContents 'Entra H1.Range("D6").ClearContents 'Dias 'H1.Range("D7").ClearContents 'Salida H1.Range("D8").ClearContents 'Turno H1.Range("D9").ClearContents 'Pax H1.Range("D3").Select Application.ScreenUpdating = True End Sub
  15. Ayudaría que resolvieras de forma manual los tiempos en el ejemplo que has subido y volvieras a subir el archivo. Lo del máximo y el mínimo entre 2 cantidades no lo pillo, ya que si una es mayor que la otra, la condición ya determina cual es el máximo y cual es el máximo, por lo que para obtener el promedio basta obtener la semisuma de ambas cantidades. ¿O me estoy perdiendo algo?
  16. Vamos a intentarlo, pero para poder cerrar el tema anterior, abre un tema nuevo con las explicaciones y vuelve a subir el archivo con el ejemplo que has subido resuelto de forma manual. Estaré atento a tu nueva consulta.
  17. Sube un archivo con datos explicando que es lo que quieres obtener.
  18. He corregido las fórmulas de las columnas G9, G19, G29, G39,......, que a mi modo de ver estaban equivocadas. Por ejemplo : G19=SI(G14>0;SI(G14>G4;G14-G4;SI(G14>G4;G4-G14;SI(G14=G4;0;"")));"") la he cambiado por: G19=SI(G14>0;SI(G14>G4;G14-G4;G4-G14);"") El tema de la pendiente era un problema conceptual por mi parte, al considerar que la subida/bajada era en relación al punto siguiente y no al anterior. Ahora al ver que la altura inicial va en la celda A8, lo he visto claro, o al menos eso creo. A ver si es esto. Has de tener en cuenta que solo se recalcula la representación de la pendiente en la fila que has hecho el cambio. Solo eliminando las cabeceras intercaladas se podría articular el recalculo hasta el final. Planificación con AZIMUT y pendiente - copia (1).xlsm
×
×
  • Create New...

Important Information

Privacy Policy