Diferencia en meses entre dos fechas

Frecuentemente leo post en el foro de Ayuda Excel preguntando sobre la forma más rápida de convertir la diferencia entre dos fecha en meses. Yo siempre utilizo la misma fórmula, aunque existen otras fórmulas e incluso otros métodos para conseguirlo (incluso más sencillos).

Al convertir la diferencia de fechas en meses, tienes dos opciones: incluir el día del mes en el cálculo (redondear hacia abajo), o no incluirlo (redondear hacia arriba).

Redondear hacia abajo

Esta fórmula utiliza días numéricos en el cálculo y redondea hacia abajo el número más cercano de meses enteros. Por ejemplo, si la fecha inicial es 30/10/13 y la fecha final 30/11/13, la fórmula devolverá 1 como resultado. Si la fecha final es 29/11/13, el resultado será 0.

=SI(DIA(ultima_fecha)>=DIA(primera_fecha);0;-1)+(AÑO(ultima_fecha)-AÑO(primera_fecha))*12+MES(ultima_fecha)-MES(primera_fecha)

Redondear hacia arriba

En otros casos puede que necesites excluir los días del mes del cálculo.

Ejemplo:

Para averiguar el número de meses transcurridos desde una fecha hasta hoy, sigue estos pasos:

  1. Escribe la fecha desde la que se van a contar los meses, en la celda A1.
  2. Escribe la siguiente fórmula en la celda A2:

=(AÑO(AHORA())-AÑO(A1))*12+MES(AHORA())-MES(A1)

 

Otra forma más sencilla

Además de utilizar uno de los métodos anteriores, tienes la posibilidad de utilizar la función SIFECHA.

No, no busques información sobre esta función en la Ayuda de Excel porque no la vas a encontrar. Se trata de una función secreta que, según parece, Microsoft quiere eliminar por ser originaria de Lotus.

La sintaxis de la función  es:

=SIFECHA(primera_fecha;ultima_fecha;intervalo)

El argumento intervalo se refiere a la unidad en la que deseas que se devuelva el resultado:

  • «d» Días entre las dos fechas.
  • «m» Meses entre las dos fechas.
  • «y» Años entre las dos fechas.
  • «yd» Días entre las fechas, tomando las fechas como si estuviesen ubicadas en un mismo año.
  • «ym» Meses entre las fechas, tomando las fechas como si estuviesen ubicadas en un mismo año.
  • «md» Días entre las dos fechas, tomando las fechas como si estuviesen ubicadas en un mismo año y mes.

[box type=»info»] Nota: Recuerda que cuando introduces una fecha de forma manual, debes hacerlo como si fuese un valor de texto, es decir, entre comillas.[/box]

Por ejemplo, si quisieras calcular los meses que hay desde el 1 de enero de 2013 hasta el 31 de diciembre de 2013, debes utilizar la siguiente fórmula:

=SIFECHA(«01/01/13″;»31/12/13″;»m»)

¿Cuál de estas fórmulas te parece más sencilla?

 

Sergio

Sergio

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.
Ebook De 0 a 100 con macros y VBA

De 0 a 100 con macros y VBA

Esta oferta no es para siempre...

¡no la desaproveches!