Cómo contar celdas que NO contienen números

Contar celdas excel que no contienen números

Ya sabes que para contar las celdas de un rango que contienen números debes utilizar la función CONTAR.

=CONTAR(rango)

Y seguramente sabrás que la función CONTARA cuenta las celdas de un rango que no están vacías.

=CONTARA(rango)

¿Y qué ocurre cuando quieres contar celdas que no contienen números?

Aquí la cosa se complica un poco. Era un tema que necesitaba buscar para hacer un proyecto. La solución que encontré fue la siguiente:

=SUMAPRODUCTO(--NO(ESNUMERO(rango)))

ESNUMERO devuelve una matriz con valores VERDADERO o FALSO según las celdas contengan números o no.

El resultado de ESNUMERO se pasa como rango a la función NO, que convierte cada VERDADERO en FALSO y viceversa.

La doble negación delante de NO le indica a Excel que debe convertir cada VERDADERO y cada FALSO en su correspondiente valor numérico (1 y 0).

Para finalizar SUMAPRODUCTO suma los valores de la matriz que contienen unos.

¿Conoces otra forma de contar las celdas que no contienen números? Coméntala para que la conozcamos todos.

6 comentarios en “Cómo contar celdas que NO contienen números”

  1. Hola sergia excelente ayuda de como contar celdas que no contienen número, podrías presentar alguna ayuda sobre como hacer para que cuando alguien escriba un nombre en una celda que esta en blanco si lo pone en miniscula se convierta en mayuscula inmediatamente. gracias

    1. Víctor, si quieres que aparezcan las letras mayúsculas en la misma celda donde las escriben, lo puedes hacer con una función personalizada. Por favor, entra en el foro y plantea ahí tu consulta. En breve te responderemos.

  2. Gerson Pineda

    Sergio

    Esta omite celdas vacías para el conteo
    =CONTAR(INDICE(1/ESTEXTO($A$1:$A$10),))

    Esta cuenta la celda vacía como texto
    =CONTAR(INDICE(1/NO(ESNUMERO($A$1:$A$10)),))

    Saludos

  3. Carlos Chandía

    Otra forma de contar las celdas que no tienen números es utilizando la siguiente formula:
    =CONTARA($A$1:$H$50)-CONTAR($A$1:$H$50)
    Des esta forma la función CONTARA cuenta todas las celdas que tienen datos y le restamos las celdas que tienen números con la función CONTAR

  4. Pingback: Las funciones básicas para contar datos en Excel - Ayuda Excel

Los comentarios están cerrados.

Sergio

Sergio

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Ebook De 0 a 100 con macros y VBA

De 0 a 100 con macros y VBA

Esta oferta no es para siempre...

¡no la desaproveches!