La función SUMA

Versiones donde se puede usar

Versión Excel 2003 Excel versión 2007 Excel versión 2010 Excel versión 2013 Excel versión 2016 Excel 2019 Excel versión 365 Versión Excel Online

La función SUMA suma todos los argumentos que contiene. La función acepta varios tipos de argumentos que se transforman previamente en valores numéricos antes de devolver el resultado. Actualmente el número máximo de argumentos que acepta es de 255.

Como digo, la función SUMA, puede sumar varios tipos de argumentos, que son los siguientes:

  • Una referencia a una celda: B5
  • Un valor numérico introducido a mano: 8
  • Una cadena de texto con forma de número: “12”
  • Una fecha: 27/03/2015
  • El resultado de utilizar una función: RAIZ(16)
  • Un rango de celdas: A1:B5
  • Un valor lógico: VERDADERO

Atención: Tanto los argumentos introducidos como texto como los valores lógicos, tienen que ser introducidos directamente en la fórmula, no pueden usar referencias a celdas que contengan el valor.

Además del uso “normal” que le puedas dar a la función SUMA, también puedes utilizarla de forma matricial:

Imagina que tienes un rango de números positivos y negativos y lo que necesitas es sumar solamente los números positivos. Tienes varias formas:

  • Con la función SUMA seleccionando manualmente cada número positivo.
  • Con la función SUMAR.SI, utilizándola de la forma habitual.
  • Con una fórmula matricial.

funcion suma1

 

La fórmula matricial funciona de la siguiente manera:

La condición A1:A6>0 devuelve VERDADERO cuando uno de los valores sea mayor que cero. VERDADERO es igual a 1, por lo que al multiplicar 1 por el número da el mismo resultado. Al sumar todos los valores VERDADERO se obtiene la suma de los números positivos.

 

Sintaxis de SUMA

=SUMA(número1;número2;…)

  • número1: Obligatorio. Es un argumento obligatorio. Es el primer número que quieres sumar. Puedes introducir el valor manualmente, a través de una referencia de celda o en forma de rango de celdas.
  • número2…: Opcional. Son los siguientes valores que se incluirán en la suma.

Índice de ejemplos con SUMA

  • Ejemplo 01: El ejemplo de uso más sencillo de la función SUMA.
  • Ejemplo 02: Diferentes tipos de argumento para la función SUMA.
  • Ejemplo 03: Función SUMA con valores lógicos y de texto.

Ejemplos

Sergio

Sergio

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Ebook De 0 a 100 con macros y VBA

De 0 a 100 con macros y VBA

Esta oferta no es para siempre...

¡no la desaproveches!