La función SI

Versiones donde se puede usar

Versión Excel 2003 Excel versión 2007 Excel versión 2010 Excel versión 2013 Excel versión 2016 Excel 2019 Excel versión 365 Versión Excel Online

La función SI es la más importante de las funciones de Lógica. Comprueba si una condicion es verdadera o falsa y, dependiendo de eso, devuelve un resultado diferente. Imagina que en un examen un alumno ha obtenido una nota de 5,5. Como esta nota supera los 5 puntos, el examen se da por «aprobado», mostrando en la celda la palabra “Aprobado”. En caso de que hubiera obtenido una nota de 4, el examen estaría suspendido y lo que aparecería en la celda sería la palabra “Suspendido”.

Probablemente se trata de la más valiosa de todas las funciones de Excel ya que tiene una gran capacidad de decisión.

Para que la función SI pueda evaluar la condición, puedes utilizar tanto operadores lógicos como valores o resultados de otras fórmulas. Los operadores lógicos compatibles con Excel son:

  • < Menor que
  • > Mayor que
  • <= Menor o igual que
  • >= Mayor o igual que
  • = Igual
  • <> Distinto a

La forma correcta para interpretar el ejemplo anterior sería la siguiente (suponiendo que la nota se encuentre en la celda A1):

=SI(A1>5; “Aprobado”; “Suspendido”)

Te resultará más fácil de entender esta función si traduces sus argumentos de la siguiente forma:

Si A1 es mayor que cinco entonces devuelve “Aprobado” y si no, devuelve “Suspendido”.

Este es el ejemplo de utilización más sencillo que podrás encontrar de la función SI. Al igual que otras funciones, si quieres sacarle todo el potencial deberás utilizarla dentro de una fórmula que contenga otras funciones.

Utilizando varias funciones SI anidadas también serás capaz de evaluar varias condiciones en una sola fórmula. Observa la siguiente sintaxis:

SI(condición1; valor_si_verdadero1; SI(condición2; valor_si_verdadero2; valor_si_falso2))

Con esta fórmula le estoy diciendo a Excel que evalue una condicion. Si esa condición es verdadera devuelve un resultado, pero si es falsa se debe evaluar otra condicion que, también puede ser verdadera o falsa.

El límite de anidamiento ha ido aumentando con cada nueva versión de Office. Actualmente, con Office 2013 este límite se encuentra en 64 niveles. Desde mi experiencia te diré que no creo que llegues ni a 10 niveles de anidamiento, pero en caso de que los utilices, te darás cuenta de que existen otras funciones mucho más eficientes para gestionar grandes cantidades de datos, como ELEGIR, BUSCARH o BUSCARV.

Sintaxis de SI

=SI(condicion;valor_si_verdadero;[valor_si_falso]) La función SI cuenta con los siguientes argumentos:

  • Condición: Obligatorio. Una condición a comprobar. Este argumento devuelve un valor lógico de VERDADERO o FALSO, matrices o referencias que contienen valores lógicos.
  • valor_si_verdadero: Obligatorio. El valor que se devolverá si condicion es VERDADERO.
  • valor_si_falso: Opcional. El valor que se devolverá si condicion es FALSO. Si no lo pones, devuelve el valor FALSO.

Índice de ejemplos con SI

  • Ejemplo 01 Uso simple de la función SI
  • Ejemplo 02 Cómo se anidan varias funciones SI
  • Ejemplo 03 Varios ejemplos de uso de operadores lógicos
  • Ejemplo 04 Cómo comprobar si un número se encuentra entre dos valores
  • Ejemplo 05 Cómo evaluar varias condiciones con una sola función SI
  • Ejemplo 06 Cómo evaluar varias condiciones con una sola función SI (II)
  • Ejemplo 07 Trucos con valores numéricos en las condiciones a evaluar
  • Ejemplo 08 Cómo estructurar funciones SI más complejas
  • Ejemplo 09 Evaluación de las condiciones de la función SI en otra columna

Ejemplos

Sergio

Sergio

La destreza y el perfeccionismo quizá sean las dos virtudes que me permiten ayudar a mis clientes a facilitar las tareas administrativas de sus negocios.

Ebook De 0 a 100 con macros y VBA

De 0 a 100 con macros y VBA

Esta oferta no es para siempre...

¡no la desaproveches!