Jump to content

[CERRADO]Calendario laboral con varios turnos y línea de tiempo


Recommended Posts

Hola y muchas gracias antes que nada, pues he echado una ojeada al foro y veo que sois unos auténticos máquinas!

Veréis, me estoy volviendo loco intentando hacer un calendario mensual laboral con los turnos de toda la plantilla y una línea de tiempo que muestre qué horas estarán cubiertos los departamentos de la empresa.

Para ello he creado una hoja principal en la que se muestra un calendario de todos los días del mes en una fila y en la primera columna aparecen los nombres de los empleados, en la celda que corresponde a cada día del mes he asignado una letra que determina en la misma celda d ela hoja siguiente el turno del empleado.

En la siguiente hoja, se muestra una tabla con los empleados y con las horas en las que permanece abierta la empresa, mediante formato condicional he hecho que si, por ejemplo junto a Jesús aparece una "M", significa que Jesús tiene turno de mañana y las celdas que van de las 9:45 a las 15:45 se autocolorean de rojo.

Este empleado en concreto, Jesús, tiene 4 turnos distintos de jornada. Lo hice en casa utilizando Excel 2010 y todo genial, funciona correctamente, pero mi desilusión fue al llegar a la empresa y al abrirlo allí en Excel 2003, vi que los turnos no se asignaban correctamente, en vez de marcar de 9:45 a 15:45, marcaba por ejemplo de 15:00 a 17:00. ¿puede ser que Excel 2003 no reconozca tantas condiciones de formato?, ¿puesdo conseguir el mismo efecto con una fórmula distinta?

He guardado la plantilla en formato Excel2003 y me ha generado una hoja de correcciones que no termino de entender.

¿¡Alguien puede ayudarme!? Adjunto el archivo. Gracias otra vez.

Link to post
Share on other sites
  • 2 weeks later...
Guest
This topic is now closed to further replies.


  • Crear macros Excel

  • Posts

    • Buenos días. Es mi primera intervención, y ya es para pedir ayuda.  Ver si puedo contar con vuestras experiencias.   Tengo una tabla, en una columna días, y en la otro la puntualidad de ese día en concreto en "%"   Ya he calculado en el total de año el nr de días que la puntualidad ha sido del 100%   Pero (y ahí es donde me he quedado atascado), necesitaría un contador que me dijera el número de días que llevamos con una puntualidad de los empleados del 100%   He encontrado este tema que me ha servido de algo de ayuda, pero o bien no se interpretarlo, o no es exactamente lo que busco.     Comunidad, anticipadamente, muchas gracias por vuestra ayuda. EJEMPLO 1.xlsx
    • Buenas a tod@s, Os adjunto un calendario al que quiero hacer lo siguiente: como veis tengo una celda que es la E22 en color rojo que usaré para los dias festivos. Justamente debajo incluiré los dias festivos (1 de enero, 6 de enero, etc) estos dias al incluirlo en el listado querria que cambiaran el color segun el relleno de la Celda E22. Tambien busco la forma de que si cambio el año estos dias se actualicen Luego tengo la celda I18 que tiene el color amarillo y querria que al incluir los dias del calendario me cambiaran al color de relleno de dicha celda. Es posible? 2021.xlsm
    • Después de varios años sin abrir una hoja de cálculo, me encuentro ante nuevos retos, espero poder aportar mis antiguos conociminentos y aprender de los vuestros.   Un Saludo. !!
    • ¡Hola a ambos! @YOUSAFJAMALD, para la próxima, sube un archivo Excel en vez de una imagen.  Nos ayuda mucho más a ayudarte. Ahora, en cuanto a tu problema y como bien te comenta @DiegoPC, efectivamente, con la función BUSCAR "solita", el problema no es posible realizarlo, pero con "ayuda" si que es posible. =BUSCAR(2;1/FRECUENCIA(0;1/(1+(K$37:K$43<=N37)*K$37:K$43));L$37:L$43) otra alternativa un poco más "digerible": =INDICE(L$37:L$43;COINCIDIR(MAX(INDICE(K$37:K$43*(K$37:K$43<=N37);));K$37:K$43;)) o también usar la función BUSCARX (solo disponible en Microsoft 365 / Excel 2021 / Excel Online 😞 =BUSCARX(N37:N63;K37:K43;L37:L43;"No Existe";-1) Analiza detenidamente las propuestas.  ¡Bendiciones!
    • Saludos espero me puedan ayudar, he intentado todo y no lo consigo. estoy tratando de descargar datos de una web la cual es "post" y posteriormente es "get" redirecciona a otra pagina, solo lo he logrado con el navegadro explorer pero el detalle que es muy tardado ya que son 170mil datos y con explorer es como si fuera navegando, abrir explorador, poner url, bucar las etiquetas donde se hace la cosulta y despues click en un boton, esperar a que cargue la pagina y extraer los datos de esa consulta.   me gustaria poderlo hacer mediante xmlhttp   anexo link de la pagina  https://serviciosfinanzas.villahermosa.gob.mx:8800/serviciosfinanzas/dp/busqueda-agua.html y mi codigo    Sub Web_Data()     Dim str_arg As String    Dim URL     str_arg = "xContrato=000001&Buscar=Buscar"     URL = "https://serviciosfinanzas.villahermosa.gob.mx:8800/serviciosfinanzas/dp/busqueda-agua.html" Set OBJHTTP = CreateObject("MSXML2.XMLHTTP")     With OBJHTTP              .Open "GET", URL, False         .setRequestHeader "User-Agent", "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.114 Safari/537.36"         .setRequestHeader "contenido-type", "text/html"         .setRequestHeader "contenido-type", "application/xhtml+xml"         .setRequestHeader "contenido-type", "application/x-www-form-urlencoded"                  .setRequestHeader "contenido-type", "application/javascript"         .send str_arg         TXT = .responseText         Debug.Print TXT              End With     [A1] = html.getElementsByTagName("td")(1).innerText 'valor a extraer numero de contrato, nombre y direccion End Sub
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy