Jump to content

Archived

This topic is now archived and is closed to further replies.

jayzun

sacar texto de parentesis

Recommended Posts

tengo un problema con unas celdas que contiene la ciudad con la provincia en parentesi

ejemplo

San Lucar(Cadiz)

necesito sacar la provincia en parentesis y poner lo en otro campo alguna ayuda seria mut agradecida

Share this post


Link to post
Share on other sites

Hola,

es mi primera respuesta en este foro y espero que te sirva. Si los datos los tienes en la columna A prueba con esta fórmula.

=IZQUIERDA(A1;HALLAR("(";A1)-1)

Busca en que posición está el inicio del paréntesis (hallar) y luego coge las letras a la izquierda de ese valor.

saludos

Share this post


Link to post
Share on other sites

Hola jayzun, prueba esta fórmula:

=SIERROR(MED(E14,ENCONTRAR("(",E14)+1,ENCONTRAR(")",E14)-ENCONTRAR("(",E14)-1),"")[/CODE]

Sustituye la celda E14 por la que desees.

Funciona si encuentra un paréntesis abierto seguido por otro cerrado, en otros casos devuelve blanco.

Seguro que hay más cortas pero ésta es fácil de comprender y es muy agradecida.

Share this post


Link to post
Share on other sites

lo de =EXTRAE(A1;HALLAR("(";A1)+1;HALLAR(")";A1)-HALLAR("(";A1)-1) funciona a medias. me ha olvidado explicar que algunas campos tiene solo la poblacion. y cuando hago la formula donde no hay parenthesis mi deja un valor, sin embargo los campos que tiene parenthesis sale como quiero

ejemplo

Montijo (Badajoz)

Badajoz

Share this post


Link to post
Share on other sites

La función SIERROR hace que no salga nada si no hay provincias entre paréntesis.

=SIERROR(EXTRAE(A1;ENCONTRAR("(";A1)+1;ENCONTRAR(")";A1)-ENCONTRAR("(";A1)-1);"")[/CODE]

Pruébala y me lo cuentas.

He editado la fórmula para cambiar las comas "," de la configuración regional del inglés, por punto y coma ";" del español.

La fórmula de Germán te servirá igual de bien, pero poniendo A1 al final en lugar de comillas, cuando no encuentre los paréntesis, sacará el texto completo.

Share this post


Link to post
Share on other sites

Prueba con esto, a ver si te funciona;

=SI.ERROR(EXTRAE(A1;HALLAR("(";A1)+1;HALLAR(")";A1)-HALLAR("(";A1)-1);A1)

copiala y arrastra hacia abajo, espero te sirva.

Un saludo, Germán.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

INFORMACIÓN BÁSICA SOBRE PROTECCIÓN DE DATOS

Responsable: Sergio Andrés Celemín

Finalidad: Moderar y responder comentarios de usuarios. Recuerda que la información que facilites es pública, y los datos que incluyas los leerá cualquier visitante de esta web, así como el avatar que poseas.

Legitimación: Consentimiento del interesado.

Destinatarios: Hetzner Online GmbH.

Derechos: Puedes ejercitar en cualquier momento tus derechos de acceso,
rectificación, supresión, oposición y demás derechos legalmente establecidos a
través del email sergio@ayudaexcel.com.

Información adicional: Encontrarás más información en la política de privacidad.




×
×
  • Create New...

Important Information

Privacy Policy