Jump to content

[SOLUCIONADO] Error "75" en tiempo de ejecucion - Excel ha detectado un error...


Recommended Posts

Hola a todos.

Luego de varios dias despues de haber contado con la ayuda de este foro y en especial de mi amigo Neverdelimon para culminar un userform donde me faltaba completar los códigos que pudieran realizar modificaciones, eliminaciones, etc.. tuve un grabe problema para poder utilizarlo en la maquina donde iba a realizar mi trabajo. El error era el siguiente:

Al abrir la macro y realizar cambios se presentaba un error de cierre en el excel que implicaba cerrarlo y recuperar lo realizado, el motivo del error se localizaba en la vbe6.dll, luego de darle a recuperacion y ejecutar nuevamente la macro aparecia el siguiente error: Error "75" en tiempo de ejecucion , por lo que no podia entrar a la macro y nisiquiera realizar modificaciones en el userform.

Realice tanto en ayuda excel como en varios foros y por medio de google sobre este error y implicaba realizar ciertas actualizaciones para el offices que incluia actualizar la dll sin que nada funcionara, consulte con varios aqui en el foro pero el error solo podiamos saber que provenia de esta dll.

Asi que me aventure a ver que paso podria hacer y nada resultaba, lo ultimo que podia dar solucion era formatear la pc, cosa que me es dificil por todos los documentos importantes con los que cuento, asi que pense en algo, si todo tenia que ver con la dll y no me sirvio ni instalar o borrar el office, que tal si hago la macro en la misma pc, ya que aunque en ambas pc tanto en la que la hice en principio como en la que iba a utilizarla utilizaban la misma version del dll por que no hacerla en la que la voy a usar a ver que tal si me funcionaba.

Como me era dificil programar boton por boton y ya habiendo probado exportando los userform luego los modulos etcc y no funciono, tuve que hacer lo siguiente:

Dibuje solo el userform vacio, luego utilice el otro userform donde aparecia el error y seleccione todos los botones que estaban dentro textbox, combox, etc.. y los copie y pegue en el otro archivo que estaba creando, luego exporte los modulos, etc... Al final copie los codigos de programacion en el userform nuevo y copie los datos contenidos en cada hoja del archivo en el mismo orden en que estas se encontraban.

Asi que con el nuevo archivo realizado pude resolver el problema. Espero que con este ejemplo de lo que hice para solucionar si alguna vez se les presenta este tipo de error espero puedan hacer estos pasos para solucionarlo. Encontre por ahi que la moderadora Katinga tiene este problema asi que puede obtar por resolverlo de esta manera, ya que este caso suele darse porque como en la mayoria el archivo ha pasado por varias maquinas tanto por el que lo crea como tambien por el que nos ayuda a terminarlo aqui en el foro y este fue mi caso.

Saludos a todos,

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

Privacy Policy