Jump to content

desactivar ajustar texto automáticamente con VBA


Recommended Posts

Hola, normalmente activo o desactivo la opción "ajustar texto" manualmente, vía Menú Inicio, o con botón de la derecha, formato de celdas, alineación>ajustar texto. He intentado con la combinación de teclas Alt+H+W para llevármelo luego a una macro pero no me funciona y por lo que he estado buscando no hay mucha información sobre esto. Existe algún código o función para poder desactivar esta opción vía VBA? Gracias!

 

 

Link to comment
Share on other sites

  • Crear macros Excel

  • Posts

    • Pon esto Sub IngresaMes() Dim MES As Variant MES = (InputBox("Ingresar número de mes", "Formato: 1,2,3...")) 'Pegar dato a partir de la primera celda libre de la columna A, en función del Nº de filas de la columna B With Worksheets("Hoja1")   For I = 2 To .UsedRange.Rows(.UsedRange.Rows.Count).Row     If Cells(I, 1) = "" Then         Cells(I, "A").Value = MES     End If   Next      End With End Sub
    • Buenos días a todos; -Necesito de vuestra ayuda. Para mejor comprensión adjunto enlace de un video y comentario. Saludos y gracias de antemano     Adjunto también la macro. MEvento.zip
    • No debe importarnos que el usuario que abrió el tema no vuelva a consultarlo porque nuestras respuestas le llegaron demasiado tarde... Lo importante es poder ayudar a otros usuarios que tengan un problema similar en el futuro...
    • Es una opción original e ingeniosa pero creo que difícil de comprender para un usuario que sepa fórmulas sencillas... Adjunto otra opción con fórmulas desbordadas que puede que sea más fácil de comprender para un usuario que esté aprendiendo a formular, pues hay 3 pasos separados: Columna D : A cada valor se le añade 1> a la izquierda, se sustituye el primer + por 2> y el segundo + por 3>. De paso se quitan los signos , y . para convertir los valores en números. Todo ello con la función SUSTITUIR. ="1>"&SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR($C2;",";"");".";"");"+";"2>";1);"+";"3>";1)   Columna E (desbordada hacia la derecha en las columnas F y G): Extrae los valores y letras de 1>, 2> y 3>. Todo ello con una versión matricial de la función EXTRAE, con la ayuda de la función ENCONTRAR. =SI.ERROR(SUSTITUIR(EXTRAE($D2;ENCONTRAR({"1>"\"2>"\"3>"};$D2);SI.ERROR(ENCONTRAR({"2>"\"3>"\"0>"};$D2);100)-ENCONTRAR({"1>"\"2>"\"3>"};$D2));{"1>"\"2>"\"3>"};"");"")   Sumas de C, T y V: Suma las cantidades consumidas de cada letra con la función SUMAPRODUCTO. Salu2, Pedro Wave Sumar Letras PW1.xlsx
    • Hola,  Estoy intentando vía InputBox rellenar con el dato introducido una columna. Pero no consigo que lo haga desde la primera fila libre de A. Sería pegar el dato a partir de la primera celda libre de la columna A (está en verde), en función del Nº de filas de la columna B No consigo modificarla y se pega desde el comienzo.  Podéis echarle un vistazo? La macro está en el ejemplo. ¡Muchísimas gracias!      ej_InputBox.xlsm
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy