Jump to content


  • Crear macros Excel

  • Posts

    • Hola 2 horas de proceso ufff me parece mucho tiempo... Si ese proceso te congela momentáneamente Excel, no te queda mas que usar una virtual   Saludos 
    • Hola El comportamiento de las funciones utilizando formato de tabla estructurada, cambia respecto a las referencias Una forma sencilla de superarlo es usar referencias relativas de esas celdas Mira =SUMAR.SI.CONJUNTO(J$7:J7,C$7:C7,$C7)   Saludos 
    • ¡Hola, @gogua! El tema de los rangos expandibles en tabla tienen un comportamiento "peculiar" cuando llegan al final de la misma.  Entonces, una opción para trabajar con ellos es "jugar" con las referencias estructuradas.  Tu fórmula, al tener un solo criterio, puede usarse con la función SUMAR.SI de la siguiente forma: =SUMAR.SI(C$7:[@CODIGO];[@CODIGO];J$7:[@[Ent./Sal.]]) ¡Pruébala y comentas! ¡Bendiciones!
    • Hola ,  A ver si soy capaz de explicarme.  Estoy intentando hacer un inventario "sencillo" para la gestión de EPIs y Vestuario Laboral de mi empresa.Más o menos tengo lo que necesito aunque poco a poco iré añadiendo cosas Una libro excel con 2 hojas (ARTICULOS  , ENTRADAS Y SALIDAS). En ARTICULOS introduzco los productos con un codigo maestro y me sirve para ver el stock actual de todos los productos. En ENTRADAS Y SALIDAS voy introduciendo los articulos utilizando el CODIGO de forma manual o utilizando la "lupa" que hay encima de la columna Ent./Sal. En la columna Existencia actual lo que pretendo es ven en cada momento , haya entrada o salida de artículo, como estába el inventario en ese momento (fecha). Para ello utilizo la formula.  =SUMAR.SI.CONJUNTO($J$7:J7;$C$7:C7;[@CODIGO]) y este código se replica en toda la columna de forma automática.   Pero me ocurre, que cuando inserto un nuevo registro, ya sea manual o con la lupa, esa formula me la cambia y me hace el sumatorio de toda la columna  para el CODIGO en concreto en la posición-fila anterior y ya no me va haciendo lo que pretendo, sino que me hace el inventario total.     Os dejo el fichero, que quizás se pueda ver mejor lo que quiero explicar y su funcionamiento.   gracias     Inventario_01 - copia.xlsm
    • buenas tardes,    tengo una macro que trabaja con datos, que los extrae de otras planillas y tablas web, cuando hago correr la macro, esta se demora aprox 2 horas en completar su proceso, lo que me imposibilita de trabajar en otras planillas existe alguna manera de abrir otro excel y poder utilizarlo a la par? tal vez con una maquina virtual o algo asi?   muchas gracias por su ayuda
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy