Jump to content

Sumar letras


Recommended Posts

Tengo en la columna  "C" lo siguiente, ver anexo, se requiere sumar las letras en forma individual, es decir cuántas "C", cuantas "T", cuántas "V". El resultado debería ser 19C, 21T, 4350V, esto mediante fórmulas ya que los macros no están permitidos. Gracias por la atención que le presten a mi problema.

 

Screenshot_20210128-184512~3.png

Link to comment
Share on other sites

  • 7 months later...

¡Hola a todos!

En primer lugar, parece que este tema lleva 7 meses de preguntado, por lo que no se si el consultante verá las respuestas que cada uno de ustedes ha posteado.

En segundo lugar, el consultante comenta explícitamente que las macros no son permitidas para la solución que se plantee... así que, a pesar que puede servir a modo de ejercicio @Janlui, no creo que sea adoptada tu respuesta.

Y, en tercer lugar, pues ya que estamos, demos otra opción con fórmulas matriciales del asunto.  ¡Bendiciones!

Nota: Mi separador decimal es la ",", por lo que añadí a la fórmula el sustituir la "," por nada para que no se tomara en cuenta como decimal.  Si es el caso del consultante en que el separador decimal es el ".", se puede omitir ese sustituir adicional.

SumaLetras.xlsx

Link to comment
Share on other sites

Hace 11 horas, John Jairo V dijo:

pues ya que estamos, demos otra opción con fórmulas matriciales del asunto.

Es una opción original e ingeniosa pero creo que difícil de comprender para un usuario que sepa fórmulas sencillas...

Adjunto otra opción con fórmulas desbordadas que puede que sea más fácil de comprender para un usuario que esté aprendiendo a formular, pues hay 3 pasos separados:

  1. Columna D : A cada valor se le añade 1> a la izquierda, se sustituye el primer + por 2> y el segundo + por 3>. De paso se quitan los signos , y . para convertir los valores en números. Todo ello con la función SUSTITUIR.
    ="1>"&SUSTITUIR(SUSTITUIR(SUSTITUIR(SUSTITUIR($C2;",";"");".";"");"+";"2>";1);"+";"3>";1)

     

  2. Columna E (desbordada hacia la derecha en las columnas F y G): Extrae los valores y letras de 1>, 2> y 3>. Todo ello con una versión matricial de la función EXTRAE, con la ayuda de la función ENCONTRAR.
    =SI.ERROR(SUSTITUIR(EXTRAE($D2;ENCONTRAR({"1>"\"2>"\"3>"};$D2);SI.ERROR(ENCONTRAR({"2>"\"3>"\"0>"};$D2);100)-ENCONTRAR({"1>"\"2>"\"3>"};$D2));{"1>"\"2>"\"3>"};"");"")

     

  3. Sumas de C, T y V: Suma las cantidades consumidas de cada letra con la función SUMAPRODUCTO.

Salu2,

Pedro Wave

Sumar Letras PW1.xlsx

Link to comment
Share on other sites

Hace 11 horas, John Jairo V dijo:

parece que este tema lleva 7 meses de preguntado

No debe importarnos que el usuario que abrió el tema no vuelva a consultarlo porque nuestras respuestas le llegaron demasiado tarde... Lo importante es poder ayudar a otros usuarios que tengan un problema similar en el futuro...

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

Privacy Policy