Jump to content

sumar si con formula matricial me da error


Recommended Posts

hola,tengo este archivo que adjunto donde al no encontrar el valor correspondiente del numero deseado toma el valor de otra columna;lo destaco en rojo en ambas hojas(nota de pedido y octubre)(es decir que al no estar cargado en octubre ese numero de pedido,me toma un valor "coincidente" de un importe de la columna anticipo

1ejemplo.xlsm

Link to post
Share on other sites

hola rubenwinner

sobre tu fórmula

=SUMA(SUMAR.SI(INDIRECTO(año & "!A:A"),A2,INDIRECTO(año & "!c:c")))

La primera parte busca el número de pedido, lo tienes en la columna A en todas las hojas, corrige por A:A

Una observación..  es necesario dar el rango de las cuchucientas mil filas que hay en la hoja excel?, sería mejor que des un rango prudente... por ejemplo, de unas 10,000 filas para empezar... , por ejemplo así:

SUMA(SUMAR.SI(INDIRECTO(año & "!A10:A10000"),A2,INDIRECTO(año & "!C10:C10000")))

 

saludos

Silvia

 

 

Link to post
Share on other sites

Hola a ambos! Es correcto lo que dice Silvia!

Por otro lado, en base a los datos que habías subido en tu consulta anterior, la fórmula de la columna B (fecha) te puede dar error si una misma orden de pedido se repite más de una vez, como pasa por ejemplo en el caso de esta imagen: imagen.thumb.png.f0660c4911527151baf00c6bd52e55d6.png

Esto es debido a que estás sumando fechas!

Saludos!

Link to post
Share on other sites

hola silvi y hola cristian;silvia,lo tuyo excelente y cristian,el ejemplo que subi el otro dia esta modificado,lo que sucedio(lo tuyo fue espectacular)pero mi compañero que esta usando esta planilla tiene una comput.muy vieja y se hacia muuuuy lento en esa maquina el "recalculo"con el boton,por eso busque esta 2da opcion;mil gracias a ambos,son unos genios;espero poder ayudar yo tambien asi a la gente del foro

Link to post
Share on other sites
a


×
×
  • Create New...

Important Information

Privacy Policy