Jump to content

Extraer parte de texto y renombrarlo


Recommended Posts

Saludos comunidad!!! Acudo a ustedes buscando una posible solución al siguiente problema. Necesito extraer o encontrar parte de un texto en una celda y que lo renombre.

Por ejemplo si en una celda puedo tener 3 variantes PERMISO DE ENTRADA o  PERMISO DE SALIDA o PERMISO DE RETRASO. Entonces si encuentra *ENT* que lo reemplaza por ENTRADA, Si encuentra *SAL* que lo reemplace por SALIDA y si encuentra *RET* que lo reemplace por RETRASO.

Para esto encontré una solución que es usar =SI(CONTAR.SI(B1;"*ent*");"Entrada";"") esto me trae solo una variante porque si en vez de ENTRADA dijera SALIDA ya no me trae la condición y al querer hacer un anidado =SI(CONTAR.SI(B2;"*ent*");"Entrada";"";(CONTAR.SI(B2;"*sal*");"Salida";"";(CONTAR.SI(B2;"*ret*");"Retraso";""))) me trae que no se puede aplicar la formula

les adjunto el ejemplo y desde ya agradezco la ayuda que me puedan brindar.

Eje Contar.Si.xlsx

Link to post
Share on other sites
En 4/6/2020 at 10:07 , John Jairo V dijo:

=BUSCAR(8^5;HALLAR({"ent";"sal";"ret"};B1);{"Entrada";"Salida";"Retraso"})

Hola John!! muchas gracias por la ayuda, funcino de maravillas. Me queda una duda para entender la formula... ¿por que se usa 8^5?

Link to post
Share on other sites

¡Hola, @Alejandro Z!

El 8^5 es mayor en una unidad a la máxima cantidad de caracteres que Excel permite en una celda, el cual es 32767.  Como el HALLAR da la posición numérica de un valor dentro de una celda, este número dentro de la función BUSCAR siempre debe ser mayor a donde lo encuentre.  ¡Bendiciones!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
a


×
×
  • Create New...

Important Information

Privacy Policy