Jump to content
Haplox

ANSWERED Automatizar fórmula para datos entre fechas

Recommended Posts

Qué tal a todos,

Pues eso, que como soy un zoquete con las fórmulas, necesito su ayuda...

Necesito calcular el número de registros entre dos fechas. Ahora uso la siguiente fórmula:

=CONTAR.SI.CONJUNTO(M5:M34;">="&FECHA(2019;10;1);M5:M34;"<"&FECHA(2019;11;1))

Esto me da la cantidad de registros entre Noviembre y Diciembre de 2019. Hasta aquí bien... ahora el problema es que eso lo necesito para, digamos, todos los meses del  2020 y no se me ocurre otra cosa que, para cada mes, modificar la fórmula a mano :blink:

Seguro que de la bola de cristal de los gurus sale algo... Gracias de antemano

Share this post


Link to post
Share on other sites

¡Hola, @Haplox!

Hace 3 horas, Haplox dijo:

... todos los meses del  2020 ...

No das muchos detalles, pero puedes intentar, entre varias opciones, con:

=CONTAR.SI.CONJUNTO(M$5:M$34;">="&FECHA(2020;FILAS(A$1:A1);1);M$5:M$34;"<"&FECHA(2020;1+FILAS(A$1:A1);1))

o, también:

=SUMAPRODUCTO(CONTAR.SI(M$5:M$34;">="&FECHA(2020;FILAS(A$1:A1)+{0;1};1));{1;-1})
=SUMAPRODUCTO(--(TEXTO(M$5:M$34;"yyymm")="2020"&TEXTO(FILAS(A$1:A1);"00"))

y copiar la fórmula hacia abajo tanto como lo necesites. ¡Bendiciones!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png