Jump to content
  • Debido a la crisis sanitaria, hasta el día 31 de marzo, el registro al foro de Ayuda Excel será totalmente gratuito para facilitar el teletrabajo. Todos los registros que se produzcan entre estas fechas tendrán acceso gratuito ilimitado a la comunidad hasta el 30 de abril.

    Regístrate

    Si te surge alguna duda mientras estás trabajando en casa con Excel, ya tienes a quien preguntar.

    Espero que esta medida te sirva de ayuda. Frenar la expansión del coronavirus depende de todos. Sé responsable.

ROVER1965

ANSWERED dejar celda alfanumerica solo con numeros

Recommended Posts

Hola he buscado por todoexcel mi problema y no lo veo o no entiendo las formulas, incluso e usado algunas parecidas a mi problema como extrae, limpiar, buscar y no me funcionan. Tengo celdas con letras a derecha e izquierda de los números y yo solo quiero que me queden los números, luego arrastro la formula por todas las celdas de la hoja que son miles, gracias.

DEJAR SOLO NUMEROS.xlsx

Share this post


Link to post
Share on other sites

¡Hola, @ROVER1965!

Puedes usar la siguiente fórmula:

=EXTRAE(A1;4;10) ' Si quieres el resultado como texto
=--EXTRAE(A1;4;10) ' Si quieres el resultado como número

Nota: Mi separador de argumentos es ";".  Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema.  ¡Bendiciones!

Share this post


Link to post
Share on other sites
En 29/12/2019 at 9:01 , johnmpl dijo:

¡Hola, @ROVER1965!

Puedes usar la siguiente fórmula:


=EXTRAE(A1;4;10) ' Si quieres el resultado como texto
=--EXTRAE(A1;4;10) ' Si quieres el resultado como número

Nota: Mi separador de argumentos es ";".  Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema.  ¡Bendiciones!

muchas  gracias, toda la mañana buscando por la web y nada, os lo pido a vosotros y en media hora ya lo tengo, me sirve para una columna, pero yo buscaba que sirviera para quitar cualquier letra dentro de una celda y que queden solo los numeros esten donde esten las letras y el guión-, tengo varias columnas que los datos que me dan son con letras en medio de numeros, o a los lados de los numeros, si hubiera uno general que me funcionara con todos los formatos que expongo, de todas formas muy agradecido, pedon por las mayusculas, escribo a distancia del portatil y las veo mejor. saludos.

Edited by johnmpl
quitar mayúsculas

Share this post


Link to post
Share on other sites

hola Rover1965  (y John 😉)

Esta fórmula de Elías Sailepaty, te puede servir

@sailepaty

=SUMA(EXTRAE(0&A15,K.ESIMO.MAYOR(ESNUMERO(--EXTRAE(A15,FILA($1:$50),1))*FILA($1:$50),FILA($1:$50))+1,1)*10^FILA($1:$50) /10)

* Mi separador de argumentos es la coma, si el tuyo es otro, corriges.

** si el texto es grande (mayor que 50 de largo), utiliza 100 en lugar de 50.

*** Es de  entrada Matricial, por lo que deberás dar entrada con Control+shift+Enter

saludos,

Silvia

 

Para John, un especial RPC.

 

 

 

 

Share this post


Link to post
Share on other sites

¡Hola, a ambos! (SIL... RPC de vuelta pa' ti)

Ya estaba redactando una posible respuesta, cuando Sil compartió una fórmula muy similar a la que yo iba a compartir.  De todas formas la pongo (igual, de entrada matricial).

=SUMA(EXTRAE(0&A1;1+K.ESIMO.MAYOR(FILA($1:$99)*(1-ESERR(-EXTRAE(A1;FILA($1:$99);1)));FILA($1:$99));1)*10^(FILA($1:$99)-1))

Tal y como lo comenta Sil, ese 99 (en mi fórmula) corresponde a la cantidad de caracteres posible que tenga la cadena alfanumérica.  Con esto, lo que quiero decir es que siempre debes colocar un número igual o mayor a la cantidad de caracteres de la cadena alfanumérica.

Si tienes Excel 2019, o Office 365, puedes usar (también de introducción matricial):

=UNIRCADENAS("";;SI.ERROR(--EXTRAE(A1;FILA($1:$99);1);""))

¡Bendiciones!

Share this post


Link to post
Share on other sites

¡Feliz año nuevo a todos!

Te dejo el archivo con esta UDF:

Public Function SOLO_NUMEROS(Texto As Range) As Variant
For x = 1 To Len(Texto)
   If IsNumeric(Mid(Texto, x, 1)) Then
      SOLO_NUMEROS = SOLO_NUMEROS & Mid(Texto, x, 1)
   End If
Next
End Function

 

DEJAR SOLO NUMEROS.xlsm

Share this post


Link to post
Share on other sites

Gracias a todos  por ayudarme y feliz nochevieja y año 2020, Antoni soy un pez frito para entender tu ayuda, no se ni si se escribe todo o es copiar y pegar. Gracias de todos modos, nos vemos en 2020 con mas preguntas sabiamente resueltas por ayudaexcel.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...

Important Information

Privacy Policy


CTA Templates.png