Jump to content
ROVER1965

ANSWERED dejar celda alfanumerica solo con numeros

Recommended Posts

Hola he buscado por todoexcel mi problema y no lo veo o no entiendo las formulas, incluso e usado algunas parecidas a mi problema como extrae, limpiar, buscar y no me funcionan. Tengo celdas con letras a derecha e izquierda de los números y yo solo quiero que me queden los números, luego arrastro la formula por todas las celdas de la hoja que son miles, gracias.

DEJAR SOLO NUMEROS.xlsx

Share this post


Link to post
Share on other sites

¡Hola, @ROVER1965!

Puedes usar la siguiente fórmula:

=EXTRAE(A1;4;10) ' Si quieres el resultado como texto
=--EXTRAE(A1;4;10) ' Si quieres el resultado como número

Nota: Mi separador de argumentos es ";".  Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema.  ¡Bendiciones!

Share this post


Link to post
Share on other sites
En 29/12/2019 at 9:01 , johnmpl dijo:

¡Hola, @ROVER1965!

Puedes usar la siguiente fórmula:


=EXTRAE(A1;4;10) ' Si quieres el resultado como texto
=--EXTRAE(A1;4;10) ' Si quieres el resultado como número

Nota: Mi separador de argumentos es ";".  Si no es el tuyo, cámbialo por "," o por el que maneje tu sistema.  ¡Bendiciones!

muchas  gracias, toda la mañana buscando por la web y nada, os lo pido a vosotros y en media hora ya lo tengo, me sirve para una columna, pero yo buscaba que sirviera para quitar cualquier letra dentro de una celda y que queden solo los numeros esten donde esten las letras y el guión-, tengo varias columnas que los datos que me dan son con letras en medio de numeros, o a los lados de los numeros, si hubiera uno general que me funcionara con todos los formatos que expongo, de todas formas muy agradecido, pedon por las mayusculas, escribo a distancia del portatil y las veo mejor. saludos.

Edited by johnmpl
quitar mayúsculas

Share this post


Link to post
Share on other sites

hola Rover1965  (y John 😉)

Esta fórmula de Elías Sailepaty, te puede servir

@sailepaty

=SUMA(EXTRAE(0&A15,K.ESIMO.MAYOR(ESNUMERO(--EXTRAE(A15,FILA($1:$50),1))*FILA($1:$50),FILA($1:$50))+1,1)*10^FILA($1:$50) /10)

* Mi separador de argumentos es la coma, si el tuyo es otro, corriges.

** si el texto es grande (mayor que 50 de largo), utiliza 100 en lugar de 50.

*** Es de  entrada Matricial, por lo que deberás dar entrada con Control+shift+Enter

saludos,

Silvia

 

Para John, un especial RPC.

 

 

 

 

Share this post


Link to post
Share on other sites

¡Hola, a ambos! (SIL... RPC de vuelta pa' ti)

Ya estaba redactando una posible respuesta, cuando Sil compartió una fórmula muy similar a la que yo iba a compartir.  De todas formas la pongo (igual, de entrada matricial).

=SUMA(EXTRAE(0&A1;1+K.ESIMO.MAYOR(FILA($1:$99)*(1-ESERR(-EXTRAE(A1;FILA($1:$99);1)));FILA($1:$99));1)*10^(FILA($1:$99)-1))

Tal y como lo comenta Sil, ese 99 (en mi fórmula) corresponde a la cantidad de caracteres posible que tenga la cadena alfanumérica.  Con esto, lo que quiero decir es que siempre debes colocar un número igual o mayor a la cantidad de caracteres de la cadena alfanumérica.

Si tienes Excel 2019, o Office 365, puedes usar (también de introducción matricial):

=UNIRCADENAS("";;SI.ERROR(--EXTRAE(A1;FILA($1:$99);1);""))

¡Bendiciones!

Share this post


Link to post
Share on other sites

¡Feliz año nuevo a todos!

Te dejo el archivo con esta UDF:

Public Function SOLO_NUMEROS(Texto As Range) As Variant
For x = 1 To Len(Texto)
   If IsNumeric(Mid(Texto, x, 1)) Then
      SOLO_NUMEROS = SOLO_NUMEROS & Mid(Texto, x, 1)
   End If
Next
End Function

 

DEJAR SOLO NUMEROS.xlsm

Share this post


Link to post
Share on other sites

Gracias a todos  por ayudarme y feliz nochevieja y año 2020, Antoni soy un pez frito para entender tu ayuda, no se ni si se escribe todo o es copiar y pegar. Gracias de todos modos, nos vemos en 2020 con mas preguntas sabiamente resueltas por ayudaexcel.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

INFORMACIÓN BÁSICA SOBRE PROTECCIÓN DE DATOS

Responsable: Sergio Andrés Celemín

Finalidad: Moderar y responder comentarios de usuarios. Recuerda que la información que facilites es pública, y los datos que incluyas los leerá cualquier visitante de esta web, así como el avatar que poseas.

Legitimación: Consentimiento del interesado.

Destinatarios: Hetzner Online GmbH.

Derechos: Puedes ejercitar en cualquier momento tus derechos de acceso,
rectificación, supresión, oposición y demás derechos legalmente establecidos a
través del email sergio@ayudaexcel.com.

Información adicional: Encontrarás más información en la política de privacidad.




  • Posts

    • Mauricio_ODN te agradezco la colaboración de verdad, la idea que pones en si, sí funciona, pero eso me obligaría a utilizar hojas y celdas y no es lo que quiero, es solo que lo que yo necesito hacer es que el proceso se realice dentro del textbox o a nivel de código y no en la lectura dentro de la hoja, es decir; sin utilizar celdas ni hojas, si no que se haga dentro del textbox el proceso de "reconocimiento" del texto como tal, no se si me doy a explicar. ¿Podrias ayudarme una vez mas con eso, mi estimado experto?. Gracias de antemano  
    • Hola @Marcelo Una vía rápida es reemplazar: Donde en buscar colocas un espacio y en reemplazar no colocas nada. Nos comentas.  
    • Buenas tardes tierra_pampa, Gracias por conestarme. Si es diferente el documento ya que no lo voy  a utilizar solo yo. Ahora si, me di cuenta del error que habia. Datos guardados 2 veces. Que tengas un buen día y suerte en el trabajo. Nos mantendremos en contacto. Saludos,
    • Hola @joselica Creí que no iba a tener tiempo antes de salir al trabajo, pero siempre hay que intentarlo...jajaja Aquí te dejo un nuevo archivo modificado en sus registros duplicados (hice una copia de la hoja y dejé la hoja original con los errores señalados para que puedas ver cual pudo ser el error al cargar) Por favor, revisa y comenta tus impresiones. Suerte!   ae20200707_post43704_LISTADO DESAYUNOSv4.xlsm
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy