Jump to content

Ayuda con Función SI.CONJUNTO


ShinigamiKinomoto

Recommended Posts

Buen día,

Estoy realizando un reporte con unas tablas, en este quiero realizar lo siguiente:

-Contar los valores que son diferentes y que además sean diferentes a vacaciones (que no cuente la palabra vacaciones)

La consulta que tengo estesta:

=SUMA(CONTAR.SI(1/CONTAR.SI.CONJUNTO((Tabla269808998107116125142[CLIENTE],Tabla269808998107116125142[CLIENTE], Tabla269808998107116125142[CLIENTE],"<>VACACIONES"))))

En esta estoy jalando los datos de una hoja diferente de la tabla clientes, normalmente sirve solo con la función =SUMA(1/CONTAR.SI(Tabla269808998107[CLIENTE],Tabla269808998107[CLIENTE])) pero al agregarle la otra conción me manda error.

 

Les agradeceria mucho su apoyo.

Link to post
Share on other sites
Hace 3 minutos , Luis paz dijo:

En realidad no te entiendo muy bien, no sé si es esto lo que necesitas:

=CONTAR.SI.CONJUNTO(Tabla2[CLIENTE],"<>VACACIONES")

Esta función da el total de los clientes que son diferentes a vacaciones, lo que necesito es que además de eso de los clientes diferentes, como ves en la tabla se repite Toyota, por lo que el resultado debe de ser 4 y no 5.

Link to post
Share on other sites
Hace 59 minutos , Silvia dijo:

Hola Silvia, tengo una duda en tu formula:

 

=CONTAR(1/FRECUENCIA(SI(Tabla2[CLIENTE]<>"Vacaciones",COINCIDIR(Tabla2[CLIENTE],Tabla2[CLIENTE],0)),FILA(Tabla2[FECHA])-FILA(Tabla2[[#Encabezados],[FECHA]])))

 

la parte #Encabezados a que parte de la tabla corresponde?

Link to post
Share on other sites
Hace 3 minutos , ShinigamiKinomoto dijo:

la parte #Encabezados a que parte de la tabla corresponde?

-FILA(Tabla2[[#Encabezados],[FECHA]])

toda esa parte corresponde a la celda A4, puedes reemplazar por Fila(A4), o simplemente por 4, ya que los datos de la hoja1 empiezan en 5, se restan 4 filas para empezar de 1.

saludos,

Silvia

 

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Guest
This topic is now closed to further replies.
  • Crear macros Excel

  • Posts

    • Private Sub CommandButton1_Click() saltos = Len(TextBox1.Value) - Len(Application.WorksheetFunction.Substitute(TextBox1.Value, Chr(10), "")) texto = TextBox1.Value For i = 1 To saltos Hoja2.Cells(i, 1) = Mid(texto, 1, InStr(1, texto, Chr(10)) - 2) texto = Application.WorksheetFunction.Substitute(texto, Mid(texto, 1, InStr(1, texto, Chr(10))), "", 1) Next Hoja2.Cells(i, 1) = texto End Sub Private Sub UserForm_Activate() TextBox1.Text = Sheets("Hoja1").Range("a1").Value End Sub  
    • Es un error de datos, sin el archivo es imposible decirte nada más.
    • Abre el adjunto, selecciona la Cía por la que quieres empezar y pulsa la flecha azul. Asignar código.xlsm
    • Hola, Tengo un excel con una bbdd de entradas de ocupación de aulas. El programa consiste en lo siguiente: En la hoja "Asignaciones" es donde se introducen manualmente los registros de ocupación, en la hoja "bbdd" es donde se encuentran la lista de profesores y la lista de aulas, y por último la hora "EJEMPLO" que es donde se realizan las consultas de disponibilidad con 2 campos como criterios, "AULA" O "PROFESOR". He añadido una hoja "GENERAL" en la que mi objetivo es que aparezca una vista de todas las asignaciones en el mes en curso, según aula y día, y según sea por la mañana o por la tarde.   ¿Alguien podría echarme un cable? Muchas gracias de antemano. Calendario_aulas_2021.xlsb
    • Hola estimados amigos de ayuda excel quisiera pedirles de favor me ayuden con el siguiente problema: Tengo en la celda a1 de la hoja 1 un texto que puede ser mas largo eso no importa, he colocado un botón con un código que al presionar separa el texto en varias líneas pero el problema es que sustituye el contenido de la celda a1 de la hoja 1, me interesaría que la celda a1 de la hoja 1 quede intacta con la información que se muestra inicialmente y más bien que al presionar el botón del formulario se pueda copiar el contenido a la hoja 2 ahí si me interesa que se separe en líneas como actualmente lo hace, el código trabaja, pero, lo que quiero es que NO sustituya el código de la hoja1 esta información debe mantenerse ya que en el programa que trabajo actualmente se extrae esta información a un formulario, todo este texto, y ustedes comprenderán que al separarse me va a leer solo la primera linea y eso es lo que no quiero, por el contrario el texto separado en lineas necesito que vaya a la hoja2 ya que posteriormente colocare un botón para poder imprimir esa información separada en lineas considerando un rango determinado de celdas que podrian ser desde la a1:a20 , les adjunto el ejemplo para que por favor me colaboren...muchas gracias. Ayuda Copiar texto en Hoja 2.xlsm
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Privacy Policy