Jump to content
Kalima

Ayuda con una formula

Recommended Posts

Hola en esta ocasión tengo una duda que no logro aclararme, me intentare explicar lo mejor que pueda.

 La idea es que al seleccionar el año y la categoría, me da como resultado un salario, hasta ahí bien. 

Ahora quiero que al seleccionar si es media jornada o jornada completa , me ponga el salario que corresponde, que sería la mitad más o menos.

 

Muchas gracias de antemano

Libro1.xlsx

Share this post


Link to post
Share on other sites

Hola:

Se me ocurre así:

=SI(E4<>"completa",SUMAPRODUCTO((H3:I3=C4)*(G4:G5=C2)*H4:I5)/2,SUMAPRODUCTO((H3:I3=C4)*(G4:G5=C2)*H4:I5))

Mi separador de argumentos es la "," cámbialo si utilizas otro

Saludos..

 

 

 

 

 

Share this post


Link to post
Share on other sites

Muchas gracias Snake por la respuesta, tal cual esta funciona pero al pasarlo a la plantilla original no consigo que funcione bien. La verdad es que la plantilla principal es un poco mas completa, estoy intentando subirla pero pesa 2,40mb  y no consigo que me baje de ahí. 

cuando lo consiga la subo para que la puedas ver mejor.

 

Un saludo y muchas gracias.

Share this post


Link to post
Share on other sites

A ver si me podéis ayudar con la siguiente formula:

=SI(E6="Inspector";BUSCARV(I2;'Tablas Salariales'!B15:D21;2;0);BUSCARV(I2;'Tablas Salariales'!B4:F10;2;0))

basandonos en esa formula, quiero añadirle que si en la celda L6 pone "Media Jornada", la casilla I11 me lo divida por 2

 

Gracias y un saludo desde Canarias

 

Share this post


Link to post
Share on other sites

Hola, segun la formula que tienes puedes añadirle otro Si.

=SI(E6="Media Jornada";SI(E6="Inspector";BUSCARV(I2;Datos!B15:J22;2;0);BUSCARV(I2;Datos!B4:I11;2;0))/2;SI(E6="Inspector";BUSCARV(I2;Datos!B15:J22;2;0);BUSCARV(I2;Datos!B4:I11;2;0)))

 

Saludos.

Share this post


Link to post
Share on other sites

Perfecto Toldeman me ha funcionado, muchas gracias. Lo tenia en mis narices y era capaz de verlo...jajajjaa

 

Un saludo desde Canarias

Share this post


Link to post
Share on other sites



×
×
  • Create New...

Important Information

Privacy Policy