Jump to content
JSDJSD

ANSWERED Formula que se me resiste

Recommended Posts

Mi intención sería que tal cual se encuentran los datos, en la celda K2 muestre la valoración que se repita más veces teniendo en cuenta lo que tenemos     en la celda I3 y J3 que en este caso es  Alumno 1  Asignatura1, el resultado que se espera es Buena.

En el caso de que elijamos Alumno 2 y Asignatura2 el resultado sería Mala.

La formula que uso es          =INDICE(D3:D11;MODA.UNO(SI(Y(C3:C11=J3;B3:B11=I3);COINCIDIR(D3:D11;D3:D11;0))))
se que me estoy equivocando pero no se donde.

Formula.xlsx

Share this post


Link to post
Share on other sites

¡Hola, @JSDJSD!

El problema, puntualmente, está en el uso de la función Y.  Puedes usar su forma booleana, la cual corresponde a la multiplicación, o hacer un doble SI, preguntando por cada condición.

Entonces, la fórmula podría quedar así (no olvides el CSE : Ctrl + Shift + Enter) :

=INDICE(D3:D11;MODA(SI((B3:B11=I3)*(C3:C11=J3);COINCIDIR(D3:D11;D3:D11;))))
=INDICE(D3:D11;MODA(SI(B3:B11=I3;SI(C3:C11=J3;COINCIDIR(D3:D11;D3:D11;)))))

¡Bendiciones!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.



×
×
  • Create New...

Important Information

Privacy Policy